English

Investing in long-lasting design: Android 7 for the Fairphone 2

osupdates
blog
Tags: #<Tag:0x00007f9ffa303738> #<Tag:0x00007f9ffa302a18>

#63

Thanks!! That’s what I missed :wink:


#64

Thanks for your answer. But I’ve already tried that. When booting directly into TWRP after the update through TWRP, I get the new version. Then I boot the system, and the next time I’m back to TWRP, I get back to 3.1.1. It’s not a major issue, as backups are possible, but I was just wondering, whether there was someting I was missing out on…


#65

That’s odd, several users have updated TWRP successfully already.
When the new TWRP started, did you “Swipe to Allow Modifications”?


#66

I installed the update the day before yesterday and lost all my data of the internal storage :frowning:
I had FP open installed, the new cameras in and the internal storage encrypted.
When it restarted I entered my PIN and the phone said it was wrong, then I entered it again and it stated that the PIN is correct but the data is corrupted and left me no other option as to reset everything.
I did not bother to backup everything before but have many things synced in some way so this was not too bad, the only thing I definitely lost is my Threema Account because the password I stored in my password manager for the Threema Backup seems to be wrong :frowning:
I was surprised how quickly the update worked but on the other hand I spent several hours to restore all the settings, apps, accounts and data.


#67

Open Android updated and no problem with shutting the device down. Install very smooth, thanks for the nice work


#68

Hi!

I had serious problems, had to go back to FP Open 18.04.1
Phone was on FP Open 18.04.1, rooted and encrypted, using twrp recovery.
After installing 18.10.1, I had trouble with some apps using root access. ViPER4Android FX (2.5.0.5) would not recognize the root access, my CyanogenMod file manager (version 3.0.0) crashed when trying to open the general settings menu to check the root access.

I had no problems with the torchlight, and was able to install the current version of the Xposed framework (89).

/system/app mover did not work though; an error message told me that it was not able to remount /system.

After a few attempts to reinstall Viper via twrp, the phone crashed, and I wasn’t able to restart the system; it only rebooted into recovery. Since I could not reinstall some twrp backups I had made when switching to FP Open, I had to manually reinstall the last stable Open 18.04 version…
Fortunately I didn’t loose any data, just a few hours to get everything back in place…

I’ll probably wait a bit before trying again.:disappointed:


#69

Another happy camper here. Updated to FP Open 18.10.0 (no GAPPS) and everything went smooth. A few new touches in the UI, but everything else really stayed quite the same. All of my applications that I tested still work, no loss of data, no trouble shutting down or rebooting (old camera module). The occasional spontaneous reboots are still there (never bothered me much), the occasional connectivity issues as well. Battery life looks similar to Android 6…

From the little I have seen so far, my FP2 really seems to have remained very much its own self: a little quirky and otherwise simple and solid.


#70

Hm, I think this only showed up the first time I launched TWRP. And then yes, I did “swipe to allow modifications”.


#71

My device with FPOOS and new camera modules can also shut down only when the torch is turned on.

But the upgrade went smoothly and all other seem to run well yet. So thank you Fairphone for your great work!


#72

I am under the impression it is mainly FPOOS users that got the update, at least based on the report of forumers. Not so random after all?


#73

Thank you for the upgrade I believe this is very good for the image of Fairphone. However, the Decision by management NOT to include the switching off of a SIM card is in my view a deterioration of one of the features of Fair Phone 2 and the new Nougat (7 - OS 18.09.2)software. You can still use 2 SIM cards no issue there but in the previous software version of Android (6.0.1) one could switch one off. Especially if you want to switch of your work SIM over the weekend or switch of the SIM you use on other continents is no longer possible in the updated version. So be aware if you need this feature to not to update to the new version. Just a warning to inform others….Thank you.


#74

Not much of a decision … the feature is just not there in Android 7 by default, and it is uncertain whether Fairphone will be able to add it themselves.

https://bugtracker.fairphone.com/project/fairphone-android-7/issue/55

“Regarding disabling SIMs: This option is indeed not available on Android 7. Currently we cannot say if we will be able to bring back to feature, but for sure it will not be included in the first official Android 7 release for Fairphone 2.”


#75

I guess a fairly high number of (active) forum members are FPOOS users, compared to the general non-forum FP-users :slight_smile:


#76

Hi Francois,

I asked Fairphone to prioritise my Android update as there is not much time left on my warranty and I wanted to see the phone work well before my warranty expires. I have found the battery drain to be really bad, and have not found an effective answer whilst Fairphone have promised battery improvement via Android 7 for quite some time now.

Fairphone sent me a generic response, they didn’t help prioritise my download.

I found a shortcut to the update to Android 7 by accident. The Updater told me I was up to date on Android 6 as I was awaiting the Android 7 update.

I tapped on the ‘Fairphone OS’ text on the Updater app and noticed a ‘click’ sound. I tapped several times and the phone put me in developer mode and offered the Android 7 update. The installation went smoothly, and yesterday my battery and phone performed much better!

For those of you whose warranty is about to expire, this shortcut could expedite the update process.


:de: Kein Android 7 Update mehr angeboten?
FP2 stuck with 18.04.1 version
Dreem sleep application - bluetooth
#77

Indeed, just tried it, and also got the update!
Edit: the update is actually 18.09.02, not the latest 18.10. Since it was still beta testing in September, not sure how stable this version is…


#78

Got a completely new FP2, installed FP Open immediately (v18.04.1 from the ‘Installation Guide’), installed F-Droid (which didn’t work - seemed to have no data-connection), installed the Update to 18.10 with fp2-sibon-18.10.0-manual.zip from ‘Download Releases’.
-> Phone only shuts down with the torch on - otherwise it reboots …


#79

Dear FP community,

as already asked in this question on mouse-functionality in Android 6, I would like to know, whether the FP2 can still be operated with a mouse after the Android 7 update. I don’t dare to update, before I can be sure that Android 7 on FP2 supports this mouse-functionality. :wheelchair: :computer_mouse:

To check, whether mouse-functionality is integrated in your FP2, you just have to connect a usual mouse via a USB-to-Micro-USB-adapted to the fairphone’s micro-USB-port. Then, either a mouse cursor appears on the screen and can be controlled via the mouse (in this case mouse-functionality is available) or nothing happens (in this case mouse-functionality is not included in Android 7).

It would be great if either the developers or some fairphone-users could give me feedback concerning the above stated question!


#80

Hi Tuvok, if Google didn’t remove the feature then it should still be present. If it’s not working, you can create a bug in the bug tracker and the next update might solve it :slight_smile:


#81

@Tuvok is dependent on mouse functionality and can’t operate the phone if the feature breaks, hence the need to really know for certain :wink: .

I can only confirm it works in LineageOS 15.1 for microG (Android 8.1).


#82

Hi Francois

I thought the same as you, however the article linked below describes 18.09.2 as the Android 7.1.2 release:

https://support.fairphone.com/hc/en-us/articles/208342503-Fairphone-OS-for-Fairphone-2-Release-Notes

I think version 18.10 is the Open Source alternative.

Cheers