English

Investing in long-lasting design: Android 7 for the Fairphone 2

osupdates
blog
Tags: #<Tag:0x00007f9ff8cf2cc8> #<Tag:0x00007f9ff8cf2840>

#43

srlive thanks! updating TWRP worked fine and is easy.


#44

Same on my side (I open a separate topic)


#45

:open_mouth:
That’s a new one.
Luckily it seems I have to wait some more time.
So I can wait a little longer, while the early adopters take the burden to discover and solve all the flaws that escaped even the long and intense beta-testing-phase. :wink:

Just kidding (mostly)!


#46

Nice, I’ll take a look this night on how to update. (I had to go this morning thus leaving you the information as I was leaving after the search)


#47

Thanks for the klarification :wink:
I think I prefer the real Firefox/Fennec browser for normal web browsing because I can have plugins like uBlock, first party isolation, etc.
I suppose the system webkit is still part of Android though, right? This is the thing that would be used for, e.g., the captive portal login (the thing that gets you through the login pages when you connect to some open wifis) and many apps use that too. And that would still need to be maintained and updated in order to keep it secure, etc. Would that happen via normal FP OS updates, or do I have to care for this myself, e.g. via https://www.bromite.org/system_web_view ?


#48

Upgraded to FP Open 18.10.10 just nu. Shutdown just reboots the phone! Don’t know what info you need but new camera modules, SD card and encryption. With the flashlight on it shuts down as expected.


#49

Thanks everyone for responding to my question. It clearly seems that the shutdown bug is still there.


#50

Recently Upgraded to FP Open 18.10.0: Worked just fine and Shutdown works out of the box. (without flashlight workaround). I have old camera module.

There is a trick for installing the Xposed Module: Update TWRP to version 3.2.3-0. Otherwise there is an zip verification error (also with unchecked verification).

Because there is no manual update file out now, I have downloaded it per Fairphone Updater and after selecting “Install” the update would be installed within TWRP. After affirming the question to Reboot I have interrupted the Boot sequence with long holding down power and volume up button until reboot into TWRP.
If you do not want to interrupt the boot sequence you can also fetch the manual update file from internal card /Android/data/com.fairphone.updater/files before selecting “Install” and then leave Fairphone Updater to make your update manually.


#51

Hi. I have update my phone with FP Open 18.10 and everything went fine until now. I have just had two red messages “Command unknown” during the update, but nothing more. I have not lost any data (photos or messages…). I would like to thank the Fairphone team for this great update !


#52

Actually I don’t know. Someone more invested in Fairphone Open OS would need to step in here.


#53

Same here, FP open, encrypted, new camera, everything looks good on the first glance.


#54

I updated to TWRP 3.2.3 before, just in case and then just updated Fairphone Open OS to 18.10. No issues so far. Encryption still works. Contacts and photos are still there. Wonderful!

UPDATE: Shutdown reboots here as well.


#55

After 24 hours, I just realize that UnifiedNLP (with mozilla backend and nominatim), which was perfectly working on android 6, doesn’t register in the system anymore with android 7.1 (FP Open OS).

Can’t find anything about it… did I missed something?


#56

I did the same, but TWRP keeps downgrading to version 3.1.1 when I boot the system normally, then boot it again in TWRP. I had the same problem with the old FPOOs. But now at least, the version it gets back to, is a version that lets you do backups from an encrypted phone.
Does your phone stay with version 3.2.3?


#57

Intersting topic and interestin workaround.
I had the following: updated FPOOS (new camera module)
1st time shutting down my phone: reboots immediately
2nd time: shutdown with flashlight on: phone stays off
3rd time: shutdown when charging: phone stays off
4th time: shutdown when charging (very low battery level, around 5 percent): phone reboots immediately
So there’s no clear pattern yet, I’ll keep an eye on the topic.


#58

After you flash the new TWRP, directly reboot into TWRP to let it make itself resident, don’t directly boot the OS as this way (as you found out) the OS restores its own recovery.


#59

Hello,

No luck for me since version 18.02.1 the updater is not working properly so here I am like you one of the choosen to upgrade to Android 7 with an updater down. The unsolved problem is that when I click on the available 18.10.0 upgrade page in the updater nothing happens.


#60

Congrats on getting there :slight_smile: The post makes it really clear why this is important. Looking forward to the update :slight_smile:


#61

This is a known issue, still in progress: https://bugtracker.fairphone.com/project/fairphone-android-7/issue/33


UnifiedNlp localization don't work anymore (Open 18.10)
#62

Are you on Wifi (i.e. not mobile data)? (Updates only download on wifi)
If you’re using regular Fairphone OS, is the google play store working normally? (the updater itself is updated via play services)
Is the ‘download manager’ app enabled and can it connect to the internet (i.e. check your firewall if you have one)? (the updater uses download manager to download updates)
Have you already tried to clear app data for the updater app?