English

Investing in long-lasting design: Android 7 for the Fairphone 2

osupdates
blog
Tags: #<Tag:0x00007f9ffc4b3748> #<Tag:0x00007f9ffc4b34f0>

#23

nice. I saw the announcement, checked the updater. it said new OS available, now updated:


#24

What doesn’t work? Starting TWRP or starting to install Open GApps?

To boot into TWRP, keep Volume Up pressed while starting or rebooting the phone until you see TWRP.


#25

The updater offered it after rebooting my phone sometime today.


#26

Oh oh … Fairphone support staff and the community forum better brace for torches and pitchforks :fire::man_farmer::woman_farmer::man_farmer::woman_farmer::fire: :wink:


#27

Thanks, I am in TWRP again now. Has that changed or am I oblivious?

However, the opengapps pack appears not to work right now. ZIP signature failed. Anything I need to do differently than before?


#28

You need to disable signature verification. :wink:


#29

Tried. Didn’t work unfortunately


#30

The OpenGApps package needed should now be ARM - 7.1 … but I would have gone with @paulakreuzer’s hint to disable the signature verification in TWRP. I don’t know how that can go wrong.


#31

Doesn’t seem to work. Still the failed verification let’s the install stop, even when unticked


#32

Updated to FP Open without problems (FP2 with old camera module, encrypted phone, SD card is internal memory). Shutdown works without any workaround.
I’m so glad the waiting is finally over :slight_smile:


#33

Update went smooth, but I can neither shutdown with nor without the flashlight turned on before. :sweat_smile:


#34

Successfully installed FPOOS 18.10.0
Successfull shutdown done, but needed the flashlight-workaround…


#35

Yay, I am one of the random ones!

Could someone please point me in the direction of the guide with the flashlight? I am on a three month trip through south east asia at the moment and I have no PC I could use to back up / NAND everything or get ADB access to my phone in case it gets inaccessible during or after the update process.


#36

You don’t have to update. Why not wait till you are home again?


#37

Honestly, because I’m curious. But on the other hand, curiosity killed the cat, didn’t it?


#38

There’s no guide needed. Just turn the flashlight on before shutting down the device. This can be done using the torch icon. It’s only needed if the “new camera module” is installed in the device.


#39

Same problem for me. I’m using opgapp pico, selected the mew android version (7.1), architecture is still arm. I tried several package checking and unchecking the zip signature verification features and twrp keep telling the signature failed and stop…

Anyone found a workaround for this?


#40

Thanks Lord i am not alone. At the moment I don’t see a solution. I even tried a factory reset erasing everything (starting fresh with Android 7 was intended anyways) however now I don’t have access to some google and play store apps at all.


#41

After some research, I think it might be a twrp version problem but I have no time to update it right now. I’ll try it later in the week.


#42

Update worked flawlessly on FPOOS, but I also have the shutdown problem (actually I don’t care because I never shut down the mobile, I only set it to flight mode).
I noticed that the Widget with the Web links disappeared, and the live background I had.