Insufficient storage

Hi there,

There have been many posts about the error 'insufficient space on the device" when trying to install an app, even when there is sufficient storage.

I messaged about this some time ago, and was advised to reset my phone and upgrade to the latest software with the partition. I little while ago I reset my phone and upgraded to 1.8. I also bought a 64GB SD card.

Despite all of this, I still cannot save apps either to the phone storage - with 12GB left - or to the SD card - with 60GB left. Right now I’m trying to install an app that’s just 42MB but won’t install.

This has been rumbling on for many months now, with many users posting to the forum and Fairphone repeatedly assuring users that they have fixed the problem. It’s really frustrating for this still to be an issue after so long, especially when I purchased a large SD card and can’t store apps to it.

Can you please advise what we’re supposed to do? It’s gone on for far too long now and needs to be resolved.


Could you please link to the topics, which are already discussing this issue, so we can make ourselfes a wider picture of the troubleshooting process? Thanks! :blush:

Did you also do the partition upgrade before updating to 1.8? I think that’s the update you need!


of you open “settings->storage” have you set the verry top option to SD-Card?


Hi Shiny,

Yes, I have that selected. But it either doesn’t try to save to the SD card or it somehow reads the memory as full. I have things saved to the SD card which I can view, so the card is working fine.


Hi Daniel,

I did - as far as I remember. Is there a way to check, do you know?

There are more, but it says that new users can only put 2 new links in a post

Yeah, I keep forgetting that, sorry! :blush:

Check this page from the interactive tutorials. Does it say “Total space: 13,37GB”?


the following text based on observation so maybe I’m wrong. But as much as I see, there is still a 650 MB System Partition on your phone mounted to “/system”. In “/system/app” you will find an APK for every installed App.

In general sys APKs are small, because the Apps will store there Data on an other partition. So this shouldn’t be a problem. But I have notified, that some Apps of special sourced, in my case the Humble Bundle Store, will include all data to the APK in “/system/app”. I have rebought some games in an Humble Bundle witch I already owned from the Play Store. If I install the very same game once from the play store once from the hunble store the first time I find a small APK at “/system/app” and a big Data Folder somewhere at “/mnt/sdcard/Android” (on my internal storage) and in the second case I will just find one big APK at “/system/app”.

So if you maybe have installed many apps from an “unfortunate” source your “/system” partition might be full. You can check this with a tool like Diskinfo.

But as I said, I might be wrong, because I just tryed to put two and two together based on some observation I made on my Fairphone 1U.


Hi there,
I’ve got the same issue and would be so grateful for a solution. I’ve basically deleted most of my apps in order to keep the few I want to have updated. Great way to declutter your phone!

The downside is, I hardly use my phone anymore, 'cos all the calendars, emails and browsers can’t fit in. I so wanted this Fairphone to work!

@Katja: If you have a FP1 (not a FP1U from the 2nd batch), have you done the Unified storage upgrade?


I too have frequent insufficient storage problems. I currently use Cherry 1.6 without having yet installed the 1.6 storage upgrader. Should I wait for the revamped (and most hopefully thoroughly tested) 1.8.x update to get rid of my storage problems or do I anyway have to run the 1.6 storage upgrader beforehand independently? More precisely asked: will 1.8.x do anything about insufficient storage or is this uniquely being solved by the 1.6 storage upgrader?

It is uniquely solved in the storage upgrader. As far as I know, you won’t be able to run the storage upgrade on 1.8, so you have to run it, when still on 1.6.

1 Like

there is another workaround: uninstall updates of google apps. This frees up a lot of space on the internal partition. Of course that makes only sense when you don’t use google apps.

the only google apps I’m using are:

  • play
  • youtube
  • maps

so I’m installing updates for them, but not for the others. That improved the situation a lot for me, without installing the unified memory upgrade.

Hi, I also have “insufficient storage problems” since i manually updated my phone to 1.8.5 with this manual here using the “FP1U - Mid-2014 (2nd batch) & FP1 with unified storage” File. The “FP1 old partition layout - Late 2013 / Early 2014 (1st batch)” did not work for my phone.

After restart everything updated via the play store except the apps “Google”, “Maps” and “Google My Business”. Insufficient Storage Errors all the time.

In step 9 of this manual is mentioned that there should be a “Storage Upgrade” within the Fairphone Updater App but i don’t have this button…

In Step 18 of the same manual is mentioned that you should have one big storage showed in the settings > storage area but on my phone there are 2 storages shown. Internal and SD. Which means i don’t have a a storage upgrade made yet or am i wrong???

How can i fix this?

This is strange, since you mention that you still have the old partition layout. Try to run the “Storage_Upgrader_1_8_5” file from here manually.

1 Like

Did i mention that the file “Storage_Upgrader_1_8_5” aborted too when i wanted to update manually before i used the “FP1U_KolaNut_v1_8_5_OTA”

Do you think that it’ll work now?

I think it’s normal that the storage upgrade aborts before you update to 1.8.5

So yes, now it should work.

Just tried it!

“Installation aborted” :frowning:

Please try the version with the old partition layout again, but this time first go to Settings > Developer Settings and tick “Keep Active” (Display doesn’t go to Standby).