Insufficient storage error even after partition upgrade for FP1

I have installed the 1.6 software update and partition upgrade for my FP1.
It all seemed to go smoothly and my storage now shows as one drive, Internal Storage with 11GB free and 2.2GB used. I reinstalled Google Apps and restored some of my apps with Titanium Backup.

However I can’t install updates for apps from Play Store or restore the rest of my apps from Titanium Backup, as I am still getting an insufficient storage error messages, even though most of the memory is empty!

Any ideas?

1 Like

Hi, I’m dealing with the same problem! Is this another bug or would anyone know how to solve it? Any tips would be highly appreciated!

Mmmhh intriguing!

May be worth trying a hard reset to see if you can clear the problem this way.

Another potential option to try first is to wipe the cache partition from the recovery mode screen (details are also in the hard reset post)

Sorry I didn’t read MBO’s post carefully enough before replying. I do also have the insufficient storage problem despite sufficient space, however, I did not install the partition upgrade exactly because I didn’t want to wipe all my data. Wiping the cache partition isn’t helping unfortunately. Could anyone think of a solution that doesn’t involve a hard reset? Thanks so much!

@Sanne - The only other method is to move some of your apps onto SD card or to remove apps that you infrequently use. I would recommend the storage upgrade though as this way your problem should be fixed forever. Just backup you data before hand and hey presto.

Same problem here! Getting an error that there is insufficient storage available (after the storage upgrade). Hard reset didn’t work. Problem is still here. 2 GB in use, 11 GB free.

It seems that this problem only occurs for encrypted apps.

@dib0 @MBO

I have flagged this issue to the support team, but in the meanwhile can you raise a support ticket for yourself by going to the support pages and clicking “send us your question”

Same problem here (still 7 GB free memory). And I didnt do the partition stuff since I am not so much into that technical issues and know how to do backup all my files.
But are there any solutions so far??

@oekomi I can see you have raised a new topic so will respond there as your issue is separate to this topic.

For me I experience this issue after upgrading to unified storage and restore data with titanium backup. How did you restore?

Same problem here. The problem has to do with the new version of Google play store. If I go back to the old version of play store, I can download apps etc. But it goes b back to the new version all the time, so the problem occurs again.

About the reset’ sorry’ I’m not going to do that for several reasons.

I tried to follow the instructions for this problem: Software update v1.6 log - August 2014.

Step 3 Click on the Fairphone OS button I cannot fulfill. I already switched off wifi connection and even rebooted the system, but still no success.

What I saw is that my phone gave a notification that the link of this button is incorrect.

Riet de Vlieger

Just to follow up: I wiped the whole thing and did the partition upgrade and it seems to be solved now (although the messages about this happening again after the upgrade sound somewhat worrying).

Same problem here. @all: it might be helpful to the support / tech guys to know which backup/restore options were chosen, if (and that’s a big if) we chose different ways of .

I did this:

  • Updated to 1.6;
  • applied unified storage update,
  • restored from Titanium Backup (Pro). When restoring, I used the
    Prefer XML option, and first restored all apps with data, then all
    system data (because of some other problem).
  • I also wiped the cache, did not help.
  • I also deleted unused files from the Dalvik cache (via Titanium Backup), did not help.

Curious enough, I had to restore all my contacts etc. via the standard Backup & Restore app, because they seemed not to have been restored via Titanium Backup.

I’ve asked a friend who’s more knowledgeable in linux/Android things. Apparently, something like this also happend to Samsung GalSII users when unifying partitions; seems to be a linux partition problem. (There are probably more partitions then we see in the Settings/Storage menu.) He advised me to use the terminal, get SU rights, and check out both the output of mound and df. Especially df(DiskFree) info should be valuable. Have not yet done so, anddoubt I can really make head or tails of the output.

Additional question: I tried downloading apps via F-Droid, to no avail. I get an error message: the link to the APK at the F-Droid repository. Might this be connected?

(OT, the new forum soft is really working well, notified me of this
thread when I was trying to start another. Also, the edit function is well implemented. :thumbsup: )

Same problem here. I had youtube installed and insufficent space for update. Deleted , changed to internal storage location. Now says insufficient storage although plenty left.???

Edit: Sorry, I did the partition update late because I didn’t know about it. So far it seems to solve my problem.
Just in case my post might help anybody to fix the problem on his phine I will leave it.

Same problem. I might had the problem shortly before 1.6 update, I’m not sure when the problem raised exactly.
First i could update 2 apps, then the error came for the first time. The next time I wanted to update some apps, again I could update 2 but no more. Since several days I cannot update or download any app at all (google play store).

What I did within the scope of 1.6 update (maybe 5 days ago):

  • FP 1.6 update
  • reinstall google play store via Google-Apps-Installer

My data storage app tells me:
phone: 11.4 GB free
SD-Card: 8GB free

A phone restart was useless so RAM shouldnt be the problem.

I’d like to draw your attention to a post over here. I found some emulated SD card /sd0 on my FP1. Anyone also seeing this? Could this be at the root of this issue?

What helped me get rid of these error messages is wiping the cache partition before the Cherry 1.6 Universal Storage update (that failed to install also until I did the cache wipe). After the wipe + US update everything is fine. Use the information from the hard reset post but make sure to only do steps 1,2,3,4,10,11. Then restart.

@JanDoggen THX, I’ll then probably try to reset again during the next weekend. I already unified the partitions, as you might have seen from my previous posts. I also wiped the cache some times.

Strange enough, I noticed some apps do apply their updates, from the play store. However, oeffi, GoogleSearch (sic!) and some other fail with the mentioned error of insufficient storage. (I’m tempted to dub this one the 3StoogesRage bug, as it keeps hitting me. On the head.)

[Pulling this over here from the other thread, see link “Unable to install some apps…”]
Couldn’t wait. I did a hard reset this morning, without doing a cache wipe. Still, what @Hugo_Buddelmeijer says is right:

I can confirm that: after the reset, GApps are installed. However, I specifically uninstalled Google Search yesterday and tried (unsucsessfully) to reinstall it from the app store. Now, it is gone.

I restored all my personal info and the apps from a backup, this time the standard out-of-the-box “Backup and Restore” app. This did not, however, re-install/restore all apps! For example, Twidere and TextSecure were there (but the credentials and data were gone). Threema, e.g., was not. Some other paid apps weren’t there, as well.

I opend Titanium Backup (Pro), which then prompted for Super User rights, and asked if I wanted ro restore my android ID. Which I did.

I did restore some apps and their data from Titanium Backup, like Twidere, and TextSecure. As Hugo says:

Worked fine. I actually also tried and restored the clock app, including alarms (it’s a system app). Worked as well. But I kept away from restoring most system apps.

Now, something funny: I checked the the PlayStore for updates, and could update the (restored) Oeffi Transport Buddy to the newest version - which somehow behaved like a new installation, placing a icon for the app on the home screen.
However, some apps (some of them payed apps) are now not shown in the “Installed” apps tab in the PlayStore, but in the “All” apps tab. And I double-checked: it said I should pay, again.

I decided not to, but to restore some of them from the Titanium Backup. One by one. Which worked. However, they are still shown in the “All” apps tab. Now, however, the price is gone, instead it shows “Installed” next to the app name.

This is annoying, to say the least.