Unable to install some apps (Blendle) after 1.6 repartitioning

It seems indeed to be related to specific kind of apps. After searching for ‘Unlock Key’, none of the apps I tried (“Wi-Fi Rabbit Unlock Key” and “AppSwipe! Unlock Key”) work. (I don’t know the apps they unlock.) However, it’s not just paid apps, since most paid apps install without problems but Blendle is free and won’t install. “Scribblenauts Remix” is a normal paid app that won’t install (that is, not an ‘unlock’ app).

Edit: It seems that all apps which require Android 4.1 or higher won’t install, e.g. ‘Blendle’, ‘Scribblenauts’. Couldn’t find any other apps that require Android 4.1 or higher. 4.0 apps (‘Hungry Shark Evolution’) install fine. The ‘unlock’ apps do not require 4.1 though, but that might be device dependent. 4.1 introduced apk encryption, so that might indeed be related.

@Hugo_Buddelmeijer, the linked post is not about all apps. I recently noticed some apps do indeed update. (As I just wrote here, particularly oeffi and GoogleSearch seem to cause problems, among others.)

I’ll have a look, but I doubt it’s just > 4.1 apps - some other Google-Apps do update. I’ll check that.

@Hugo_Buddelmeijer: you wrote that ‘It seems that all apps which require Android 4.1 or higher won’t install’. As you say it’s not easy to find one (most apps seem to be content with Android 2.3) but out of curiosity I found and tried one called Cherwell Mobile (requiring Android 4.2 or later). It installed without issues on my FP1 with Cherry 1.6 and repartitioned. So the common denominator must be another one.

@humorkritik Thanks for the info. I’ll try some of the solutions there, like wiping the cache partition and perhaps reset again if necessary. I cannot find anything called “oeffi” I can’t install the “Offi - Public Transport Buddy” (2.2+) due to ‘insufficient storage’.

“Google Search” indeed seems to be important. I also cannot update it, and furthermore it often crashes, especially when doing things with the Play Store. Perhaps this is paranoia, but it seemed that more apps failed after trying to update Google Search.

Furthermore, worth mentioning is that the next app that I try to install after I failed to install an app results in another error: ‘""could not be downloaded due to an error. (941)’. I can simply retry and install the second app without problems (unless it’s one of the forbidden ones).

@kgha there are indeed other apps that won’t install, but so far none of the >=4.1 apps want to install. Also ‘Cherwell Mobile’ won’t install on my device. Were you able to install one of the others? E.g. Blendle, but this is for the Netherlands only, or Scribblenauts Remix, which costs about a dollar (so don’t try it if you don’t want to). I don’t know any others.

Another app I can’t install is “Nuts!” (2.3.3+).

That’s the thing.

Nope, I noticed the same: the update downloads ca. 23 mb of data, and afterwards the process fails. Until you wipe your cache clean (e.g. with Titanium Backup), more apps are bound to fail installing/updating.

Funny enough, the Oeffi Transport Buddy app is installed and updated at one point! (I am running version 8.27 now, that is 0.03 versions behind - and I cannot update currently.)

Maybe that’s a lead… Have a look here

That’s an elaborate fix for the (941) error @humorkritik ! Unfortunately, neither clearing the caches, nor removing Google Play Store updates resolved the issue. However, the Play Store is still called “Play Store” after removing the updates; that is, it didn’t revert to Market (or what it was called).

Also wiping the cache as suggested here Insufficient storage error even after partition upgrade for FP1 didn’t work. Perhaps a full hard reset is in order, but I’m not yet willing to do that.

Indeed as others said, many apps can’t be updated. For some reason I never noticed this, probably because I didn’t care to update them (or there might not have been many updates since I upgraded to 1.6 and repartitioned). Currently I can’t update: “Facebook”, “WhatsApp”, “Twitter”, “YouTube”, “Swype”, “Maps”, “Google” (==“Google Search”?) and some other lesser known ones. Most apps update fine though.

An idea: perhaps the ‘backup-and-restore’ procedure was different for different users who repartitioned; and perhaps only some procedures do result in this ‘insufficient storage’ problem. So perhaps we can share our actions? What I did was backup everything with the free “Titanium Backup root”, upgrade to 1.6, repartition, install Google Apps, reinstall “Titanium Backup”, bought and installed “Titanium Backup PRO” in order to do batch-restore, batch restored all apps.

It might be that I also backed up the “Google Play Store”, restored that over the freshly installed one, and subsequently installed the right Google Apps again through the FP widget. I recall something like that, but I’m not entirely sure. Perhaps that caused a problem.

I tried, but Play Store refused since i tried to install from outside the Netherlands.

Just speculating, but I’m beginning to believe that backing up with Titanium from one folder structure and restoring in a new structure after repartitioning can give trouble. I have the impression that most users that have experienced oddities after repartitioning have used Titanium. But I might be wrong here.

I think that nails it. We have a Titanium problem.

By the way, I can’t use discourse on my FP in the stock browser. Can’t
type, for some reason. Seems to be related to the way the compose field is
Meh. :frowning:

1 Like

I too got an insufficient memory when I approved a request to update some apps. But I have no idea what repartitioning and Titanium are about :frowning:

Decided to do a full hard reset this morning, including wiping the cache etc. This seems to have solved the problems: all apps do install/update nicely now.

I did test Titanium Backup by restoring some apps that caused problems before, e.g. Twitter, and now those update fine. So Titanium Backup can be used, but perhaps it causes problems when restoring system apps like Google Play. I’m not going to try that and in the future will be more selective in which apps I restore.

BTW, a hard reset did some interesting things. First the Google apps were already installed, so the widget was already greyed out saying that it should be deleted. Furthermore, upon boot the normal Android configurator asked for my Google account; subsequently it seems that the FairPhone configurator removed this information, causing all kind of new update errors (906), which prompted Google Play to request my Google account details again, and everything was fine.

@Cathal if you did not update to the “unified storage partition”, then you might indeed have ‘insufficient storage’ to update/install certain applications. This update can be performed after updating the FairPhone to version 1.6 (cherry). However, this will remove all data from the phone, therefore many people like to make a backup first. Titanium Backup is a tool to make those backups, but there are others. Please follow the link above for more information about repartitioning and backup tools.

@Cathal, I’d like to stress this:

You will loose all contacts, photos etc. that are not stored on your SD. You will have to re-enter all your credentials into all apps (which need credentials), loose your ringtones and notification sounds (if you changed them) and so on.

So, please, DO make a backup. Titanium Backup is for free, but if you want to restore all data(*) in a batch you’ll need a Pro key.

(*) We would probably not recommend batch restore at the moment, right, @Hugo_Buddelmeijer and @kgha?

Hi! I have exactly the same problem. Did a full reset/wipe, but the problem came back. I think it is a problem with the appspace for encrypted apps. Non-encrypted apps install fine, but encrypted apps run out of space.

I have an open ticket that is send to technical support.

Too bad your problem is still there @dib0! Hope you’ll have some success with the technical support.

Do you mean that the problem was gone for a while by saying that the problem ‘came back’?

By the way, how can you tell which apps are encrypted?

Some pre-4.1 apps also refused to install, but encryption was not yet supported then if I understand correctly. Perhaps different versions of the apps can be available for different platforms? That is, the Play Store says 2.3+ but only installs the 2.3 version on older Androids and the encrypted 4.1 version if possible.

Yes, the problem was gone. In my case I could install all the apps that I wanted (probably missed one or two the second time) as was the case before wiping/resetting my phone.
Some apps keep installing ok and keep updating ok. Some do not.

Before the 1.6 repartitioning I used link2sd (among other solutions) to be able to install the apps that I need. Link2sd shows if an application is encrypted. Most apps that can’t be updated right now where displayed (before) by link2sd as encrypted. I can’t be sure if this is the case with all these apps, but it is the only logical conslusion I could draw (until now) on these symptoms.
Maybe encrypted isn’t the right term here (I’m not too well know in the inner technical workings of Android), but I believe there is a different between non-secure and secure storage. I thought that Android decide to place apps in these different appspaces based on encryption of the app, but maybe I’m wrong about that.

Interesting. I don’t have had any installation problems in the last week. Wiped, restored non-system apps including data one by one via Titanium Backup, let apps update themselves via the PlayStore.

(One minor annoyance was that the sound recorder: lost my recordings, and strangely a restore including data did not bring them back. Apparently, Titanium Backup did not back up the data - and I have no idea why. Good thing I copied some of them to a PC.)

Discourse on mobile is horrible, doubly so on Android. The Discourse developers don’t really care.

If you want a halfway decent forum experience, you’ll have to use a computer…


I too have difficulty updating apps. Insufficient storage. I have gone through and moved everything that lets me, to phone storage. My internal storage is still 3/4, 750MB full. How can I make more space, and why was the phone not set to phone storage in the first place?

Have a look at the tutorial here: https://fairphone.zendesk.com/hc/en-us/articles/200887199-How-do-I-upgrade-to-the-unified-storage-partition-for-first-edition-Fairphone-owners-

Installing this update will solve your problem

I have a FP1U and I did the update to Cherry (without Unified partition, because it was already present).
But I have this strange problem with some Apps ! Twitter, Yahoo Meteo, Sholi…
I read this thread and I did’nt found definitive solution for now…

1 Like

Same problem here: unable to update WhatsApp.

I did the unified storage and upgraded to 1.6. Restored using Titanium (free version). Honestly I don’t recall exactly what settings I used (or if I restored any of the google apps from Titanium), as it was months ago. I didn’t install google apps or the app store. Today I found out my version of WA would expire soon so I decided to install google apps (by the way, you can download the WA apk install file from whatsapp.com, I wish I had known this before!). Then it started auto-updating all my apps (WTF?! there are some I don’t want to update). So I turned off all data/wifi until I could find the setting to not auto-update. Anyway I got everything under control, then updated a few apps. Then when I went to update WA, it said insufficient storage. No problem, I uninstalled a couple apps and cleaned the cache. But when I tried again to update WA, still insufficient space even though I have over 11GB free. So tried to restore it again from Titanium, but it took forever and never finished. So I rebooted and tried again. Same problem. So I rebooted and uninstalled WA, thinking I could just install it over again from the app store. but no, still insufficient space. I installed a few other new apps without issue. I tried downloading the apk to my SD card and installing it that way, but still insufficient space. What’s going on? Why is this phone such a pain in the ass?

Update: There were no Google Play updates to uninstall. I did the wipe partition cache thing, which didn’t fix the issue either.

Update2: I did a hard reset and wiped cache partition. Google apps was still installed. It again tried to auto-update. I stopped it. I successfully installed WhatsApp, OneDrive, CBC Radio, and AnyConnect ICS+ (the rest of the apps I didn’t update because I was afraid that I wouldn’t be able to restore my app data from an old version). I closed the Play store and then it suddenly became a different version the next time I tried to open it (black edges around the icons), and now there is an option to uninstall updates.

Update3: then I restored via the stock backup and restore. No issues. Then I tried to restore via Titanium, only I deselected the Play store. Here’s where the wheels fell off. It wouldn’t restore those apps listed in my second post, plus a few others. So I lost the app data. But since many were already up to date from Update2, it’s ok for now. The others that wouldn’t restore via Titanium also still can’t be upgraded in Play store. I tried deleting them and reinstalling, but now I can’t install. WTF?! I also tried uninstalling the google play updates, no help. So I’m stuck again. Titanium sucks. Most of my settings didn’t restore. I’m really annoyed with this crappy phone/android. So many bugs, and each fix just breeds more bugs.

Update 4: tried re-doing the hard reset/wipe, tried restoring things in a diff order: stock restored titanium, then updated titanium (the changelog said it had fixed exactly this error!). Then I did titanium restore for everything except the apps I didn’t want to update (facebook, messenger) and not google play. then went to stock backup and restored personal data and those apps I had skipped. but only half of them would install; the rest failed (Facebook, but not Messenger).

So this is ridiculous. I will try again later skipping titanium completely (so really Titanium becomes useless and if they really did fix the error, it probably only works if you made the backup with the latest version, which doesn’t help me).