Insufficient storage error even after partition upgrade for FP1

Just to follow up: I wiped the whole thing and did the partition upgrade and it seems to be solved now (although the messages about this happening again after the upgrade sound somewhat worrying).

Same problem here. @all: it might be helpful to the support / tech guys to know which backup/restore options were chosen, if (and that’s a big if) we chose different ways of .

I did this:

  • Updated to 1.6;
  • applied unified storage update,
  • restored from Titanium Backup (Pro). When restoring, I used the
    Prefer XML option, and first restored all apps with data, then all
    system data (because of some other problem).
  • I also wiped the cache, did not help.
  • I also deleted unused files from the Dalvik cache (via Titanium Backup), did not help.

Curious enough, I had to restore all my contacts etc. via the standard Backup & Restore app, because they seemed not to have been restored via Titanium Backup.

I’ve asked a friend who’s more knowledgeable in linux/Android things. Apparently, something like this also happend to Samsung GalSII users when unifying partitions; seems to be a linux partition problem. (There are probably more partitions then we see in the Settings/Storage menu.) He advised me to use the terminal, get SU rights, and check out both the output of mound and df. Especially df(DiskFree) info should be valuable. Have not yet done so, anddoubt I can really make head or tails of the output.

Additional question: I tried downloading apps via F-Droid, to no avail. I get an error message: the link to the APK at the F-Droid repository. Might this be connected?

(OT, the new forum soft is really working well, notified me of this
thread when I was trying to start another. Also, the edit function is well implemented. :thumbsup: )

Same problem here. I had youtube installed and insufficent space for update. Deleted , changed to internal storage location. Now says insufficient storage although plenty left.???

Edit: Sorry, I did the partition update late because I didn’t know about it. So far it seems to solve my problem.
Just in case my post might help anybody to fix the problem on his phine I will leave it.

Same problem. I might had the problem shortly before 1.6 update, I’m not sure when the problem raised exactly.
First i could update 2 apps, then the error came for the first time. The next time I wanted to update some apps, again I could update 2 but no more. Since several days I cannot update or download any app at all (google play store).

What I did within the scope of 1.6 update (maybe 5 days ago):

  • FP 1.6 update
  • reinstall google play store via Google-Apps-Installer

My data storage app tells me:
phone: 11.4 GB free
SD-Card: 8GB free

A phone restart was useless so RAM shouldnt be the problem.

I’d like to draw your attention to a post over here. I found some emulated SD card /sd0 on my FP1. Anyone also seeing this? Could this be at the root of this issue?

What helped me get rid of these error messages is wiping the cache partition before the Cherry 1.6 Universal Storage update (that failed to install also until I did the cache wipe). After the wipe + US update everything is fine. Use the information from the hard reset post but make sure to only do steps 1,2,3,4,10,11. Then restart.

@JanDoggen THX, I’ll then probably try to reset again during the next weekend. I already unified the partitions, as you might have seen from my previous posts. I also wiped the cache some times.

Strange enough, I noticed some apps do apply their updates, from the play store. However, oeffi, GoogleSearch (sic!) and some other fail with the mentioned error of insufficient storage. (I’m tempted to dub this one the 3StoogesRage bug, as it keeps hitting me. On the head.)

[Pulling this over here from the other thread, see link “Unable to install some apps…”]
Couldn’t wait. I did a hard reset this morning, without doing a cache wipe. Still, what @Hugo_Buddelmeijer says is right:

I can confirm that: after the reset, GApps are installed. However, I specifically uninstalled Google Search yesterday and tried (unsucsessfully) to reinstall it from the app store. Now, it is gone.

I restored all my personal info and the apps from a backup, this time the standard out-of-the-box “Backup and Restore” app. This did not, however, re-install/restore all apps! For example, Twidere and TextSecure were there (but the credentials and data were gone). Threema, e.g., was not. Some other paid apps weren’t there, as well.

I opend Titanium Backup (Pro), which then prompted for Super User rights, and asked if I wanted ro restore my android ID. Which I did.

I did restore some apps and their data from Titanium Backup, like Twidere, and TextSecure. As Hugo says:

Worked fine. I actually also tried and restored the clock app, including alarms (it’s a system app). Worked as well. But I kept away from restoring most system apps.

Now, something funny: I checked the the PlayStore for updates, and could update the (restored) Oeffi Transport Buddy to the newest version - which somehow behaved like a new installation, placing a icon for the app on the home screen.
However, some apps (some of them payed apps) are now not shown in the “Installed” apps tab in the PlayStore, but in the “All” apps tab. And I double-checked: it said I should pay, again.

I decided not to, but to restore some of them from the Titanium Backup. One by one. Which worked. However, they are still shown in the “All” apps tab. Now, however, the price is gone, instead it shows “Installed” next to the app name.

This is annoying, to say the least.

ok found solution. Went through every app and moved it to phone storage. Updates must need some internal storage to update and if there is insufficient there it wont do it. 2 questions. Why is the default not phone storage? and why if you chose the option to let the phone decide does it not chose phone storage? Maybe for the last question the answer was the internal storage was already too full to allow updates as I have described above.

@ozbizbozle: Glad you found a solution. Sadly that solution only works on phone that didn’t install the unified partition update. If you install this unified partition update, there is no option to move apps the the phone storage.

I must say this problem is really starting to annoy me, since I cannot install some apps that I really would like to install.

@dib0, as described above: it worked for me after installing the unified partition update to

  • factory reset
  • restore some specific apps from my backup but NOT
    system apps, especially Google PlayStore.
  • update apps via the PlayStore, one by one (not: update all apps)

No problems since then. You could try that and report back.

Hi @humorkritik!

Thank you for your reply and the tip. This is exactly what I did about a week or three before. I did a factory reset, installed the google apps and then installed all the apps from the playstore. Still, I got the error back in a few days.

I hope this soltution did fix it with your phone permanantly! Let me know! If you don’t have the problem back in a month or two, maybe I’ll give it another try.

That’s curious. Just to be on the same page, did you use any backup, either from the “Backup and Restore” app pre-installed on your FP, or a third-party app (like Titanium Backup, in my case)?

Also, when resetting, did you follow the instructions letter by letter, especially the “wipe cache partition” part? I did two factory resets, and wiped the cache only the second time - since then, the problem is gone. (I also wiped the Dalvik cache using Titanium Backup Pro, which did not solve the problem before resetting. However, there is the possibility that this contributed to the success in getting rid of the PlayStore error.)

Hi @humorkritik,

Yes, I did follow the instructions letter by letter. I received them from one of the support employees. I did wipe the cache partition.

I use Titanium Backup, but this last time I did not use it to restore the apps. I downloaded them, one by one, from the app store. I did use the import function of one app (Automagic) to restore the triggers and actions I configured in the app.
I did not use the Dalik cache wiping from Titanium Backup.

Still: I can install apps, even large games. A few days ago I deinstalled some apps that couldn’t be updated (it took me some effort to convince myselve to do this :-)). After that I could update some of the apps that couldn’t be updated before. After a few updated apps (logically) the problem was back, as expected.

Since I’d hate to go through the whole wiping resetting and reinstalling proces again, I’m going to wait for a while. I kinda expect (not to be negative) that you will run in to the same problem. (To be sure: I truly, truly hope not, I want this to be fixed). So, if you can keep me updated how this solution works for you in the long term, I’m truly thankfull.

I get the “Not enough space” / “Nicht genügend Speicherplatz verfügbar”-Error in the Playstore, too.
I still have over 10 GB of free space, both on the phone storage and SD card.
Only updates for certain apps create the error – I can install new apps form the Playstore without a problem.

I reset my FP to factory settings four times (!) allready, whiping caches, installing apps manually from the playstore, restoring them with or without the data from my Titanium Backup, deleted all GoogleApps, the GoogleAccount, deinstalled the PlaystoreUpdates, … long story short: tried all sorts of things to get rid of the problem – but I had no luck.

Moreover I have an other problem – not with the Playstore, but with F-Droid:
Other than @humorkritik I don’t get

[quote=“humorkritik, post:14, topic:564”]
an error message:
[/quote] Instead any app I want to install via F-Droid is first downloaded but then I get the error “no free space” / “Kein freier Speicher vorhanden”. Anyone else got that problem?

I really hope somebody finds a solution. I’m quite exhausted because of this.

I have a FP1 that says I have about 1 GB Internal Storage and about 13 GB Telephone storage. The internal storage seems to be exhausted. All applications I could move from Internal to Telephone storage have been moved. Only app’s that reside on internal storage won’t update anymore. So I think repartioning is the thing to do. But how do I do that? Can anyone describe this in Dutch step-by-step? Starting with what I need? Since I am not the most experienced user, please keep it simple.
Perhaps the more clever girls and boys can write such a guide in their own language.


you can find a step-by-step guide here.

It’s no magic at all. :smiley:



Can it wait till Friday? I then have translated the step-by-step guide mentioned by @stojmas into Dutch.

Thank you and yes it can wait till friday. The updates are now waiting so long those few days wont matter. In the meantime I will pláy with my new 32GB SD card and MyBackup Pro. The latter won’t do what I want it to do (make backup of application with data). It stops somewhere and there is no backupfile. Enough to find out till friday (or saturday)


Hoe kan ik upgraden naar de één interne opslagruimte

(dit is enkel van toepassing voor eerste editie Fairphone-eigenaren)

15 september 2014 17:31 uur.

Met de softwareupdate 1.6 (named Cherry =kers) krijgen de Fairphone
eerste editie-eigenaren de kans om hun interne in tweeën gesplitste opslagruimte om te zetten naar 1 grote interne opslagruimte.
Deze nieuwe grote opslagruimte is een verbetering van de oude situatie,
want de oorspronkelijke interne opslagruimte bestond uit een een zogenaamd intern deel en een telefoondeel.
Dit gaf soms foutmeldingen zoals “insufficient storagen =niet genoeg opslagruimte” of “internal storage running out =de opslagruimte zit bijna vol”.
Let op: Het is beslist nodig om een backup te maken van al je instellingen
en bestanden, want bij het upgraden naar deze speciale opslagruimte wordt
álle data van je Fairphone gewist.

Je kunt deze upgrade uitvoeren met behulp van de Fairphone Updater app.
Volg de stappen in de juiste volgorde om naar de nieuwe opslagruimte
te upgraden.

Stap 1:
Maak een backup van je Fairphone (volg zo nodig onze instructie Backing up your personal data).
In de volgende stappen zullen alle instellingen en bestanden verwijderd worden, dus zorg voor een goede backup.

Stap 2:
(hint: Je moet per se gebruik maken van wi-fi.)

Tik op de ‘Fairphone Updater’ app:

Stap 3:
Tik op ‘Fairphone Os
en in het volgende scherm op ‘Storage Upgrader Cherry 1.6

Stap 4:

Tik onderaan op 'DOWNLOAD AND UPDATE

In het geel zie je waarschuwing “THIS WILL ERASE ALL YOUR DATA = Dit verwijdert al je data”.

Stap 5:

De upgrade wordt nu gedownload en geinstalleerd op je Fairphone.
Als dit klaar is, zal de Fairphone vanzelf zich herstarten.
Belangrijk: Als je de melding ziet “Fairphone OS is requesting Superuser access =Het Fairphonesysteem heeft superrechten nodig”, kies dan altijd voor "Remember choice forever =onthoudt deze keuze altijd” and “Allow =toestaan”.