Insufficient space, at least that's what the phone says

Hello there,

I’ve had this problem since a few weeks ago. Whenever I try to download anything from the Play Store, it can’t download and it says my phone has insufficient space. However, the internal storage still has 102 MB out of 0,92 GB, and my phone storage has a whooping 11,76 out of 12,98 GB available. I have not downloaded the partition upgrade, nor the newest Fairphone update 1.6 since I have been too much of a procrastinator to do that as of yet. Incidentally, I can’t download that either.

My dad, who has a Samsung (Android), says he has had this problem before and he then had to dial a number with hashtags and stuff and then manually clear something - I can’t remember what exactly, some log thing. However, Fairphone OS does not let me dial that number. Anyone who has an idea what the Fairphone equivalent of that action might be? Or how I could solve this problem in any way?

Thanks in advance!

EDIT: The number for Android is *#9900# and the action is “Delete dumpstate/logcat”. I can’t do that, it’s invalid.

We discussed something like the error you describe in length here and here, but you might also try to go to recovery mode and wipe the dalvik cache first.

Not sure about the logcat, though. There was somebody describing continuously growing logcats at some time, might even have been on the old forum. Can’t find it right now, at a quick glance.

Okay. I’m not sure what this all means. Does this mean I need to do a factory reset in order to wipe the dalvik cache? So will I need a backup (on an SD card) of all my apps and files?

I have the same problem with my FP1U
I read lot and lot of topic about this problem and I have finally try a hard reset of the FP

But it doesn’t works !!!
After reset, I have installed one app with success and now I have the same error message : “Insufficient storage error”

With my reads, I think have understood this about my FP:

  • the system partition is 1Go
  • the “internal memory” is 13Go
  • in my case I have another SD card with 32Go (external storage)

I don’t undertand why the app goes to the system partition (even if “internal storage” or “external storage” is set).

How can we definitively solve this problem ?

Chris_R wrote in the post ‘storage-problems’

The FP1 comes with 1GB allocated to apps and then 13GB allocated to other things like media. So when you are looking in the File Manager you are viewing the 13GB partition, so the fact that you have 7GB left doesn’t mean you have any storage left for applications.

To fix this problem you need to run the storage update

The update does away with 2 separate partitions and merges into one. You will need to backup and restore your data as it erases everything as part of the process. It is a pain, but this is the solution to resolve this.[/quote]

Thanks Lidwien, but I don’t have the First edition, but the Second Batch.
I made the update to Cherry when I received it in august, and it’s looks good.
But I don’t know how to manually verify if the storage is efficiently unified or not…
If you have a clue…

Go to the apps,
tap on 'File manager’
Now you should see an internal storage of with a total space of around 13.7 GB
How much GB is available on your internal storage?

Your SD card should read a total space of around 29GB

Yes I have the same informations. So do I have an unified storage ?
When I’m installaing an app, where does it go ? On the 1Go hidden partition ? on the 13Go partition ?
How can I choose where to stock them ?

If you read in the ‘File manager’ the same as me, then you have one unified storage.
There is on your Fairphone no hidden partion of 1GB and a second 13GB partition.
It’s one unified partion of 13.7GB

Yes, you can choose where to stock an app.
Go to 'System settings’
Under the sub ‘DEVICE’ tap on "Storage"
Under the sub ‘DEFAULT WRITE DISK’ you can choose either the Internal Storage of your SD card.

Thanks for the precision about the non-existency of the 1Go partition :slight_smile:
But I’m confused because despite this unified storage and all the right settings you described, I still have this error message when trying to install more Apps : “insufficient space”

What’s wrong ?

Please go again to the ‘Filemanager’ and tell me how much is available on your Internal storage.

Well, you hardly used the Internal storage.

Could you go Go to 'System settings’
Under the sub ‘DEVICE’ tap on "Storage"
Under the sub ‘DEFAULT WRITE DISK’, where do you stock an app.
Is it on the ‘Internal Storage’ or is it on the SD card.

Now, it’s set to SD Card.
But I also tried “Internal storage” and nothing change when I’m trying to install app : always the message “insufficient space”

Set the default write disk to the Internal storage.
Switch off you phone and on.
Check if the default write disk is still the Internal storage.
Try to install the app again.
BTW, what is the app you have problems with?

After a reboot, the “internal storage” is always set :slight_smile:
It’s strange… I have problem only with some apps such as YahooMeteo, Sholi, Twitter (for now)…
Other are installed on internal storage (the space left is changing)

There seem to be an issue with installing some apps.
In the thread about Blendle you can read more about this.

1 Like

Hummm it’s looking a good way :slight_smile:
I will read this. Thanks :slight_smile:

I had the same kind of problem and now it seems solved!

I think it depended from a kind of conflict between a old version of the play store app and the FP operating system.

simply try to re-install the play store (and all the other google apps) via the Google Apps installer (it is present in your widget list)

(just for info. I have a FP 1st edition updated to cherry 1.6 but I did not (still) merged the 2 partitions)

hope it will work

I also have this problem too. I have no SD card. Whenever I try and download an app it also says insufficient room. I have to go to storage and delete cache and that usually does it. Under Default Write Disk there is a blue dot next to the words Phone Storage. It will not let me uncheck it. Preferred install location is set to Internal device storage.