Insufficient storage error even after partition upgrade for FP1

ok found solution. Went through every app and moved it to phone storage. Updates must need some internal storage to update and if there is insufficient there it wont do it. 2 questions. Why is the default not phone storage? and why if you chose the option to let the phone decide does it not chose phone storage? Maybe for the last question the answer was the internal storage was already too full to allow updates as I have described above.

@ozbizbozle: Glad you found a solution. Sadly that solution only works on phone that didn’t install the unified partition update. If you install this unified partition update, there is no option to move apps the the phone storage.

I must say this problem is really starting to annoy me, since I cannot install some apps that I really would like to install.

@dib0, as described above: it worked for me after installing the unified partition update to

  • factory reset
  • restore some specific apps from my backup but NOT
    system apps, especially Google PlayStore.
  • update apps via the PlayStore, one by one (not: update all apps)

No problems since then. You could try that and report back.

Hi @humorkritik!

Thank you for your reply and the tip. This is exactly what I did about a week or three before. I did a factory reset, installed the google apps and then installed all the apps from the playstore. Still, I got the error back in a few days.

I hope this soltution did fix it with your phone permanantly! Let me know! If you don’t have the problem back in a month or two, maybe I’ll give it another try.

That’s curious. Just to be on the same page, did you use any backup, either from the “Backup and Restore” app pre-installed on your FP, or a third-party app (like Titanium Backup, in my case)?

Also, when resetting, did you follow the instructions letter by letter, especially the “wipe cache partition” part? I did two factory resets, and wiped the cache only the second time - since then, the problem is gone. (I also wiped the Dalvik cache using Titanium Backup Pro, which did not solve the problem before resetting. However, there is the possibility that this contributed to the success in getting rid of the PlayStore error.)

Hi @humorkritik,

Yes, I did follow the instructions letter by letter. I received them from one of the support employees. I did wipe the cache partition.

I use Titanium Backup, but this last time I did not use it to restore the apps. I downloaded them, one by one, from the app store. I did use the import function of one app (Automagic) to restore the triggers and actions I configured in the app.
I did not use the Dalik cache wiping from Titanium Backup.

Still: I can install apps, even large games. A few days ago I deinstalled some apps that couldn’t be updated (it took me some effort to convince myselve to do this :-)). After that I could update some of the apps that couldn’t be updated before. After a few updated apps (logically) the problem was back, as expected.

Since I’d hate to go through the whole wiping resetting and reinstalling proces again, I’m going to wait for a while. I kinda expect (not to be negative) that you will run in to the same problem. (To be sure: I truly, truly hope not, I want this to be fixed). So, if you can keep me updated how this solution works for you in the long term, I’m truly thankfull.

I get the “Not enough space” / “Nicht genügend Speicherplatz verfügbar”-Error in the Playstore, too.
I still have over 10 GB of free space, both on the phone storage and SD card.
Only updates for certain apps create the error – I can install new apps form the Playstore without a problem.

I reset my FP to factory settings four times (!) allready, whiping caches, installing apps manually from the playstore, restoring them with or without the data from my Titanium Backup, deleted all GoogleApps, the GoogleAccount, deinstalled the PlaystoreUpdates, … long story short: tried all sorts of things to get rid of the problem – but I had no luck.

Moreover I have an other problem – not with the Playstore, but with F-Droid:
Other than @humorkritik I don’t get

[quote=“humorkritik, post:14, topic:564”]
an error message: java.io.FileNotFoundException:
[/quote] Instead any app I want to install via F-Droid is first downloaded but then I get the error “no free space” / “Kein freier Speicher vorhanden”. Anyone else got that problem?

I really hope somebody finds a solution. I’m quite exhausted because of this.

I have a FP1 that says I have about 1 GB Internal Storage and about 13 GB Telephone storage. The internal storage seems to be exhausted. All applications I could move from Internal to Telephone storage have been moved. Only app’s that reside on internal storage won’t update anymore. So I think repartioning is the thing to do. But how do I do that? Can anyone describe this in Dutch step-by-step? Starting with what I need? Since I am not the most experienced user, please keep it simple.
Perhaps the more clever girls and boys can write such a guide in their own language.

Hi,

you can find a step-by-step guide here.

It’s no magic at all. :smiley:

Greetings

Tom

Can it wait till Friday? I then have translated the step-by-step guide mentioned by @stojmas into Dutch.

Thank you and yes it can wait till friday. The updates are now waiting so long those few days wont matter. In the meantime I will pláy with my new 32GB SD card and MyBackup Pro. The latter won’t do what I want it to do (make backup of application with data). It stops somewhere and there is no backupfile. Enough to find out till friday (or saturday)

Willem

Hoe kan ik upgraden naar de één interne opslagruimte

(dit is enkel van toepassing voor eerste editie Fairphone-eigenaren)

15 september 2014 17:31 uur.

Met de softwareupdate 1.6 (named Cherry =kers) krijgen de Fairphone
eerste editie-eigenaren de kans om hun interne in tweeën gesplitste opslagruimte om te zetten naar 1 grote interne opslagruimte.
Deze nieuwe grote opslagruimte is een verbetering van de oude situatie,
want de oorspronkelijke interne opslagruimte bestond uit een een zogenaamd intern deel en een telefoondeel.
Dit gaf soms foutmeldingen zoals “insufficient storagen =niet genoeg opslagruimte” of “internal storage running out =de opslagruimte zit bijna vol”.
Let op: Het is beslist nodig om een backup te maken van al je instellingen
en bestanden, want bij het upgraden naar deze speciale opslagruimte wordt
álle data van je Fairphone gewist.

Je kunt deze upgrade uitvoeren met behulp van de Fairphone Updater app.
Volg de stappen in de juiste volgorde om naar de nieuwe opslagruimte
te upgraden.

Stap 1:
Maak een backup van je Fairphone (volg zo nodig onze instructie Backing up your personal data).
In de volgende stappen zullen alle instellingen en bestanden verwijderd worden, dus zorg voor een goede backup.

Stap 2:
(hint: Je moet per se gebruik maken van wi-fi.)

Tik op de ‘Fairphone Updater’ app:

Stap 3:
Tik op ‘Fairphone Os
en in het volgende scherm op ‘Storage Upgrader Cherry 1.6

Stap 4:

Tik onderaan op 'DOWNLOAD AND UPDATE

In het geel zie je waarschuwing “THIS WILL ERASE ALL YOUR DATA = Dit verwijdert al je data”.

Stap 5:

De upgrade wordt nu gedownload en geinstalleerd op je Fairphone.
Als dit klaar is, zal de Fairphone vanzelf zich herstarten.
Belangrijk: Als je de melding ziet “Fairphone OS is requesting Superuser access =Het Fairphonesysteem heeft superrechten nodig”, kies dan altijd voor "Remember choice forever =onthoudt deze keuze altijd” and “Allow =toestaan”.

2 Likes

Hello

Maybe it will help using Link2SD.
Look on my Post on Storage update: No possibility to move apps.

Best regards
Bobby

@A_J, did you find a solution yet?

Restoring single apps from Titanium Backup, one by one and without any of the Google apps, and rebooting after every restore, could be a way to find out if one app causes this behaviour.

In my case, I have not problem since I did something like that. I kept the system apps and the Google stuff as it came, and just restored apps I bought, one by one. (Later, I also tried to restore a system app, i.e., the Notepad, with it’s data). Seriously, no problem since then.

@humorkritik Thanks for the advice. I will try this as soon as I have a little more time. Even though it means to do the whole restoring process again. :frowning:

@Bobby Thanks, too. However, I’d like to have a more permanent solution rather than a work-around…

Hi @humorkritik!

Any updates on the “not enough space” situation? It became problematic for me, so if you still do not experience the same problem, I will factory reset my phone again.

Hi @dib0,
thanks for the reminder. :slight_smile:

I had no further “not enough space” problems after wiping, re-installing Titanium Backup pro, and restoring apps one by one (including only some system apps, like the notepad).

(Currently, my FP is partly defunct; got to send it back to have the service look at it. I wiped it, and will restore the same way like described above when I get it back from FP service.)

Lidwien, worked like a charm. Was wel even wat werk, maar ben weer een happy fairphone gebruiker! Willem

I had the same problem after upgrading to a unified storage partition. Clearing just the cache was unfortunately not a solution, so I did a factory reset following these instructions (including “wipe cache partition”). After that I used Titanium to restore my apps one by one, excluding all Google related apps. For me this solved the problem, although it took some time to fix it, I’m now very happy that I can enjoy the full storage capacity.

Hi all!

So this week my banking application stopped working and I couldn’t update. I decided now was the time to try this fix again. And it seems to have worked. Followed the description to the letter. Installed all apps individiually from the app store and restored the data for some of the apps with Titanium Backup (the first thing I did was install Titanium backup and restore the phone ID back the the previous one, and after that install the apps).

It looks like the problem is gone. So thanks all for the support and especially @humorkritik!

1 Like