How to remove SD card configured as internal storage?

I added a 128GB card to my FP2 and configured it as internal storage. Now I’d like to run the phone without a card. I’ve deleted enough data that it will all fit in the built-in 25GB. But I can’t figure out how to move the remaining data to the phone. If I try to select “Eject” it warns me “apps stored on it will stop working”. Googling this I find hundreds of explanations of how to add a card, but nothing about how to remove one. Does anyone know how?

This is the fairphone open OS fp2-sibon-18.04.01.

1 Like

You have to:

  • Move all apps installed on the SD card to Internal Storage (if any). You can do that in Settings / Storage / SD card / Apps. You have to move each app individually.
  • Migrate your data from the SD card to Internal Storage (only if you migrated your data to the SD card before). In Settings / Storage / Internal Storage, open the 3-dot-menu and select Migrate data.
  • Now your SD card should be empty. If you want to remove it permanently you should format it as portable storage before ejecting it.

Ah, that looks like the right answer, thanks! A bit counter-intuitive, but I’m pleased that there is in fact a way.

1 Like

Ah damn, I spoke too soon. I did that. Now I have 3.52GB used in internal storage and 9.78 used on the SD card. Tapping on the SD card, it says Apps 0GB Cached data 0GB.

So what is the 9.78, and how can I move it to internal storage?

I’m trying to find the SD card in Amaze but I don’t get it. It puts me in /storage/emulated/0, and says there’s no files there.

The amount of used storage displayed in the settings can sometimes be misleading. If you want to make absolutely sure that there is nothing left on the SD card, browse /mnt/expand/_UUID_ with a root file manager (or /external_sd with TWRP). That’s your actual adopted SD card.

(/storage/emulated is just a mount point for either /data/media (internal) or /mnt/expand/_UUID_/media (adopted SD card), depending on where you have migrated your data.)


Thanks for the path, that helps a lot - I ssh in with SSHDroid. Much more civilised than trying to use Amaze :slight_smile:

Anyway the real problem is: migrating the data doesn’t work. It brings up a notification saying that the move failed and that the data was left in its original location. I tried rebooting and trying again, same result. So I guess that explains that. When you tap on the notification it takes me to a page saying “SanDisk SD card is ready”. Nothing more informative than that.

Actually this phone has multiple serious problems at this point, so I’m not going to push this further. Thanks for answering the original question!

1 Like

Just for the record: migrating the data did eventually work. After I deleted a bunch of apps, and pretty much all the media, it eventually became possible for it to migrate successfully.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.