FP3 Slow Charging

@OldRoutard @anon9989719 This is getting a bit annoying. The USB-settings should be found under connected devices, right? Well, I can´t find them there. If I use the search bar in the settings app, they are found and the path shows they are under connected devices, but if I go straight to connected devices, they aren´t there.

And here´s the best part. When I restart the phone in safe mode, I can´t use the search bar in settings app. When I try to do it, it just jumps back to settings app and doesn´t let me write anything in the search bar.

Yes, but if you do not have a ‘device’ connected then you will not see the option under Connected Devices :slight_smile:

So what device have you connected and a power unit is not a ‘device’?

Try connecting a PC and then see what you can change under the settings.

Oh, ok. Thanks @anon9989719 . Well, if I connect my laptop to my phone and open the phone in safe mode, the blinking and flickering doesn´t appear for as long as the usb cable is connected. However, I can´t choose any of the options in USB-settings either. As soon as I unconnect the cable from the phone, the flickering and blinking starts again.

Interestingly, when I kept my phone attached to the laptop and switched the phone off and on again without the safe mode, the USB-settings appeared normally, without blinking and choosable for a while. The phone also seemed to be charging (a lightning icon in the battery icon). However, when I unplugged the cable and plugged it again, it never started to charge again and the usb-settings don´t become visible again, except from the searchbar. When I go to USB-settings via the searchbar, the same blinking goes on when I unplug the phone. Also, when the phone is plugged, the USB-settings don´t blink but they aren´t choosable either.

Also another observation. Very often, when I plug my phone to a laptop or a charger, the little led light turns on (as if it was charging), but the little lightning doesn´t come to the battery icon.

What is your opinion: Software or just dirt in the USB-port causing some kind of a short circuit or something?

I opened the phone and unattached/cleaned the USB-module but didn´t open the module yet. It had no effect. It appears that Finland has a nationwide shortage in isopropylalcohol so I couldn´t get it from the pharmacy. Just my luck. :smile:

EDIT : You can buy Isopropyl alcohol online maybe??

Any pure spirit will do. Absolute Vodka so no flavourings etc. and at least 60% but will take a while for the 40% water to dry, so if you can find 90% so much the better… You can look for surgical spirit from a chemist but again it has to be additive free so as not to leave any residue.

From you experience it’s not possible to know what is wrong, however for the cost of a bottom module you can eliminate that and if that works you can then spend some time cleaning the older one. I bought a couple of bottom modules as a) I have two phones, they are two years old and of course the USB port is the most vulnerable part of the phone over time.

But it still can be a cable issue to some degree as apart from obvious dirt tarnishing of the contacts in either the cable or the phone means there has to be significant pressure between the contacts to get an effective and reliable connection, and given the inevitable bending will get even more difficult over time.

On other devices, in desperation, I have bent the USB plug or socket to increase friction, but of course that increases the problem after a while…


It does sound like a problem with the USB port.

In the past we’ve also discussed problems with misaligned contacts between cable and port, but ideally I would advise trying a bottom module exchange. There’s a Fairphone Angel near Helsinki who might be able to help, you could try writing to: Jarvenpaa@fairphone.community if you’re in the area or can get there.


So I still have this issue with the blinking in USB-settings, and I think this is eating up my battery life. My theory is that the device is thinking, that some kind of a device is getting plugged and unplugged all the time and that is using the battery. When I plugged a real USB-device, the blinking stopped but everything stayd “unchoosable”.

However when I plugged the phone to my computer, my laptop kept beebing all the time as if I was plugging and unplugging the phone all the time, so that definitely indicates (imo) something is wrong with the port. Also, when plugged in to a laptop, I was able able to choose (in USB-settings) that "the usb-connection is run by this device (instead the plugged device, don´t know the official english terms, the first setting in USB-settings), but everytime the phone switched it back to plugged device by itself.

I am thinkin about doing a factory reset and seeing if that would help.

What do I need to save from the phone before the reset? Photos, WhatsApp conversations… Can I restore the apps and accounts from somewhere after the reset or do I need to install every single app and account manually again?

Possibly, the port is both a physical thing as in the USB C socket and a software one a USB 2 port which decides on the charging.

Regarding saving data.

If you have an SD card inserted fornatted as portable then ensure any other media you have on the internal is copied or moved to the SD, or get an SD card possibly.

If you have a Goggle account there are options to upload to the google server and then download later.

I’ve never had to worry so someone else will be better placed to give specifics.

Not if you use Google back-up. I’m not saying I recommend it but it’s certainly the easiest solution for a standard Android device.

As Amoun said, copy all your files from internal memory to a SD card or computer or cloud space. The latter are great because you can configure them to sync automatically anyway.

However I would re-iterate that I’m still inclined to think this is a problem with the physical port and / or other charging-related hardware. Did you get in touch with a FP Angel with the idea of testing another bottom module?

1 Like

I’ve got a fairphone 3. It only charges when the cable is held in a certain angle and after a while stops charging. I’ve tried to gently clean the port but haven’t been sure the best way to do this. I was wondering if anyone had any advice, before I bought a new port

Hi, @starlight , and welcome to the forum.

A question: when connected, does it show in the info of the screen “fast charging” (if supported by the charger and cable) or “slow charging”?

My advice is to first try other chargers and cables, to see if that’s the problem.

In case nothing improves, try cleaning the port and connections with isopropyl alcohol and a cotton swab. I had this problem, and that’s what I did… after a couple of months, my FP3 charges correctly 98% of the time with the same charger and cable that didn’t charge before…

1 Like

As in a private message, if you have no warranty etc. you can do a deep cleaning on the bottom module.

thank you! i’ll try this. did you use the cotton bud in the port?

It’s showing fast charging. currently i’m just having to hold it with the cable in a specific way to charge it.

Have you tried another cable? The way I see it, it’s most likely that either the cable has a problem, or the USB-C port is dirty. If with another cable (and/or charger) it works properly, you know that’s the problem. If the problem is with the USB-C port, maybe cleaning it carefully with a dry toothbrush (with the phone turned off) would be enough, you wouldn’t have to open the phone.

Best of luck.


Apart from debris that can cause the force used to insert distorting the port, and or the plug, generally people are not careful and the cable may hang from port at an angle and cause distortion.

I have in the past physically bend both ports and plugs to overcome the issue, now I use a magnetic adapter so as to avoid such, plus it keeps the dust out.

1 Like

Yes, same thing with a different cable.
Have tried to clean but hasn’t changed it. I think I can see a tiny amount of dirt at the two edges (short sides) of the port but haven’t managed to get it out. It only looks like a very small amount but not sure if that’s effecting it.



If with the other cable the symptoms are the same (it only charges in certain positions), then my recommendation is that you try to see if with a few drops of isopropyl alcohol on the brush you are able to remove the small dirt you see in the USC-C port (with the phone turned off, and then letting it dry for a while before turning it on or plugging it into the charger).

If that doesn’t work, it might be worth taking the phone apart and cleaning the contacts. Or replace the bottom module to see if that’s the problem (before buying a new one, and if you have a #fairphoneangel near you, you can contact them to see if they can help you).

And remember that this is a user forum and not official Fairphone support, so, especially if you still have your phone under warranty, you might want to #contactsupport.

I hope you get it fixed soon.


Hi @OldRoutard! No I didn´t have a chance to get in touch with the angel because I left abroad.

I had a similar problem today. I tried different chargers and cables and nothing worked. Now i tried my notebook charger. it is currently fast charging with an aceptable speed. gonna keep u updated.

kind regards

1 Like

I don’t know why, but Power Delivery works!

Please see my posts in Spring '22 for more background: As stated over a year ago, I own two FP3s , one that charges rapidly and another one that only charges slowly. The problem is not the bottom module, because I switched it and nothing changed. I suspect there is some problem with the mainboard but I’m out of warranty and sending it in to repair is too expensive for me.

A few weeks ago I plugged the slow charging FP3 to my girlfriend’s power delivery charger and it now charges rapidly. But only when I use the power delivery charger (it’s still charging slowly if I use the Qualcomm Quick Charge plug)


Hi, I’ve looked around the forum, tried multiple things, but no luck so far. So trying it this way…

Over the weekend my FP3 all of a sudden stopped charging properly. A year ago I already switched the bottom module. This time around I’ve cleaned the inside battery compartment and did the system check by calling that *# number, haha. The check said my battery quality is still good.

Soooo… Could it be the bottom compartment again? Last time the USB was loose and all that, but that’s all steady (and clean) now.

Oh, when plugged in the yellow-ish charging light is shining, also when it’s not charging.

Anyone any other ideas?

Yes, I switched it on and off again :smile:

1 Like