FP2 does not start after update

If just made the recommended update through the official Updater App and now got stuck with a phone that doesn’t start anymore. It just says: Fairphone on the screen after switching on. Further I can’t switch it off anymore, it doesn’t react on nothing. If I take out the battery and put it back, start the phone again the fairphone screen starts and nothing else is happening!
Help!

2 Likes

You don’t have to take out the battery. You can press on/off button for >12 seconds instead.
Can you go into recovery by pressing volume-up on phone start (directly from the beginning and keep it pressed some seconds)?
You might consider a manual install of the OS or even a downgrade. More information e.g. here: https://support.fairphone.com/hc/en-us/articles/213290023

2 Likes

If I press the buttons for recovery my phone still blocks with a fairphone screen. The only thing that happens is I have a blinking blue light.

The Fairphone screen plus blinking blue light is the so-called fastboot or bootloader mode (reached by pressing Vol. down during boot).
Which is the correct mode for the manual installation, if you’re following https://support.fairphone.com/hc/en-us/articles/207914363

4 Likes

I’ve got the same problem as Katrin_S: restart doesn’t get past blue dots below “Change is in your hands” …
I did get into recovery mode, though. But when I try rebooting it says “No OS installed!” - so I’m hesitant to proceed.
Any advice? (apart from manual installation of the update)

[@AnotherElk] Thanks. Didn’t work out though:
Reboot > System gets stuck in FairPhone logo & blue dots, same as with restart.

(And: is it possible to back up, at least partly, when you can’t change the USB connection with the computer from charging into “file transfer”, as the phone isn’t working??)

Hello, same problem happens to me.

The download of the package was ok.
When hitting (4 or 5 times) the RESTART button inside of the updater app nothing happened.
I closed the updater, reopened, downloaded the OS update and hit restart. Went fine.

The phone rebooted, I left it apart.

After 30 min I checked the state of the update and found the phone stocked [at a screen like this one] which appears to be the TWRP (https://forum.fairphone.com/uploads/default/original/2X/0/02fa5f3a67356e8f746e85b13356b398f3e8892d.png) .

If I reboot the phone is stocked at the very first loading screen (FAIRPHONE POWERED BY android).

Do I have to wipe everything?

Not yet.

And if that failed, there would still be the manual install method …

Thanks for the reply.

if I go to the TWRP screen and look for the .zip you mentioned:

hope fp_update_gms_whatever.zip is still there to select.

there is none :frowning:

If I try to wipe from the TWRP it fails, I get a red error that says:

unable to find partition for path '\system'

then

Full SELinux support is present.
Formatting Cache using make_ext4fs...
Formatting Data using make_ext4fs...
Updating partition details...

…done

I take a look to the manual installation.

As irritating as it is, this message was observed to be kind of a feature, not a bug, of the older TWRP version bundled with Fairphone’s OSes.
If you don’t like it, you can install a more recent TWRP from twrp.me.
The proven most trouble-free version there would be 3.2.3-0.

Looks like you did the TWRP factory reset. Why? Now your data is gone.
The manual install method wouldn’t have done this, as you will read now, I guess …

I couldn’t find any old versions of the image on my phone after I hit the issue…

Downgrading with adb sideload works perfectly, no loss of data or other issues whatsoever.

A fix for the issue is on the way, it just hasn’t been merged yet:

https://review.lineageos.org/c/LineageOS/android_device_fairphone_FP2/+/255360

Yes, I eventually figured out that all my important stuff is on cloud services! :slight_smile:

1 Like

I’ve now installed the latest OS manually - my FP2 is working again! No data lost.
At first I kept getting the warning “No Fairphone 2 found in fastboot mode”. Then I downloaded & extracted the ZIP archive again, and this time it went fine.
See https://support.fairphone.com/hc/en-us/articles/207914363
In the mean time I’ve learned about recovery etc, and I’ll make sure to make backups …

3 Likes

Interesting, so you’re saying you were getting “No Fairphone 2 found in fastboot mode”. And the only thing you did different was to redownload the ZIP file? There might be hope for me!

Can I ask which update worked for you? Was it the most recent one?

Yes, last update, OS 19.08.1, as provided on the support page on manual installation - see link in my message (same as the one posted earlier by Ingo and AnotherElk).
The instructions actually cover the warning "No Fairphone 2 found in fastboot mode”.
Good luck!

1 Like

It doesn’t work on my phone at all, tried the manual installation multiple times and also tried downloading the ZIP again. No result. Screen is black with text and the script keeps asking me if I want to look for the phone again.
Anyone who experienced this and were able to fix it?

Can you upload a screenshot here?