Optimizing Apps Boot Loop


I don’t know if anyone can help me, but my FP2 is stuck in an infinite optimizing apps boot loop.

I can’t seem to enter safe mode either, I have tried holding down the volume keys but nothing seems to change. But it’s possible I’m not holding the right button down at the right time.

I haven’t made a full backup recently, so I’d prefer not to do a factory reset. I think it might be do to with not having much spare memory, but I can’t get to a state where I can delete any apps or music.

Can anyone help? My Fairphone 2 is useless at the moment.

1 Like

You might try to manually install the version you were running before the update?

1 Like

Thanks for your reply. If I was to manually install the previous version, would that wipe all my data?

No, your data partition will be untouched if you correctly follow the instructions of the according support article (and don’t wipe the data yourself): https://support.fairphone.com/hc/en-us/articles/207914363
I just can’t tell if it helps at all. The process of “optimizing apps” you described may already have changed something in the data partition…


Thanks, I might try that tomorrow.

I only really care about the photos and audio recordings in my data, so it sounds like they should be OK.

  • Connect your phone to a computer via USB.
  • Start or restart the phone while keeping Volume + pressed, this should boot the TWRP recovery.
  • TWRP enables MTP, so it is possible that you could see Internal Storage and (depending on the phone’s setup) the SD card in the file explorer of your choice on the computer, so you could copy stuff to the computer.

Thank for your reply. I have tried this, and my (Windows) laptop can’t see the internal storage. I can’t seem to get into recovery mode.

I can get into Bootloader mode (with the regular Fairphone logo and the “Powered by Android”) but no flashing blue light, which means I never had Android 7 ? (and therefore don’t have TWRP?) This surprises me but I guess it’s true.

If that’s the case and fastboot mode (aka bootloader) works, you can boot TWRP without flashing it … see #twrpwoflashing.

1 Like

Thanks again. I get the screen that I think means it’s in fastboot mode (the regular Fairphone logo and “Powered by Android”) but fastboot.exe won’t recognise the FP2. I’m totally stuck. That’s with [volume -] and power.

If I do [volume +] and power I get the Android bot lying down with a red exclaimation sign and “No command” displayed. But I don’t know what to do then, as it seems to be unresponsive to all button presses.

Edit: OK, I read on https://forums.androidcentral.com/ask-question/595427-help-how-fix-phone-says-no-command-recovery-mode.html that I needed to press [power and volume +] and then I get the Android Recovery screen. It says that I’m running 6.0.1/FP2-gms-18.03.1 which surprises me, but must be true.

Are you sure you’re using an usb data cable (and not only usb for loading)? Did you use this cable for transferring data before your problems (after the update attempt) started?

It’s correct that 18.03.1 still came with the “old” recovery and not with TWRP…

I’m pretty sure this cable used to work for transferring data, but I might see if I can buy a new one just in case.

I presume I could also try updating from SD card? Or is that more difficult?

As you’ve mentioned fastboot.EXE I suppose you’re using a window PC? Did you try to run fastboot as an administrator?

Well, I’m not sure FPOS can be downloaded in a format you can install via the “old” recovery…
Maybe @AnotherElk knows…?

Before Android 7 they used to release the “OTA” files for installing via recovery alongside the “Manual” install files for installing via fastboot, but they were incremental from the last Android 5 install file (version 1.13.0).

So to make a complete install with them was kind of a hassle … you had to know that you had to install the last Android 5 file together with the latest Android 6 file, and if you didn’t do that and booted after the Android 5 installation users with newer display modules (the supplier did change somewhen) ended up with a black screen because Android 5 had no drivers for them.

All in all it wasn’t worth it I guess, but that’s just my speculation why they don’t release them with Android 7 anymore.

They still release non-incremental OTA files for Fairphone Open OS, though.

1 Like

[Re message above from Another Elk on backing up]

  • Connect your phone to a computer via USB.

Thanks (again). I can see Internal Storage in TWRP, but Android File Transfer doesn’t (on old MacBook).

I have no Mac expertise, sorry.

Some generic stuff I can come up with …

It seems to me personally when looking at this forum (could still be wrong entirely, though) that macOS and Linux are more tricky dealing with MTP than Windows, so if there’s an MTP problem and trying it on a Windows computer would be a possibility, then that’s the first thing to try in my opinion …

Then there are different TWRP versions which can be tried without changing anything on the phone via #twrpwoflashing .
Some TWRP offers to mount USB OTG devices (to copy stuff to them? I didn’t try yet.), some other TWRP doesn’t.
Some TWRP has a button to disable/enable MTP (which can be useful if the connected computer has problems with the MTP’s file index e.g. emtpy directories or outdated file lists), some TWRP doesn’t.

Oh, and a forum classic for file transfer problems would be USB cables only for charging, not for data transfer. Those really exist, and they wouldn’t transfer data.

Thanks again. The cable shouldn’t be the problem, I’ve used it in the past to copy pictures. And I wouldn’t be able to rescue settings etc in this manner anyway, so I just hope I can get my phone to restart somehow without losing its contents. Will look into manual installation of the OS tomorrow.

PS Apologies for my previous message appearing twice; I’m not yet familiar with Replying, worked out differently than expected [same with this message: intended as indented reply]

Yes, I am on Windows. I’ll try running as an administrator later. Thanks for the idea.

Worked out well, see

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.