FP2 does not start after update

I am having precisely the same problem:

  • Reboot failed after the auto-update last night…
  • Followed the instructions on manual installation - repeated several times; got my phone into Fast Reboot mode (flashing blue light; usb connection to my Win10 laptop; heard the Windows accept sound jingle when I plugged in the USB, &etc.)

After running “flash-for-windows” multiple times, I still get:

** Fairphone OS 19.08.1 Manual Flashing Script **
Validating files…
All files are valid, let’s go!

WARNING: No device found in fastboot mode.
WARNING: Make sure that a Fairphone 2 is connected.
WARNING: To check for devices, type ‘bin-msys\fastboot.exe devices’.

Do you want to look for a device again? [(Y)es/(n)o]:

FP2 screen remains black with the “Fairphone” and “Powered by android text.”

My Win10 Control Panel shows a generic Android device is connected, but the status is “Needs driver” and there’s no option to update/install new driver.

I’ve tried all of the USB ports on my laptop; I’ve tried disconnecting, restarting and painfully following again each and every step in the process (2 thru 5); I’ve re-downloaded the binary twice (FP2 - Binary images of Fairphone OS 19.08.1 (~777MB) md5sum: c764109d20d0aae1019b513505dff76f).

But I’m stumped!

Suggestions, inspiration, ideas on this problem are welcome. Suggestions on where to find a good IPA anywhere in central Leiden also welcome… :wink:

HA! SOLVED!!! I went to my wife’s laptop (Win7; our home machine…) and tried it there - worked perfectly the first time! I guess my Win10 laptop (issued by my employer) had some sort of weird coroprate policies in place that blocked or interfered with the update script finding my FP2 via USB.

So, it ran exactly as described in the main article; the only thing I would add is that, at the end, when the Win script finishes and you see this:

Flashing successful!
Your Fairphone 2 will now run Fairphone OS 19.08.1.

Press Enter to reboot the device and complete the installation
Press any key to continue . . .

Go ahead and hit ‘Enter’ but then give it a good long time to reboot and restart - I waited ca. 20 mins during which I saw only the normal start-up screen (with the blue dots flashing underneath the Fairphone text). Then I sort of got bored, assumed it had hung up and then removed the battery to do a full restart - it then restarted in just a couple minutes just like normal.

The looming ‘Monday-morning-with-no-phone’ panic attack is hearby cancelled.

Cheers to all!

PS: Still need IPA recommendations… :wink:


Pronck, a brewery here in Leiden, makes a pretty respectable IPA - and that’s coming from someone who isn’t really into IPAs. I think they serve it at nearly every bar in the old city centre. Jopen IPA, brewed in Haarlem, is also quite good.

Also good job on fixing the problem, and on posting about it so other people with the same problem can follow your lead!

1 Like

Thank you! Will bookmark this for my next trip to Leiden… :wink:

Hope someone can help me.

My FP2 was crashing on the floor while the latest update was installing. Sadly it reebooted due to the crash.

If I start it new (battery on off or press power >12 seconds) it starts with “team win recovery project”.

Obviously never a recovery was installed (the storage is empty).

Selecting Rebooting, Recovery or System does not help

What can I do now to use my phone again?

Is there hope, that I can recovery my data? I never saved my contact data or my fotos… or better said not by intention (maybe google did it automatically)

Welcome to the community forum.

Worth a try when in TWRP …

A little more detail in between …

Apart from TWRP a manual install has helped people …

1 Like

Thank you much for your reply! It worked and seemed to be so easy.

I bend down on my knees :slight_smile: . The pictures from my newborn are still there :smiley:. Time to save them somewhere else.

Finally I realized I am a technical dinosaur…

1 Like

Indeed. Realisation is the first step towards improvement :wink: .
Here’s a guide for a start …

1 Like

I tried to update my FP2 to the newest version, but once I was in TWRP, I was not able to come back to the normal system. What should I do? I’m really not technical. In the code I had when it was trying to update: cannot find /system.
It’s pretty hard because it looks like I will never use the phone again.
Is there a way to fix it? Can you help me?

Clément (@clem.radio)

Edit: I don’t think my phone is rooted.

Don’t worry. You’ll be able to use your phone again!
Have you already tried that solution (which has worked for several people, as you’ll find out if you search the forum a bit)?
TWRP -> Install -> cache -> FP2 update zip file -> install


This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.