English

Fairphone 2 unusable while charging

Sounds like a grounding problem.

The touch screen is looking for your finger to be at the same voltage as most of the phone (which is at the same voltage as you because you’re holding it).

When you plug the phone in to a charger, the voltage of the phone changes to the “ground” voltage of what the charger is plugged into. Now the screen doesn’t see the phone at the same voltage as your finger and refuses to work. Some chargers are isolated (so the phone doesn’t get grounded) and some are not. The work around is to ground yourself as well!! Touch something that is earthed … like the outside of a metal kettle or the edge of a plugged in laptop, and the screen will work … sometimes your body potential will stay at “ground” and the phone will keep working when you disconnect yourself from ground … sometimes not. It depends what you’re standing on (whether you’re wearing socks … standing on damp ground … all sorts).

Had this endlessly with my old mobile and sometimes withe the FP2. It’s physics sadly.

PS it probably works when charging off your pc because the pc is working off batteries or has an isolated power supply. My Dell laptop isn’t isolated btw so if you use it plugged in, with bare feet you get a buzz off it.

7 Likes

I have the same problem using a Samsung charger (FP2 is unusable during charging).
When changing the charger to another one (Amazon for Kindle) or via usb to computer the phone works fine during charging.

1 Like

I had the same “hanging screen” effect when charging with a 5V / 0,7A charger. Using a 5V / 1A charger as recommended or USB computer connection works fine. I don’t know whether the two chargers differ in their grounding specs, none of them has an “earth” connector.

So I suppose it’s simply the lack of electric current when using a charger with less than 1A or even a voltage below 5V. Keep in mind that while charging the battery and the phone are current consumers as well.

[Update 21. Jan] My charger is an elder Samsung as well.

1 Like

Same problem

I have the same issue with FP2. I use a 3-year old Samsung charger with the recommended volt and amps. The screen becomes completely unresponsive when I charge from a wall plug, but everything works fine when I charge from my computer. I have not yet tried another charger.

I have had 2 other smartphones in my life and none had this issue, so I guess it can be fixed? Unless it is a hardware issue…

With my replaced FP2, its all fine. I use the same charger, 5years old, samsung…

Can someone please search and publish the Qualcomm’s PMIC (power management integrated circuit) specs for the 801 so we can get over with this? :slight_smile: I assume they have two charging modes “a clever one” that’s not always clever and a “standard” one. Maybe sometimes some older charger confuses the phone’s PMIC by somehow also connecting the data ports and/or not supplying enough stable current? Just a hunch.

1 Like

I have the same problem as it was described here multiple times. As soon as I plug in the charger, the phone freezes and does not react to touch-input anymore. Using the button, I can turn the screen off, and on again. But when I try to unlock the screen by swiping over it, it does not react.
I tried all different kinds of charges (Samsung, HTC and LG). None of them worked. Has anybody yet found another solution than finding a charger that works by trial-and-error? I want to be able to also borrow a charger from someone when I need it, and not always walk around with that single charger that works for my phone.

1 Like

My new Fairphone 2 goes dead whilst I have have the charger plugged in. I’ve tried a few different chargers but get the same problem. Won’t power off, no screen function, no main buttons. Anyone know of this problem?

I get this problem when using a 2amp Samsung charger that is less than a year old.

My (1-day old) FP2 is totally unresponsive to any action whilst plugged in for charging. Am I the only one?..

Nope. I moved your post here. We should really try to get a better search function…

3 Likes

Same problem here: I have my fp2 since a week now. After a first try (and being really annoyed about everything: flackering display, horrible picture google app, shut downs,…) I rebooted it completely, made all my backups with my old phone again and started from the beginning 3 days ago. There are still many problems and this one is one of it:
When I plug it in for charging, it is working until it goes to “sleep display” (don’t know the english name for it). If i wanna switch it on again, the touchscreen is not reacting at all. I need to unplugg it, activate and reactivate the “sleep displas” and then it works.

They hopefully fix the problem soon (i actually don’t wanna buy a new charger - liked it that i can use my old one…).

2 Likes

I just got my FP2 today and I have the same problem. Same charger as I used before. Upon reading these, I tried with a power bank (same cable) and it worked. I tried another charger (Apple USB Charger) with a different cable and it worked. Also charging directly from my computer works.
So it seems to be related to the charger, but it’s still a bit weird.

1 Like

I noticed that this problem only occures sometimes for me - although I always use the same charger and cable (original from FP1).

This let me think about:

  • So is it maybe a problem with certain wallet boxes?
  • Or only some bad circumstances in which it happened?
  • Maybe just the way we touch the charger or the surrounding with/without grounding ourselfes is the trick?
  • maybe the order of plug-in is the trick (first charger, or first FP …)?

What frequently helped was to unplug the charger itself from the net and plug-in again - and voila, sometimes then it works!

I’ve seen similar posts, but nothing quite the same: when my FP2 is hooked up to a wall charger, the touchscreen becomes completely unresponsive. It doesn’t always happen right away; I’ve just been able to use the phone normally for about a minute, and it seemed to stop working right when I did the “swipe in from the right” gesture. I have to turn the screen off and unplug from the charger to get it working again. I’ve had this issue with several different chargers that all work just fine with other phones. The cable is a data cable, USB 2.0. I don’t seem to have this issue when charging the phone through a USB (3.0 or 2.0) port on my laptop (with the same cable). The laptop also has a dedicated charging port (the yellow ones), also appears to have no problem, though I haven’t tested it excessively.

I should also note that the phone doesn’t crash or hang: screen rotation and button presses continue to work as normal.

The problem occurs both with and without the back cover installed.

I’ve tried the “jumpy screen” workaround of increasing the timing on long button presses through the accessability features; doesn’t help.

3 Likes

How exactly is it different from some of the posts in this topic:

And the I mainly mean posts like these:

There’s a plausible explanation there as well:

2 Likes

I thought I’d be clearer than just saying it’s “unusable” by describing my problem exactly in the top post. I confess I didn’t read through the entire thread. Also, as I’ve said my screen doesn’t hang. It just doesn’t register touch input. And (also, as I’ve mentioned) I’m using chargers that work fine with other Android smartphones. Two of them are Samsung branded, 5V 1A chargers, and the other one is a 4 port ewent charger that can do 2.5A per port, or 4.5A total (I don’t have anything plugged into the other ports).

If it’s indeed a grounding issue, can it be fixed with a software update at all? I don’t feel like I’m being overly critical by expecting my €530 phone to work properly with these chargers, especially since there is no charger included with the device.

I might add that the chargers in question do not have a ground connection plug (in fact I’ve never seen one on a phone charger). I’ve tried grounding myself by touching the ground pin on a wall socket, and by touching the metal shielding on the USB cable. Neither made any difference.

3 Likes

It’s true that the FP2 seems to be very picky about chargers, which is a bit of a shame. Whether it is something that you can live with is something for you to decide. If you have the phone for less than two weeks you can easily request a return via support, if you decide it is too much of a problem. Personally, I don’t think that is going to be easily addressed by a software update, so I wouldn’t count on an easy fix (but I could be wrong).

I’m a bit bothered by the fact that this isn’t mentioned in the “known issues” list. Could someone from Fairphone comment on that? Can no one there reproduce the problem? Is it considered to be the same problem as the “oversensitive touch screen” (because it seems pretty different to me)?

Of course I can live with it. I just think that I shouldn’t have to. I consider the device to be defective as long as it exhibits this behavior, and I feel like it’s bad for a company to just tell costumers to just live with it when their premium product ships with defects. Not really what I would consider a prime example of corporate social responsibility.

By the way, I agree that these topics should be joined, but can you change the thread’s title to an actual description of the problem?

4 Likes