Fairphone 2 unusable while charging

I can agree with that and I’m not sure they will do that. My point was that in a worst case scenario this never gets fixed due to a fundamental problem, and that I’d consider whether I would still like the product if it never gets fixed. Just to clear up any potential misunderstandings: the forum is a community effort and the moderators, myself included, don’t work for Fairphone (we’re basically customers like you, who spend way too much time on here).


Thanks for clearing that up, I wasn’t sure :slightly_smiling:
Basically, this is the only currently available phone I’d even consider spending this much on. So if my replacement has the same problem I guess I’ll just have to deal with it. I won’t be recommending it to anyone if it stays like this though.

Anyway, I’ll stick to discussing the problem from here on out.

1 Like

Same problem with some charger and not with another one with same specs (5.0V and 0.7A). Weird

same problem with a 0.5 A and a 2.4 A both 5V chargers, really annoying!

Same problem. It indeed depends on the charger. Similar to what @nicka is saying about “grounding”, I would blame an EMC issue. Indeed, USB 5V adapters are switched-mode power supplies which operates at high frequency (several kHz at least). This can generate high frequency electromagnetic noise which can propagate on the charging cable. If that’s the case, I fear this is a hardware design issue with FP2, which cannot be changed with a simple software upgrade…

For the time being, I’m just using a charger that happens to work :worried:

Also, I didn’t have a chance to test a possible mitigation scheme: some USB cables have a ferrite core (photo) at one end which is meant to attenuate high frequency perturbations. Maybe this can help?


Posted a reply … then thought again. Off to the lab to play with ferrites some more ;¬)

sounds interesting! let us know if you have some results!

Well … first I’ve tried to repeat the problem. Using three different cables, a motorola PSU, an ASUS PSU and several different sockets around the house and found no problem; also a “wired into the house” USB outlet we have … also no problem.

A no-name dual outlet USB supply my partner bought from the supermarket … PROBLEM. Irrespective of cable used, this one stops the FP2 dead after a few seconds … the screen won’t respond at all. In fact sometimes it will freeze the FP2 screen until I press the power button off and on again.

So, ferrites: I have a collection of these and tried up to two of them with a total of four turns around them … which makes no difference whatsoever. Ferrites block “common mode” voltage (where both + and - of the supply bounce up and down compared to ground) but not “differential mode” voltage (where + contains noise with respect to -). So possibly the el cheapo supermarket supply is noisy.

My previous “earth yourself to something” fix works - but only if it’s a really good earth (a bit of wire from the same socket as the USB PSU is plugged in to in this case).

Next I plugged a friend’s Sony Xperia C into the el cheapo supply … and it works JUST FINE without needing me to be grounded.

Fairphone … we have a problem.

But not a big one as you just need to find a decent quality supply - or keep yourself well grounded :¬).


While charging from a computer, storage of the phone becomes accessible from the computer, and so the phone becomes partly unusable as the storage is not accessible from the phone anymore… Not possible to install new apps for instance.

With my computer, if I choose not to present the phone-storage to the computer, this last one just stop giving energy… so no charging…

i bought an anker charger with two usb outputs witch each 2.4 A and i have the freezed screen issues. can you tell us which brand and type your charger is, that one which doesnt seem to make troubles? thank you for the test report!

Seems to work OK when using an old iphone 4 charger
Have the same problem with a dual charger bought in a supermarket.
I use the same cable with both.

One that works came with a nexus 7 tablet and is Asus branded, the other is unbranded and came with a Motorola smartphone I bought in germany.

I’m guessing that PSUs which come with devices have tested as working with those devices whereas the supermarket ones have only been tested to make 5V.


What about this one sold here. Is it working ?

This is the FP1-charger, I guess. I’m using it, but it gives the same result… An unusable screen :frowning:

I think I finally find one which seems OK with a Fairphone 2. It’s a Samsung Travel adapter ep-ta20ewe.
Output is 9.0 V - 1.67A or 5.0 V - 2.0 A

1 Like

It is not that simple.
I am also using the FP1 charger+cable for the FP2 and only in <10% of the events the screen becomes unusable and can simple be restored by unplug and again plug-in the charger…I never checked, how I grounded myself…

1 Like

5 posts were split to a new topic: :de: FP2 Ladeprobleme

I think I finally found out what the problem is:
After I bought

and plugged everything in, I had no problems what so ever.
BUT this voltage tester has two USB outputs.
The first one works like the USB port on the computer
The second one works like a simple charger.
The Fairphone 2 works perfectly normal on the first USB port, but has the described problems on the second USB port.
The EzReal Support also wrote, that on the second USB port D+ and D- are short-circuited due to the fact that the second USB port acts like a normal charger USB port.

Does that make any sense? I’m not a electrical engineer, so I have no idea if everything I wrote was correct.

I think it is a Software Bug on the Fairphone 2.
Somehow the Fairphone 2 needs the data channel (D+ and D- => see http://www.beyondlogic.org/usbnutshell/usb2.shtml) to be available. If this is not the case, the touchscreen simply freezes.

1 Like

mew … not for long. The bug returned, but it isn’t as nearly as bad as it is when I use the charger directly