Discussion about the Open OS Fastboot Installation Guide

Looks like this (see below) bug in the macOS version of the SDK, which some users are reporting still doesn’t work with fastboot version 0.0.1-4500957 (27.0.1, and definitely 26.0.1). A manual build is provided in comment 8 that appears to work for people who have commented on the bug:
https://issuetracker.google.com/issues/64292422

1 Like

Thanks for your response. I’m not sure, whether the bug still exists. I can successfully access the Fairphone using adb devices or fastboot devices, but I can’t execute the script. I also can flash successfully further developer devices from LG and Wileyfox but not the Fairphone 2.

I’m currently using fastboot version 0.0.1-4500957 on macOS 10.13.3 on a MacBook Pro with Touchbar. Another potential problem could be the USB-C port respectively driver for this device.

Anyway I switched to my Linux developer VM and managed to install Fairphone Open with KDE Neon.

Unfortunately Fairphone Open is only available for people educated in computer science. I think, Fairphone should offer Fairphone Open preinstalled, because the Google layer violates privacy and security. Today European consumers have no alternative to iOS or Google Android. There are only after marked alternatives available.

I don’t think that education in Computer Sciences is needed… Just following a tutorial. You have made it this far and the only thing stopping you is a bug. Unfortunately.

Fairphone can’t preinstall AOSP because people expect Google Services - despute all their privacy issues. Strange world, indeed.

1 Like

Hello FP Forum,

I really do want Fairphone Open but can not accomplish the manual.

I think my phone gets in fastboot, shown by the known splash screen, which stays on display instead of leading to android start up. I connect the phone via USB but flash-for-mac.command leads to the error, stated in the title of this topic. This is the complete code, triggered by the installation file:

** Fairphone Open 18.03.1 Manual Flashing Script **

WARNING: Flashing this image wipes all user data and settings on the phone.

Validating files…
Validation complete.
ERROR: Unable to create a plug-in (e00002be)

WARNING: No Fairphone 2 found in fastboot mode.
WARNING: Make sure that a Fairphone 2 is connected.
WARNING: To check for devices, type ‘/Users/sebastianschumann/Downloads/fp2-sibon-> 18.03.1-manual-switcher/bin-darwin/fastboot devices’.

Do you want to look for a Fairphone 2 again? [(Y)es/(n)o]:

I did a tutorial for installing adb and fastboot. I am in developer mode, with usb debugging enabled and media transfer mode. My cable is a transfer cable from an sony camera. I use OSX 10.13.04.

I would appreciate any ideas to try out.

Despite the fact, that I might not be able to implement a manual build in my system, the link is broken. I will try the flashing manual with a windows machine as soon as I am able to.

Thank you so far.

Had no problems setting up Fastboot & ADB upon Mac OSX 10.13.4 using this resource, which couldn’t have been easier:
http://www.stechguide.com/setup-adb-and-fastboot-on-mac-easy-step-by-step-guide/

1 Like

ADB and Fastboot are not missing on my system. But your resource was helpful to proof that. The expectet files can be founf in finder. But adb devices does not lead to the expectet output (fastboot devices did). Can anybody understand this?

schuseba-wlan2:~ sebastianschumann$ fastboot devices
fdbdb62a fastboot
schuseba-wlan2:~ sebastianschumann$ adb devices
List of devices attached

@Realcyke

Is there an error in PATH for ADB perhaps, does anything in this resource help you?
https://stackoverflow.com/questions/17901692/set-up-adb-on-mac-os-x

1 Like

fastboot devices works when your phone is booted into fastboot mode (aka bootloader).

adb devices works when your phone is booted into something supplying USB debugging, most prominently Android, or perhaps the TWRP recovery.

Short: fastboot and adb don’t work at the same time.

1 Like

Again this was helpful resource. I installed homebrew which made the phone appear in the list after typing adb devices. Unfortunately this seems to be only one step forward. I get the same error message when I launch flash-for-mac.command. The phone is still not recognized for this operation. :disappointed:

I tried the different operating modi and can proof this information. Thanks for this insight. Now I know that adb and fastboot work properly for me. The Error has to come from another direction.

I used a windows 7 machine which did the job without any issues.
And, by the way, I like Fairphone Open a lot.

1 Like

The error comes from the fact that the manual switcher is using the fastboot in /bin-darwin. If you try to replace that fastboot with the one from https://issuetracker.google.com/issues/64292422 (which works in High Sierra), you get a checksum error.

Was only able to workaround this using another Mac that had El Capitan.

Thank you! I have been trying all day to do this and your instructions were very clear. Am very happy to have Open OS again :smiley:

1 Like

Hi,
to install FP OPEN from a new FP2 with FP OS: I downloaded the file “fp2-sibon-18.04.1-manual.zip”, unzipped it and modified the “flash-for-unix.sh” due some issue with checksum:

ERROR: Checksums do not match.

I commented (#) the whole paragraph about SHA256SUM check.

Flashing successful!
Your Fairphone 2 will now run **Fairphone Open 18.04.1**.

Press Enter to reboot the device and complete the installation...
rebooting...

… so, the lines the script was giving before that error message would have been interesting.

I would assume checksums are there for a reason.
Commenting out a checksum check might be advisable with trouble unrelated to the process the checksum is there to check, but else I would be wary about the results :wink: .

yes, right but it’s can be launch from a terminal separately and it’s not necessary for complete the installation.

However my phone hadn’t finish the installation after reboot… So i followed this post (downloading the “fp2-sibon-18.04.1-ota-userdebug.zip”) and now I have FP OPEN on my FP2.

Glad you got it to work :+1:

I was trying to say that even if the script said that the checksums don’t match at this point, the error could have been something else entirely, as the script will abort there for other errors, too, but the message will be “Checksums do not match” anyway, because the script was just written that way, it doesn’t distinguish and catch other errors there.
You can see an example of this in the topic I linked to. The script said the checksums don’t match there, but the real error was that a file system path couldn’t be found in the process of checking. That was visible from the terminal output before the script gave the checksum message.

I just didn’t want to let it stand uncommented that the solution to a checksum check complaining is to disable the checksum check.
Get to the cause of the error (and fix it if possible). If the cause of the error is something else and perhaps unfixable momentarily and the checksum is alright otherwise, a checksum check might be discarded, but not only because it’s a nuisance :wink: .

1 Like

Well I’m feeling a bit thick now. I’ve spent all day trying to install fastboot on my iMac and I’ve got nowhere.