Problems going back to fairphone os

Hi there,

I’ve been using fairphone open for a few months now, and i’d like to give fairphone os a shot.
At the beginning it was just to give it a try, but after some hours of failures it has become an obsession :smiley:

I’m using a windows 10 x64 laptop.

So, i followed the going back procedure from here, then i got the infamous warning described there, and that’s an infernal loop procedure from which i didn’t get out yet.
Funny thing is i can run the flash-for-windows.bat script without launching as an admin, and then get the warning loop. But if i run it as admin i get

** Fairphone OS 18.01.1 Manual Flashing Script **
WARNING: Flashing this image wipes all user data and settings on the phone.
Validating files…
Le chemin d’accès spécifié est introuvable.
ERROR: Checksums do not match, try to download the manual update again.
Aborting now (press Enter to terminate).
Appuyez sur une touche pour continuer…

Sorry some sentences are in french, but you get it checksums do not match. I tried to run the mdsum.exe in bin-msys, it pops a terminal where i can see the dark color of the black hole of my own perplexity, and does nothing. I downloaded the zip files three times with the same result.

I then searched for ‘‘fastboot devices’’ and i don’t get anything, i tried fastboot reboot, but again no movements.

After a savage reboot i tried looking for adb devices i get

C:\Users\Armand\Desktop\android_sdk\platform-tools\platform-tools>adb devices
List of devices attached
f8def625 device

I then tried ‘‘adb reboot bootloader’’, and it works i get my phone into fastboot mode. Yet i can’t see the phone with ‘‘fastboot devices’’.

So i guess the problem comes from the fastboot connection, and/or the manual switcher zip file (which i downloaded three times with the same result).

I read somewhere that the phone should be neither in charge, nor mtp options for usb connexion, but i can’t uncheck all boxes.

Please help me ?

The second line translates to "The specified path was not found."
The script will abort the checksum checking upon any error giving the same message regardless of what kind of error actually occurred.
So it seems that the error message is not about the checksum, but some necessary path was not found before even getting to the checksum checking.

Windows as of late is by default displaying ZIP files as folders you can do some limited stuff in and with. The “Going back” guide states that you should extract the ZIP file. Did you do that, or do you operate in the still zipped folder (which wouldn’t work because the script wouldn’t find anything it needs resulting in the exact error behaviour you cite here)?

If you have unzipped the ZIP file, open a cmd, cd into the directory with all the unzipped files, then cd into bin-msys and try fastboot devices with (your phone in fastboot mode and) the fastboot.exe which is there instead of the one in your Android SDK.

1 Like

Hi AnotherElk,

Thanks for your quick answer.

I did extract the zip files, and i ran the fastboot using the cmd in the bin-msys directory, yet i still get

C:\Users\Armand\Desktop\fp2\bin-msys>fastboot devices



And i checked the md5sum of the zip file, they are identicals.

Are you still able to boot the phone into the TWRP recovery of Fairphone Open OS (Volume Up when starting or rebooting)?

If so, you might try installing Fairphone OS via TWRP using these files …

(Be aware that as I read it, you need to install two files in succession this way to get to the current OS version … the “FP2 - Update file of Fairphone OS 1.13.0” file and then the “FP2 - Update file of Fairphone OS 18.01.1 from 1.13.0” file, as the 1.13.0 file is the last complete OTA file given there, even it is called an update, everything else are really just updates from another version. Don’t boot in between, just queue the two files in TWRP for installing and then flash them in one go.)

By the way … do you have a backup of your important data :wink: ?

1 Like

Hello again,

I downloaded both files : FP2 -gms76-1.13.0-ota (FP2 - Update file of Fairphone OS 1.13.0) and FP2-gms-18.01.1-ota-from-1.13.0 (FP2 - Update file of Fairphone OS 18.01.1 from 1.13.0”) and tried to install them into TWRP recovery, but i get

zip signature verification failed

and when i tried after unchecking the zip signature verification option i get

Can’t install this package (Thu Mar 2 11:10:24 SGT 2017) over newer build (Tue Dec 19 17:41:19 GMT 2017)
Updater process ended with ERROR: 7

Should i try with the binary ‘‘FP2 - Binary images of Fairphone OS 1.13.0’’ ?

I’m thinking of going through a hard reset, but i’m not sure i’ll go back to factory setting (ie fairphone os).

Thanks for your concern about important files, it’s all backed up already :slight_smile:

As long as TWRP works (and you have a backup of your data), you are in control.

You could use TWRP to wipe the phone completely and install the OS from scratch.

For Fairphone OS, you can slightly adapt the Fairphone Open OS procedure given here, you would just use the Fairphone OS files you downloaded instead of Fairphone Open OS …

Hi again,

I followed the procedure as you described it.
And now i’m facing the same message when trying to install FP2 -gms76-1.13.0-ota (FP2 - Update file of Fairphone OS 1.13.0)

Can’t install this package (Thu Mar 2 11:10:24 SGT 2017) over newer build (Tue Dec 19 17:41:19 GMT 2017)
Updater process ended with ERROR: 7

I also tried again to install (manual switcher to Fairphone OS) and this time i get

Could not find ‘META-INF/com/google/android/update-binary’ in the zip file.

I will try to install the [Binary image] Fairphone OS 18.01.1 (Android 6.0) as suggested here

[edit] Ok did try it, but i get the same meta-inf issue …

Then you didn’t completely wipe the phone. On a wiped phone there would be no date left any script could compare the date of 1.13.0 with.
Perhaps if TWRP asks you at startup whether you want to stay read-only or whether you want to allow changes, please allow changes.

For the record: I had such a date problem, too, a long time ago. I simply deleted the date check in the script back then, so it didn’t check for the newer date anymore … but I can’t seem to find the post right now …

Edit: Got it, but it’s way old, perhaps the path or filename changed …

So … unzip the ZIP, edit the file, rezip the ZIP, and good luck :wink: .

Maybe the FP OS-specific TWRP version blocks installing an older FP OS version over a newer one.

You could try

Maybe this TWRP wiki can give some additional hints:


I flashed the latest twrp version, and managed to install the first ota package FP2 -gms76-1.13.0-ota (FP2 - Update file of Fairphone OS 1.13.0).

But as i tried a system reboot, twrp asked me if i wanted to root the device, which i did. When it finished, i got a black screen. After a while, i took out the battery and inserted it again. But now i’m facing a black screen phone, unable to boot, neither into twrp nor fastboot. Although when i push the power button i hear the phone vibrate, and when i connect it to my laptop i can access the internal storage.

Do you have a new screen?
If so it’s not compatible with such an old OS, which would explain the black screen. In that case you’ll need to manually update via fastboot.

For adventurous people of the future (aka “the record”) …

I am not kidding … often :wink: .
If you try to boot 1.13.0 inbetween, a black screen is what you get with a new screen, as 1.13.0 came too early to be able to handle it … and 1.13.0 will have overwritten your TWRP with its stock recovery, probably also unable to work with the new screen.

@paulakreuzer is right, now fastboot is your friend …

1 Like

yeah, i was so desperate, i didn’t think it would flash, so i didn’t bother. Well, i get what i deserve !

But i’m back to the first problem of all : fastboot doesn’t detect any device.

I’m still a bit puzzled about adb working and fastboot not working … really odd.

Can you try on another computer (friend, family)?

You could also boot up a Live Linux DVD or a bootable Linux USB stick (without having to install Linux on the computer, here are steps for the popular Ubuntu) and try to get adb and fastboot to run and check whether it works this way … the manual installation guide says “You need to install the fastboot tool, usually available through your package manager” … this should work with Linux Live distributions, too, nowadays.

1 Like

I will try with another computer.

For now, i have reinstalled universal adb driver as described here

With my phone into fastboot mode (hopefully, because power button and down volume button gave me a vibration as it should when entering fastboot), I now see an android device in windows device manager, but without any driver.

I can install one from my computer (for example the android adb interface or xiaomi android interface) but i’m not sure i should, as i saw different drivers for adb and fastboot or bootloader for other devices (such as google nexus).

Thank you for stopping me if i’m in the process of making another big mistake.


I managed to manually install fp os 18.01.1 through another computer (win 10 also). With a slight feeling of ‘‘why didn’t i start there ?’’ …

Thank you anotherElk for guiding me through all that stuff, even though i have been a bad student !


This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.