Manually installing update with linux

My FP2 needs an update, auto updates or advanced updates have failed to work . I have installed fastboot on my linux mint laptop, now when I run the extracted FP update file I get the error message ‘checksums fail to match’ pls see screenshot attached. Please bare in mind I have very little know how with Linux.
Any ideas please?
Thanks in advance.

… so the checksum error message is not necessarily given because of the checksum, it could be a problem with a path or else.

In your screenshot the flashing script can’t change the directory (cd) to the images subdirectory. Could be a permissions issue.

The manual installation guide states

" On GNU/Linux , open a terminal emulator, navigate to the archive content directory and execute the script with the command sh"

Try to run the command in a terminal window with “sudo” before it …
sudo sh

I think the usual explanation for such an error message is that the file you downloaded didn’t download properly. Some data might be missing for the complete file. I think this happens more frequently with wireless downloads. If this was the case with your download, can you download it through a cable connection?

Thanks for advice, will try a cabled download…tomorrow otherwise my brain may implode.

Can an incomplete or otherwise corrupt ZIP file even be extracted?

1 Like

Have you checked that the directory “images” exists under the path “/home/duncan/Donwloads”?
Can you open a terminal, type “cd /home/duncan/Downloads” and “ls -al” and post the output?

Not sure I read the second command line correctly as l for Leema s - a l for Leema?
This is what I did:
duncan@duncans-laptop ~ $ cd /home/duncan/Downloads
duncan@duncans-laptop ~/Downloads $ ls - al
ls: cannot access ‘-’: No such file or directory
ls: cannot access ‘al’: No such file or directory
duncan@duncans-laptop ~/Downloads $

There is a space between the “-” and “al” - where it must not be.


duncan@duncans-laptop ~ $ cd /home/duncan/Downloads
duncan@duncans-laptop ~/Downloads $ ls-al
ls-al: command not found
duncan@duncans-laptop ~/Downloads $

same result after removing space?

You also removed the space before the “-” not just the one after.

It should be like this:
duncan@duncans-laptop ~ $ cd /home/duncan/Downloads
duncan@duncans-laptop ~/Downloads $ ls -al


This looks more interesting, to someone!!
-rwxr-xr-x 1 duncan duncan 16407 Sep 9 2016 Transaction (6).pdf
-rwxr-xr-x 1 duncan duncan 13982 Sep 9 2016 Transaction (7).pdf
-rwxr-xr-x 1 duncan duncan 14156 Sep 9 2016 Transaction (8).pdf
-rwxr-xr-x 1 duncan duncan 19351 Sep 9 2016 Transaction.pdf
-rw-r–r-- 1 duncan duncan 30199 Apr 4 2018 Turning corners I04.pdf
-rwxr-xr-x 1 duncan duncan 137945597 May 8 2016 Twist And Shout - The Beatles Beginner Easy Song Guitar Lesson (BS-207) How to play.mp4
-rw-r–r-- 1 duncan duncan 5086625 Dec 10 2017 ultimate_30c.pdf
-rw-r–r-- 1 duncan duncan 7556199 Feb 1 2017 video-1485942057.mp4
-rw-r–r-- 1 duncan duncan 13039 Jul 20 15:36 Welder transformer testing (1).pdf
-rw-r–r-- 1 duncan duncan 13039 Jul 20 15:35 Welder transformer testing.pdf
-rw-r–r-- 1 duncan duncan 36323482 Aug 14 11:18 WhatsApp.apk
-rwxr-xr-x 1 duncan duncan 4248223 Sep 13 2016 Wiring Matters full file (1).pdf
-rwxr-xr-x 1 duncan duncan 4248223 Sep 13 2016 Wiring Matters full file.pdf
-rw-r–r-- 1 duncan duncan 60898 Jun 17 21:11 wiring schematic.gif
-rwxr-xr-x 1 duncan duncan 535558 Jun 7 2016 Wood working workshops.png
-rw-r–r-- 1 duncan duncan 2107493 Jan 18 2018
-rw-r–r-- 1 duncan duncan 898773 Feb 19 2019
-rw-r–r-- 1 duncan duncan 221526 Jul 29 10:02
-rw-r–r-- 1 duncan duncan 21364490 Jul 5 12:37
duncan@duncans-laptop ~/Downloads $

1 Like

That’s strange. If you followed the instructions (, you should have extracted the downloaded ZIP file.

I neither see the downloaded ZIP file not its extracted contents.

Did you download
And where is that downloaded file?

After downloading Fairphone 2/fp2-gms-19.8.1-manual to “Downloads” did you right click > Extract Here?
After opening a Terminal if you type cd / you can drag and drop fp2-gms-19.08.1-manual folder into terminal and it will fill in the blanks for you.
You only need type ls and should see bin-darwin flash-for-mac.command flash-for-windows.bat README.txt bin-mays images listed

I downloaded the file again and extracted before dragging it into the terminal after cd or sudo

As the first file starts with “T” we’re likely seeing only the tail of the output.

It may be easier to troubleshoot if the zip file is copied into a sub-folder (i.e. a new directory with any reasonable name will do) in Downloads and extracted there - that way it will be easier to get a list of files only related to the update. Even a screenshot of a file manager showing the contents of the sub-folder after the zip file has been unpacked will do.

1 Like

Don’t call anything (except extract maybe) from the file browser, but from a command line. Hop in the directory where you have extracted the archive to (and hopefully nothing but the extracted archive is in) and run inside there sh which you had opened from file browser before. If it fails to flash for some reason even though your telephone is connected via USB to your computer, try sudo before flashing (maybe sudo sh or similar.

Hi any contributers helping with my issue,
Sorry for truncated discusion, life is irratic atm. Just wanted to ask, I had been trying to do this without the phone connected as a trial run for fear of losing all phone data if I got it wrong, this wouldn’t be the reason it is not unpacking the program would it?