Wifi turns off immediately after activating. Any ideas?

Dear Fairphone community,

until now my Fairphone experience has been pretty well. Last weekend I meet someone at a Party having the Fairphone as well. Asked if she is happy with it, she told me yes, but:
The wifi does not work.

Here is what happens, she demonstrated me:
When turning the Wifi on - no matter if via Quick or normal settings - the icon turns blue and gets animated, but only for a few (milli)seconds before turning gray again. In normal settings, the the switch turns to “off” again.

There is no error message whatsoever and data connection via HDSPA works like a charm. Has anyone experienced similar issues? Where you able to resolve them?

I’ve not seen this before. Do you know if she had tried anything to solve it? Potentially if it’s a software problem then a hard reset might be the answer, but could be a hardware fault maybe?

Hi All,
I have exactly the same problem.
First it had disappeared after factory reset…not right after reset but magically a while after reset.

Now it happend again, … after several resets, manually installling Updates like support suggested etc, it keeps refusing to turn on WIFI.

It is now a nice looking paperweight with Fairphone printed on it as I cannot udate my contacts anymore as google only loads the package of 100mb if I got WIFI turned on.
I cannot say how much I am annoyed right now!
I do not have spare phone and connot do anything…thanks Fairphone.

Anybody got a workaround? Or Idea?


i have not found a solution. I think you should contact customer support.

I try to enable wireless but never change status on still in grey and turn to off automaticly

@Tusker: Did you solve your WiFi issue? Maybe it helps @jaimecarmonasantiago too!

no still my issue I try restore factory settings and does not work for now
only works for make call not for wireless conection and bluetooth as well
present same issue
my best regards

@jaimecarmonasantiago :es: Supongo que hablas castellano? In este caso tambien podríamos comunicar in espanol. Veo que tienes dificultades comunicar en inglés.

:gb: I assume you know Castilian? We could also communicate in Spanish then. I see that you have difficulties communicating in English.

1 Like

Dear @jaimecarmonasantiago,

I had just the same problem a few moths ago.

I gave the phone to repairs after several tries of resetting and firmware

It all did not help, so my last resort was sending it back to Fairphone.

They solved the issue quite quick, but they unfortunately did not tell me
how they did it or what I did wrong.

So my advise would be to send it to the technical support and avoid all the
hassle and frustration of a non working wifi.



1 Like

unfortunally I am in mexico so cost to send to technical support is expensive from my country, do you know some customer technical service in america?
thanks in advance

this issue i thinks is a hardware failure because bluetooth and Fm radio is affected as well so some tip to know where came this issues??

The repair guides are on iFixit, so pretty much every repair shop should be able to help you (assuming they order the spare parts from Fairphone).

Assuming you did not expose your phone to extreme humidity and/or let it drop, etc., Fairphone Support would probably repair your device on warranty, and also cover part of the shipping costs.

PS.: You do not have to write multiple posts. Better direct an answer to a specific person by adding an @ before their name (e.g. @jaimecarmonasantiago) ;).

maybe thats help let me contact to techical support to know when expire my warranty, thanks

I have a similar problem since today (see image).
I restarted my FP1 several times, but still the same Problem.

So the only solution is to send it to FP?

today I also had the problem that the wifi constantly tried to activate without success.
I read some logs and found out there is some problem with the wpa_supplicant.

This is a file on your android system that is related to all you wifi passwords.
I followed the tips on this site http://forum.xda-developers.com/showthread.php?t=1450511
Moved the wpa_supplicant.conf , rebooted and voila, the wifi worked again. (you have to reenter all wifi passwords)

Hope this helps.

While I investigated the contents of the wpa_supplicant.conf I found this line


Is it possible that all the people having this wifi activation problem have F-Droid installed? Could be interesting.

I realized that even after the wifi worked again I couldn’t create an access point for sharing internet. After checking the logs I saw that there was a problem with p2p_supplicant.conf
As I checked the content it was the same like the broken wpa_supplicant.conf. Once removed AP worked fine again.
Is it safe to say that under some conditions F-Droid brakes the wifi functionality? Doesn’t happen to everyone that is sure.
If I have some time I might open a bug in their github, but the holidays are there soon :wink:


Thank you a lot, tobika!

Yes I have F-Droid too.
My first problem, was that it was not possible to create an access point. Not so important, because you can share internet also with bluetooth.
But Some weeks later also the normal Wifi connectivity failed.

Your post was to late :smiley: , now I send it already to Fairphone for repair. (I had also an other problem, so not that bad)
I gave them a link to your post…

I think it is strange hat F-Droid can modify these files, because you need root to modify them. And I never run it as root. So how is it possible?

Are there other people with the same problem, which solved it like tobika?
Best wishes