Wifi not working after battery died [Resolved]

Hey guys,

the Wifi of my FP1 is not working anymore. It was activated with hotspot on, my battery died. After charging and booting, the Wifi keeps activating without any change. I tried to restart the phone and to put the phone in flight mode. None of both worked.

What can I do?

best regards

I’m not 100 % sure what you mean.

  1. Do you mean your WiFi is on all the time and cannot be stopped … or

  2. Do you mean it is not working for you (not coming back on again?)

I think of 1). Try to take out the battery and wait a bit (30 secs). Put it back in again and restart. Does that work?

sorry for being imprecise.

Its 2) When I boot the phone it says the “wifi is activating” but it is not coming on. The switch for the wifi is off and deactivated. The wifi symbol in the quick settings tab is animated like it would connect to something.

I even tried the battey-thing, but did not help :-/

Too bad, I was hoping that the firmware of the wifi just needed a restart. Do you have second device to test your Wifi?

Yes, the wifi-router is working - tested with notebook and another android based phone. The wifi of the FP does not even turn on so i could search for networks

Sound like a firmware issue to me or the wifi system. Else, do you know how to access the phones log files? (Usb or CatLog?) It would be interesting to know if all the services are working correctly and that they say about the wifi status. Currently nothing more comes to my mind ;(

Keeping the battery out over night and sleep a bit is maybe a good option right now :smile:

Great work, Bastif84! Oh … the topic was already closed, but could somebody fill a bug report against this stupid behavior of f-droid? Maybe there is a good reason for this, but I was not able to find something related to this problem in their issue tracker.

Bastif84 just told me he filled a report, thanks a lot!

I resolved the issue! With catlog installed, I had proper error messages to search for. The solution is in this thread post 15 from tobika. Somehow FDroid has a bug inserting wrong data those two files


I removed those files using the root explorer amaze. After a reebot, everything works fine again.

Many Thanks for helping!!