FP1 wifi app reacting in super slow motion

hey everyone,

i’ve been happily using my FP1 (very first edition) since it came out, have regularly updated the software and never had any major problems.

but for some months now the wifi app is reacting extremely slow whe i open it; choosing a hotspot, entering passwords etc all goes VERY slow to the point you think it might be frozen.

any ideas how to solve this?
is there a way to reinstall simply and only the wifi app?

thanks for your help!

This could be an issue with one or two files on your phone. Sometimes they get messed up and the easiest way to resolve this is to delete/move the file(s).

Read this carefully:

If you need further assistance, come back here, and ask the community again! :smiley:

thanks for your reply, but i’ve now spent two afternoons trying to delete that file, to no avail. tried to instrall and use adb shell, but hey, i’m not a computer nerd, and i could not get this file to be deleted, i always get a “read only” notice…

is there no simpler way to restore my wifi settings?
the phone works just fine, just entering new wifi spots is incredibly slow and sometimes freezes up settings (!).

thanks again.

Have you tried it with Amaze File Explorer? I think you need to activate “root explorer” in the settings before you can see system files.

i used x-plore, and i had not activated root access on that, thanks for the hint.
unfortunately i guess i had become a little too impatient and may have deleted the wrong files, cause now wifi won’t activate at all…
i guess that means i have to set my phone back to the original settings now, or is there a way to just restore the wifi app?
basically what i’ve been trying to do from my first post?

Hm this doesn’t sound good. Usually the phone should create the files anew, if you delete them. I don’t know what do do, if WiFi doesn’t activate at all… You might be able to extract the WiFi files from the original OS zip: https://fairphone.zendesk.com/hc/en-us/articles/201189497-Fairphone-OS-downloads-for-Fairphone-1-Fairphone-2 (be careful to use the correct version!).

thanks for trying to help stefan.
i’ve sent a help request to the support team now.

1 Like

OK, please tell us how they could help you afterwards.

so far the only help they offered was sending me links to general faq pages and making me resubmit my help request today…

but hey, i live in hope :candle:

Yeah, the general FAQ should help most people, but it won’t help in very specific problems like this one.

Hey, our apologies for not replying earlier to your request. I’m making sure you will receive an answer from us today. Thanks for your patience Surfling…!

thanks for your help, michiel. i did indeed receive a reply today!

not the one i was hoping for, but i kinda had expected it to turn out that way:

“1) The wifi settings is deep integrated in the whole system. So “just” to replace a wifi is is sadly not possible.
2) I dont see this here. So i dont have a fast solution, how i would proceed now:
a) I know you did ask to not reset your phone - but i would recommend it. If everything works fine, perfect.
b) If it does not work after the reset like it should we need to check it
here for repair. We saw some FP1 1st batch with serious problems with
the Wifi/Bluetooth/GPS Chips. So it might be a slowley failing Wifi chip
that just needs forever to find Wifis around your places.”

so i’ll do a reset next weekend and hope for the best i guess :slight_smile:

thanks again for your help stefan and michiel!

1 Like

so yesterday i finally got around to doing the hard reset and now everything works again. ufff…

thanks again for helping out stefan and michiel!