WIFI is connected but still doesn't work (O2 router Fritz-Box 6431)

Second Batch Fairphone - Updated to Cherry 1.6.
I rebooted many times, removed battery an SIM, tried everything out I read at the relevant forum threads (including emptying the google play store cache, but after a certain time it’s always the same: The WIFI bar turns from blue to grey and shows uploading arrows but it’s not possible to use the internet based apps. Could anyone help me please? It’s really annoying!
Maybe a useful information: After OS updating I sometimes recieved the message (in German): Google Play Store wurde beendet…?!

[Edit by @Stefan]
#The solution to this can be found here
KUDOS to @Frankenpfalz and @Sebastian

1 Like

Just to be sure. Did you reinstall Google Apps?

Yes, i did it several times.

Again to be sure. What is your modem showing?

My modem shows just green lights. And I use my WIFI connection right now to write this post at my computer. And had no problems at all with other devices.

What is the name of your modem? Is it an o2 box, Fritzbox, Homebox, D-link? look here for pictures

It’s an o2 box. But I don’t think it’s a modem issue. Do you?
In that case there would be problems with the other devices as well…?

There is a possibility that your phone hasn’t unrestricted rights in your modem.
Can you try your phone on another wifi?

Or go to the WLAN-page in your first mesagge. Tab on o2-WLAN78 and then on ‘Forget’.
Turn down completely your phone. Wait a minuut and restart.
Set up your WLAN again and see if there is any change.

I already did the WLAN setup after ‘Forget’ before. But now again: No change.
Sometimes it suddenly worked - but I can’t see on which fact it depends. And suddenly, it breaked down again.
And all the time it shows: ON and CONNECTED.

Is it possible that it has something to do with the WPA2 Key?

Hi @atispricht,

it is unlikely that the key has something to do with your problem.

Just take a look at this post and the thread in general.

Perhaps there is a general problem with some Fairphones and the wifi module.



Perhaps you could give this a try.

1 Like

Thanks stojmas, I already read this thread. There is no authentification problem. As you can see at the screenshot, I am connected to the net.

@Lidwien: Thanks to your advice. I have to go now but I’ll try it later.
At the moment, it works. But 2 minutes ago it didn’t. And it will break down again I fear…
I’ll let you know!
Thanks to you and stojmas for now.

Hey! I am dealing with exactly the same problem. No solution yet! Tried the tricks the support sent me.

  • used WPS to connect
  • hard reset several times
  • changed the mode to 300 MB n
  • changed the channel several times
    It only helps temporarily! Really frustrating!
    I also have an O2 Box. Mine is a Fritz-Box 643. Wirth any other wifi there are no connection problems whatsoever.

Hi @atispricht, @Flow,

I also experience this problem with the O2 Box 6431. I think the problem is with the DHCP client (dhcpd) on the Fairphone. My girlfriend does not have this problem, using another Android 4.0 based smartphone and the same router, of course (-; Someone else at computerhilfen.de supports that it’s a problem specific to Fairphone.

Unfortunately, I couldn’t solve it completely, but I’ve got a quite good workaround:

  • Change the DHCPv4 lease duration to the highest value (2 weeks), so this issue should occur quite less.
  • The static IP solution should solve it as well. Then you’ll also need to register the IP you’ve used in the router, so it will be reserved for only this device.

That is what I forgot and then wondered why just setting a Static IP didn’t work… Thank’s for pointing that out! :slight_smile:

1 Like

Thanks for finding a solution. Don’t mind me asking how I can register the static IP.

Oh! I found it under LAN on the navigation bar. Now I am hoping it works.

1 Like

Neither of the workaround works for me. I set the lease on 2 weeks and I put th IP on static. worked for a while, now nothing works :frowning:

@Flow how long is [quote]for a while[/quote]?

It is likely that some wifi-related files get reset periodically by the Fairphone (or some app) and thus produce the issue.

Do you have Google Services installed? (Question also to @Dominik, since it works with you).

Check the apps which have wifi-permissions and try to disable/uninstall them temporarily to see if the issue persists and is produced by a specific app. (Careful: Backup your app data.)