WIFI is connected but still doesn't work (O2 router Fritz-Box 6431)

I had the same problem yesterday in the morning while checking weather on YR. It reset itself. It worked again when I got to work as well as when I got back home.

I often have problem with wifi at home beacuse the router is almost out of range in the kitchen. The phone in that situation has hard to decide to use Wifi or not. But I Think this is th efirst time i see the gray bars on the WiFi Icon. Like it is working and not at the same time.

The bars of the WiFi can be grey or blue. The color of the icon depends on whether Google services are “connected” or not.

@Stefan The internet only works a couple of hours. When I leave the house it doesn’t work when I come back. I have only half successfully set the lease on 2 weeks. My expertise is very limited so I don’t know how to successfully set a static IP.

@Flow what exactly would you need to know for setting up a static IP? Look at post 11 to tell us for which part you need further explanation.

I have the exact same problem. I received my O2 Box 6431 a few days ago and never had the issue before, so I assume that the problem is with the O2 Box. Maybe we should just all buy a new router? Has anybody tried that?

Hi to all,
same problem here!
I have this f***** o2 box as well and my Fairphone (2. batch) shows the same behaviour in this network. :confused:
Whenever I’m in other networks (university, at friends) it works perfect. No connection problems or any strange behaviour at all.
As soon as I come to home the grey wifi bars appear again. The phone tries to reconnect all the time and consumes lots of battery therefore…

My assumption is that it has something to do with the COMBINATION of o2 box and Fairphone because I have no problem using the network with other android 4.x devices.

I tried all forementioned workarounds without success…
Hopefully somebody comes up with a solution soon!

Edit: I forgot to mention that sometimes the MAC-adress of my Fairphone is not correctly recieved by the o2 box when the phone shows the grey bars behaviour. MAC-adresses of other devices appear in the webinterface as they should.

I have the same problem, but only figured out just now it was connected to O2 routers. I have had this problem out friends houses months ago already, but never wondered why it didnt work. Now I have O2 myself and everything is f****d. What do we do?

Write a complaint to O2. Tell them that they should fix the problem or provide a new router. If they give you a new router and it still does not work, ask for another. If it sitll does not work ask them to send another brand, or you will quit the contract, since they do not provide the service advertised. If they refuse, quit the contract and get a new provider.

Be sure to check, if that is the legal way in your country. I can only speak for how it works in germany: Complain, let them try to fix the problem twice. If they fail the third time you may quit the contract even if it normally would run longer.

@ace28, as soon as you mention that you only have a problem with one specific device, you are screwed: they just provide you with a WiFi-enabled modem/router. What happens with your devices is, sadly, your problem. Even if it’s a general problem with their router, having problems with only one specific device that you, by (bad) chance, happen to own.

(However, it’s worth a try to get another model from them, nevertheless!)

Just FTR, can anyone enlighten me about the manufacturer of the router in question (6431, that is, right?)? Is it really a re-branded FritzBox, as seem to be implied by @Flow?

I do not think that you have to tell them that is only one device. I would simply tell them “My device does not connect to your router, and it is the same at a friends house where the same router model from your company is running. So please give me another model.”

I renamed the topic to make it easier to find for others, who also have troubles with the O2 router.

I just tried solving this via the O2 customer service chat and they told me to call their technical support service. Of course for this I need to be at home (now I’m at work). I’ll try tonight and let you know how it went. If anyone is impatient and wants to try now, the number is 0800 5251378 (Germany) :wink:

1 Like

OK, so I called them. You can get a different model router from O2, but it’ll set you back 69 Euros. It’ll be what the support service guy called a “Home Box” which is supposedly a model up from the O2 Box 6431 we all have. No idea whether it’d work with our FPs. So I asked him if I could just connect my old Alice router again, which used to work perfectly with my FP. He said no, because they changed the dial-in protocol, but apparently you can connect it to the O2 box via cable and use it as a sort of wifi booster. So I’ll try that one of these days (again, I’ll report). The other option is an actual wifi booster, which costs money but is still cheaper than the O2 Home Box.

There’s no guarantee either of these will work, sorry I can’t be of more help.

1 Like

My girlfriend is using a Fritz-Box (router) for the wifi. She simply connected the Kabel Deutschland router directly to the FritzBox and let it do the rest.

She did this because if she wanted to use the Kabel Deutschland wifi (the router is capable of providing wifi) it would cost her a monthly fee.

So maybe it is possible to connect a wifi router (of any brand?) to the O2 internet router.

At least other, unaltered, Fritz-Box routers should do the job.

Who knows how O2 changed their Fritz-Box 6431…

1 Like

I am in Germany for a couple of days, in a rental apartment with an O2 router. Because I face exactly the same problem as described here, I am checking the forum. No solution so far - I am not going for the static IP and all that since I am going home in 2 days. I was hoping to make use of free wifi in public places, but these seem to be limited too here.

Hi,
I had this problem too. This was the only thing that worked for me:
http://hilfe.o2online.de/t5/Router-Software-Internet/Ständige-Verbindungsabbrüche-mit-O2-BOX-6431-WLAN-Problem/m-p/801198/highlight/true#M57367

You have to go to the configuration site of your o2-router. Than in the firefox menu go to “Ansicht” - “Webseiten-Stil” and choose “kein Stil” (sorry, don’t know how this is named in english). There you can change the WiFi mode to 20 Mhz. This should solve your problems.

2 Likes

For some strange reason, for me the problem has fixed itself. I did nothing but it has been working by itself for over a month now. I sometimes get the grayed out wifi icon, but then I just restart the router and it works again. Not sure why, but this is why I haven’t posted about my experience with another router - I didn’t end up getting one.

1 Like

I set this topic on autoclose. If nobody else is experiencing troubles with this type of router, the topic will close in 10 days.

Don’t close the topic yet. The Wifi Connection Problem with the O2-Router occured about 2 weeks ago on my phone. So far I didn’t solve it. I wasn’t aware that so many people are having the same problem (everything as mentioned in other posts, except that very few times a day my WiFi works).
I would like to try the solutions mentioned above tomorrow. Would be nice if you wont close it until than. Thanks!

2 Likes

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.