Can't connect to wifi

I’ve just recieved my fairphone and it can’t connect to wifi. I’ve tried everything! Any idea??
thank you so much

Hi @marta

A little more info would be helpful :slight_smile: In what way can’t you connect to wifi? Don’t you find any networks? Do you get an error message? …

Kind regards


Hi Robin, sorry…I get an error message, the authentication. I can find the net, I write the correct password and it’s impossible to connect :frowning:
thank you!

Hmm I’ve seen something similar on this forum. The solution was in fact that this person wrote his password wrong every time :slight_smile: Perhaps you want to try it again, there’s an option to show the password you’re typing.

Also, if this your own WiFi, and this is still not working even if the PW is shown and you are sure to have typed it correctly, you could try to remove the PW for a moment, i.e. create an open WiFi, and try to connect again.

BTW, what kind of error message do you get?

I’ve typed correctly, I’m sure of that. The message is in Spanish and in English will be something like “Authentication error”.
The phone detects the net, it says “keeping” and then “Authentication error”.

By the way, in an old Fairphone forum I’ve read some messages with the same problem, even people saying they couldn’t use wifi at all, so they couldn’t download any app…I’m sad… :frowning:

Hello @marta,

do you know the Model/Name of your router (may be printed on it)?
Maybe it has a WPS Function. In this case you wouldn’t need the password.


Hi Shiny,
In the router I have printed WPA / WPA2 / PSK but no WPS. So I guess I have to find another solution.
Thank you very much anyway!

Did you possibly de-activate DHCP on your router? Or restrict it to certain MAC addresses?

You can also login to your router and look at the log there - it should tell you if a device tries to connect, and fails. Maybe, the log can give us a hint why the connect fails.

@humorkritik, I’ll investigate this, thank you.
@Shiny asked me before about the name and model of the router:
Name: Home Gateway
Is it useful??
really, thank you all for your help!

Hello again,

sorry, I set a wrong Link. At the correct Article you will find a Photo with a usual WPS Symbol under the blue button. Can you find a Symbol like that on your Router.


I just looked it up, it should have WPS, according to the instructions. Button on the side, Nr. 1 in the diagram. Push this for > 1 sec, until the WPS light blinks. Then, at your Fairphone, push the arrows in the lower left corner of the WiFi menu. Wait up to two minutes. Should be done, then.


Thank you so much @humorkritik. I couldn’t find the button and I called the company and they confirmed me I don’t have the WPS function…they can send me another router with the WPS but…ups…I guess I have a big problem.
I will try to contact Fairphone and try to find a solution.
Thanks again!

Then you apparently don’t have the HG532s, which has WPS, at least according to the manual I could find. Anyway, did you try to turn off your WiFi password, effectively creating an open WiFi?

If you still can’t get it to connect on an open WiFi, there might be other problems with the WiFi (and not your phone) still: if there are many overlapping WiFi networks on the same channel (as often happens in larger cities…), connectivity can be terrible. You could then try to choose another channel, manually.

If there is a problem with your phone, you will also not be able to connect to other networks. As Strbucks and McDonlds are basically everywhere, and offer free WiFi, you could go to your next dreadful fast food corner and try to connect to their network.

Hope that helps. :sun_with_face:

I think I have a similar (the same?) problem. I received my phone on Saturday and was able to use the WiFi on Sunday. I installed the updates, some apps, and suddenly the WiFi just stopped working. I’m not quite sure if this happened directly after the last update (I have Android version 4.2.2) or some time later.
What happens:

  • I see the network. Sometimes I have full, sometimes I have ok connectivity (even if I’m sitting just next to the router, before the problems started I always had full connectivity). I also see other networks. But like with my network, the connectivity seems to be “jumping”, I see them, then they are gone.
  • I select connect. Directly after this, mostly I can’t see my network anymore. Or it tries to connect, then I just get the message “authentification problem”.
  • When trying WPS, under my network SSID the text “deactived” appears.
    What I have tried:
  • Like mentioned above, I’ve tried WPS.
  • I found some people mentioning the use of the airplane mode and then enabling WiFi again.
  • I changed the password into a shorter one.
  • I changed the encryption (from WPA2 to WEP to completely open).
    Any other suggestions would be appreciated :confused:

Hi Noctima,
What I tried and it worked was to go to the bar next home that has WPS and I could install some of the apps. But it still doesn’t want to connect to my router. I will try some of the things you mention just in case because I can’t use my fairphone normally…I’m worried…
Good luck and thank you very much!

Hi Noctima,
just to get this more clear:

  • you have an FP1U (not a FP1),
  • you have Stock Android aka AOSP (not Fairphone OS) installed,
  • you changed the encryption on your router, so you have a open WiFi,
  • you can connect to this open wifi (and others), but are loosing connectivity after some (apparently random) time interval?

Can you give us some info if there are very many WiFis visible when you search for your WiFi? (“Very many” would possibly translate to > 6).

Hi humorkritik,

no, it is a FP1 model with Fairphone OS (I only applied updates). I tried different encryption modes on my router (including WPA2 and open) but I can connect neither to the open nor to the encrypted network. Irregardless of the employed encryption I receive the “authentification problem” error message. As for the number of detected WiFis, it varies from zero to approximately eight. As mentioned above, my own network might indicate full connectivity, and a moment later it’s gone, even if I’m sitting next to the router.

I hope this answers your questions! Thanks for your help!

If even the connection to the open WiFi fails with the error message “Authentification problem”, then something is seriously wrong.

Seeing 8 WiFi’s actually could cause problems in connectivity, as it would be ideal to leave two free channels between each WiFi. (If your router allows it, you could, however, try to go to channel 12 or 13, which are often turned off in many routers due to restrictions in the US.)

Nevertheless, even with 8 WiFi’s you should not get this error message.
I guess you already tried to reboot your phone several times. You could boot it to factory mode an test the WiFi.

  1. Turn it off.
  2. Hold volume down + power button.
  3. navigate with volume down to Test Report
  4. choose Test Report with power button
  5. navigate with volume down to WiFi
  6. choose WiFi with power button, try to get a quick glimpse at the output (vanishing fast)
  7. check if WiFi gets an red X or a green 0.

If the WiFi is working properly, you should get the green 0.

This is just a general connectivity test - I did not sniff on it, log it or anything, so I don’t know what actually is done. Probably it’s just a handshake, bur if this works, you should, at least in theory, be able to connect and maintain a connection.

If you get a red X, you definitely should get in contact with support - can’t help you there. If not so… I’ll have to think of something else. Already got a faint idea … :signal_strength: