Can't connect to wifi

Hi Noctima,
What I tried and it worked was to go to the bar next home that has WPS and I could install some of the apps. But it still doesn’t want to connect to my router. I will try some of the things you mention just in case because I can’t use my fairphone normally…I’m worried…
Good luck and thank you very much!

Hi Noctima,
just to get this more clear:

  • you have an FP1U (not a FP1),
  • you have Stock Android aka AOSP (not Fairphone OS) installed,
  • you changed the encryption on your router, so you have a open WiFi,
  • you can connect to this open wifi (and others), but are loosing connectivity after some (apparently random) time interval?

Can you give us some info if there are very many WiFis visible when you search for your WiFi? (“Very many” would possibly translate to > 6).

Hi humorkritik,

no, it is a FP1 model with Fairphone OS (I only applied updates). I tried different encryption modes on my router (including WPA2 and open) but I can connect neither to the open nor to the encrypted network. Irregardless of the employed encryption I receive the “authentification problem” error message. As for the number of detected WiFis, it varies from zero to approximately eight. As mentioned above, my own network might indicate full connectivity, and a moment later it’s gone, even if I’m sitting next to the router.

I hope this answers your questions! Thanks for your help!

If even the connection to the open WiFi fails with the error message “Authentification problem”, then something is seriously wrong.

Seeing 8 WiFi’s actually could cause problems in connectivity, as it would be ideal to leave two free channels between each WiFi. (If your router allows it, you could, however, try to go to channel 12 or 13, which are often turned off in many routers due to restrictions in the US.)

Nevertheless, even with 8 WiFi’s you should not get this error message.
I guess you already tried to reboot your phone several times. You could boot it to factory mode an test the WiFi.

  1. Turn it off.
  2. Hold volume down + power button.
  3. navigate with volume down to Test Report
  4. choose Test Report with power button
  5. navigate with volume down to WiFi
  6. choose WiFi with power button, try to get a quick glimpse at the output (vanishing fast)
  7. check if WiFi gets an red X or a green 0.

If the WiFi is working properly, you should get the green 0.

This is just a general connectivity test - I did not sniff on it, log it or anything, so I don’t know what actually is done. Probably it’s just a handshake, bur if this works, you should, at least in theory, be able to connect and maintain a connection.

If you get a red X, you definitely should get in contact with support - can’t help you there. If not so… I’ll have to think of something else. Already got a faint idea … :signal_strength:

By the way, @marta, your case seems different, as you could connect to another WiFi properly. I don’t want to annoy you, but have you triple-checked and then again quadruple-checked (with “show password” activated) you’ve got the right WiFi key? The fact that you could connect to a WiFi with WPS clearly indicates that your WiFi modem is working.

You also did not answer the question if you were able to remove your WiFi password from the router (creating an open WiFi), and then connect.

Hi humorkritik,

I’ve tried the WiFi test in the factory mode. Unfortunately, I get a timeout and the message that “No suitable AP” was available. Could it be that something went wrong during the updates?

Thanks again!

I take it that you get a red X with the timeout?

“No suitable AP” actually means there is no access point, meaning: no available WiFi Network. If you report that there are up to eight, it should at least see one? o_O

I’m going to try that at somewhere where I can easily manipulate the WiFi. Maybe, it only tests connectivity on open WiFi, not on secured ones. Should have seen your open WiFi, then.

Just for the fun of it, you could get Fing from GooglePlay, and try out what it gives you if you choose Discover Wi-Fi. If it’s unable to connect at all, you will get a stupid error message sending you back to the WiFi settings - but if you are able to connect, you should be able to explore the network a bit. (Not that this would help you with it’s output, really - but it would show your modem works.)

I’ve tried the report again after changing the encryption back to open: no network available, connection timed-out, no suitable AP… but neither X nor 0. I’ve also just realised that bluetooth isn’t working anymore, so I used the test report on that one, too, and got the red x. I guess something is really wrong and I should contact the support. If I get an answer that might be of interest for others I will post it. Thanks again for your help.

Nothing heard from you in a while. How are you and @marta doing these days? Still troubled by WiFi connectivity?

I’ve contacted the Fairphone support and, in addition to the other suggestions, have even tried a hard reset. Unfortunately nothing worked. I’ve received a new phone two days ago, but haven’t installed any updates yet. But im positive that it will work this time :slight_smile: Thanks for your interest, humorkritik.

I have problems with wifi as well and tried this procedure. what if I get nor a green 0 nor red X?

Cheers Peter

Uhm. How is that even possible? You are sure you started the test?

yes I’m sure. WIFI does not work since days, Support is not answering. In Forum people with same problem, but no solution… This is really annoying.

I feel for you.

When I contacted them some time ago, I got an auto responder with a support ticket number, and a reply 13 minutes later. If you got a ticket number, you should also be able to contact them by phone, I think.

On the subject of the factory tests: do any of the other tests give you results?
Did you try running a full test of all components?

I have the same problem with wifi. I can’t connect to different wifi providers cause of authenticate problem. Fill in the password correctly. By testing wifi in factory mode, no red or green message but the message with ‘No suitable AP’.
I’ve tried to call the support but they don’t answering the phone… Don’t know what to do now…

Thanks, humorktitik¨
I did a hard reset twice now, and after this there is still no connection to wifi, I can’t even see a network (which exist a lot, believe me).

When I use the Wifi switch (trying to to turn it on), it jumps back to ‘off’. And by the way the same with bluetooth…

When I do the full test (auto test) it goes till GPS, says ‘GPS failed’ -6 (then I have to remove the battery because phone does not react on any button…)

Cheers, Peter

@Peter_Goldi, sorry to reply with this lag. Your problem sounds like a hardware failure, if I’ve ever seen one!

I would contact support and ask them to repair the phone. If this just happened by updating the OS, it is very odd. I would expect that the phone dropped and some connector or soldering was damaged, but then, you don’t write about anything like this.

(@alex1, any luck reaching support until now?)

1 Like

Thanks for your answer. Support contacted and phone sent back. Will get a new one!

1 Like

@humorkritik: Yes, last week I had contact with the support and I’ve sent the Fairphone back. They will repair the phone and sent it back within 15 days. I’m curious of what the solution is for solving the wifi issue… I’ll let you know, thnx