English

Using LineageOS on the FP2

Does the Dual SIM feature work yet? If so, I would move from FP Open to Lineage on Friday evening… :slight_smile:

I’ve just tried the first time since I’d switched to LineageOS, no problems here.
Is there anything special I might try that possibily cause problems?

Works for me on the latest build (from LineageOS 14.1 with OTA updates for FP2).

1 Like

No, just receive and make calls. Thanks.

no problems encountered

(I just would have written “works” but the forum tells me to write at least 20 signs :wink: )

If you don’t want to use adb you can also use TWRP to copy the file. I did this with the NetworkLocation.apk and it worked well.

Hey, everybody. A screenshot of the initial wizard setup with the logo centered would came handy to make a splash screen.

PM me one while you enjoy using such a great OS, :slight_smile:

3 Likes

After having used the first version of Lineage for a week or so, I had to send my display for a replacement.I do have my display back and have updated Lineage through OTA updates.
Unified NLP works perfectly. I moved it to the system/priv-app folder using TWRP.
I am very happy with the results.
The ONLY thing I am missing is the Fairphone Ringtone. :slight_smile:

2 Likes

2 posts were merged into an existing topic: Official Fairphone Ringtone!

I am using LineageOS on my FP2 since a few days now, and so far without any problems. :slight_smile:

I formatted the SD-card as internal (adopted) storage and was surprised that the storage is then automatically encrypted. This is great and works well for me.

But there is also a downside and a warning for all who want to use the SD-card as internal storage: since the storage is encrypted, there is no easy way to access the data from the SD-card slot of your computer. You will need a Linux system and some experience with the Linux command line (more info about this e.g. here or here). You should also backup the key from /data/misc/vold since this is the only chance to get access to the data on SD-card if something breaks the system on your phone or you did a factory reset.

2 Likes

I’m using Lineage for 1 day now and have two questions:

  1. I keep having the info thatn WiFi is connected, but no internet - but the internet still works. Does this have to do with the MAC-Problem? (See pic: WiFi with x)
  2. In my status bar I have the hashtag-icon. Where does this come from?

The hashtag icon says, that an app has root access this moment.

2 Likes

The only issue I face is this:
Call Volume too high even on lowest level. This is a known issue which will be investigated and should be fixed with the next Update of Fairphone OS or Fairphone OpenOS.
And then, with the new modem files, it should be fixed on Lineage OS as well, right?
:slight_smile:

Is the non-working UPnP a LineageOS or a general Android 6 or 7 issue?
I did not notice, if it was working with FP Open and Android 6.
Anybody with a different device with UPnP working?

A post was merged into an existing topic: LineageOS 14.1 with OTA updates for FP2

Lineage uses the Trebuchet Launcher - which is fine. On my old FP Open OS with the FP-launcher you could assign a different launcher to a click on the home-button. I added KISS-launcher there to quickly search for contacts (sadly not music). Is this possible on Lineage aswell, or do I have to install the FP-launcher again?

A single tap on the home button will always get you to your default launcher, which you can define any way you like.
You can also set KISS as your search app so it will be started on long pressing the home button (or define any other activity).

Found it. Thanks a bunch.
For all:
Install KISS-launcher. Then press home button. It offers the choice of Trebuchet or KISS. I chose KISS. Then Settings --> Buttons (Tasten) --> Home (long press) --> choose “search assistant” (Suchassistent). The next time you press long on the home button you can choose between KISS and G&&gle.

1 Like

I have installed the latest build on two of our company phones. Here my experience:

First Fairphone contained latest fairphone Open OS. Installation all went fine. Problem arised because the phone did not contain a simcard. I set up wifi, but the first time setup allways crashed after the date/time setup and restart itself. I could only get further when inserting a simcard.

Second Fairphone contained normal Fairphone OS, latest build with a quite a few installed apps. I therefore installed Titanium Backup and made a backup of apps and settings on an external sdcard. I installed Lineage and wiped according to description. Start worked, but I could enter the sim pin correctly (T-Mobile Germany). I repeatedly was shown a message, that there was a problem unlocking the phone with the sim. The pin was correct, I tried it a dozen times and did not receive any message that I need to enter a puk. I could also put the sim in a different, also lineage powered non fairphone and there it worked on the first try. I tried it with a vodafone card, which worked perfectly. Retrying the T-Mobile card (which is half a year old and has so far worked without problems in a few different phones). Next problem was that Titanium Backup could not access the simcard (I am sure the sdcard is fine) to reinstall the backuped data and files. Since the T-mobile problem was there to, I reinstalled the backup of Fairphone with Android 6 via backup in TWRP which worked without problems.

Hope this report is of any use. If there are any questions, I will try to answer them. In general: I like it, you have done great work!

I had the same problem with the crashing setup app when no SIM Card is inserted.
I deleted the Wifi-Connection and jumped over wifi setup step.
Setup App finished successfully and after that I connected to my wifi again.

To the developers:
The LinegageOS is really great. Now I’m very happy with my phone :slight_smile: Thank you for your work!

3 Likes