Using LineageOS on the FP2

I downoaded and updated and I also note the missing brightness behaviour.

Additionally Encrypting doesn’t seem to work. Whenever I hit ‘Encrypt Phone’, the phone just reboots and nothing seems to happen.
This happened on first install as well as after the OTA update.

Edit: At least, I expect the phone to mention it is encrypted in the settings menu. However instead, I can just do the scripting procedure again, with the same result.

1 Like

If you are on the OTA-update version, just download 20170708 from here.

I’ll remove the latest build.

1 Like

Hi, I succeeded to do the fastboot method as mentioned in “LineageOS 14.1 with OTA updates for FP2” :smiley::smiley:. Tnx to @Johannes!

Unfortunately now, after I tried to flash the modem zip and and the latest LOS zip (20170708), my phone fails to install. It says:

‘Zip file is corrupt!’
'Error installing zip file ‘external_sd/’

Beside that, it couldn’t find the MD5 file.

I presume I shouldn’t reboot my system right now?

tnx again…

ZIP and MD5 can be found here:

You can transfer files from TWRP with MTP and then retry flashing all the zips.

1 Like

tnx @snevas. I put the MD5 file on my sd-card, but when I put it back in my phone and tried to install again I couldn’t find the MD5. I still tried to flash again, but again I couldn’t flash.

I didn’t transfer the file from TWRP with MTP. I don’t know how to do that, although I tried to find out. Maybe that’s the reason that I can’t find the MD5 file on my sd-card in TWRP? Although, that would be strange, since I can see the other zip files in TWRP while I I didn’t use MTP to put those on my sd-card…

I hope anyone can help me out, that would be great :slight_smile:

Edit: Could this be the reason: ‘Android can choose the files it presents to you, and hide system files so you can’t see or modify them. If you attempt to delete or edit a file that can’t be modified, the device will refuse the request and you’ll see an error message.’? (

Edit 2: 27072017 - I tried to transfer the md5 file with adb push, but it didn’t succeed. I constantly get the following answer:

-bash: ./adb: No such file or directory

the last command I used was:
./adb push C:\ /sdcard1

I put the file directly on the Mac HD…

Edit 3: pfff… sorry guys, ofcourse the file was on my sd-card of my phone the whole time (I saw I could check it in TWRP via ‘Advanced’). Transferring via TWRP or adb wasn’t necessary. But well, I still got the same problem, which I wrote down in my previous post.

If anyone can help me out… tnx!

Edit 4: Problem solved!! :grinning::relaxed: I solved it in the end by NOT queueing the modem zip and the lineage build and then flash, but by flashing them one by one. So, in my case step 3 and 4 of ‘When coming form any other OS’ (LineageOS 14.1 with OTA updates for FP2) should be done differently as is described there.

I have a reproduceble bug in the latest Version from 8.7.2017 with dual SIM cards.

My config looks like this:
SIM1 = Telco1
SIM2 = Telco2

Mobildata = Telco1
Telefon = Telco2
SMS = Telco2

After every reboot the SMS is switched to Telco1 :frowning:

Can someone confirm this?

Same issue for me… with an older version: 14.1-20170626-UNOFFICIAL-FP2

Good to know that I’m not alone. Perhaps someone with more development skills like I do have the same problem. @chrmhoffmann @z3ntu

I have the same setup, but this does not change at boot (so probably it’s dependent on the operator/sim)

I had an issue with UnifiedNlp not completing the self-check succesfully (The registration in the system never completed). I had this fixed by moving the backend and UnifiedNlp to system with the Link2SD app (suggested by Snevas).

An alternative is to use Terminal (with root permission), as suggested to me by dedareit. I have not tested it, so I am not sure it’s still 100% correct after I reformatted it in a more readable state:

  • Open Terminal with root permission
  • $ su mount -o remount,rw /system
  • $ mv /data/app/APP /system/priv-app/
  • $mount -o remount,ro /system
    (Replace APP with the name of apps directory, which you can look for with $ls /data/app)

I just thought I post it here in case anybody else encounters this.

The best way is to follow this:

Thanks to @Roboe.

This way, you do not have to worry about making unified Nlp as a system app after every update.

Works like a charm for me.


Did anyone flash the unofficial sdk25 zip file for android 7.1.2 from purify? I don’t understand why there are no zip files for arm / arm64 / arm86.

Edit: Can I consider it to be safe to flash the zip file? The other sdk’s didn’t do the job.

As stated in the article you linked to, I wouldn’t try it without making a nandroid backup in advance.

1 Like

Realy? Do you use SIM2 for SMS?

Same here.

My usual config is:
Cellular data: SIM1
Calls: SIM2
SMS messages: SIM1

For testing I switched SMS messages to SIM2 and did a reboot. Afterwards SMS was indeed switched back to SIM1.


@snevas I also switched the SIM cards to test if it depends on what SIM card is in which slot. But it doesn’t. I set SMS to SIM2 and again after reboot it was switched to SIM1.

I’ll look into this. I have removed some brightness properties from the overlay. Maybe too many :slight_smile:



Hi all,

Xprivacy doesn’t work like it should work. After installation I get the following text:

‘An internal check failed, do you want to send support info?’

Xposed gives me the following text: ‘could not load available zip files. pull down to try again.’

I tried to find out what could be the solution via and, but I really don’t understand it so I don’t know if there is the solution for my problem.

I thought the problem might be solved through a new installation of xposed, because Xposed installer (v3.1.1) gives me the following text: ‘could not load available zip files. pull down to try again.’

I installed the xposed framework (sdk 25 by Purify) again which didn’t help.
After that I did a reboot in Xposed installer. That didn’t work. I did a soft reboot. That didn’t work out either.

After that I made a factory reset, installed lineage again, installed xposed again and finally xprivacy (v3.6.19).

Could it be that Xposed Installer doesn’t support sdk25 right now? Is it a bug in Xprivacy? Or is it more probable that there is another problem which needs to be fixed?

Edit 19 08 2017: I installed x-privacy some time ago again to check what kind of permissions user and system apps do have besides the permissions Privacy Guard shows. I get the same message ‘An internal check failed…’, but It seems to be working fine.

  • There is no official XPosed for sdk25 for now. So neither the XPosed Installer nor XPrivacy “support” sdk25.
  • It was never a good idea to install XPosed on Cyanogenmod/Lineage OS. The Cyanogen Bugtracker didn’t accept bugs from devices with XPosed.
  • In my opinion there is no need to have XPosed/Xprivacy with Lineage. It supports everything I need. Which features are missing for you?
  • XPosed was always a crutch. It’s far better (also for security) to live without. I used XPosed with FPOS because there were so many advantages, but I don’t see any reason to install it over Lineage.
  • XPosed is very deeply integrated into the OS. I don’t trust a random developer from the internet, this unofficial version wouldn’t be an option for me (if I wanted to install it).


I had my doubts about that too. I wanted to use it, because of all kind of (personal) information apps can send ‘home’ and (sell it) to third (advertising) parties.

So, you just use Privacy Guard? Or do you use other privacy apps like Netguard / Net monitor, and/or a firewall (something like Afwall+)?

Edit: It’s a pity (?) that FPOS did not support App Ops in the end as one can read in this thesis of Maarten Derks ‘Fair Privacy: Improving Usability of the Android Permission System’

AFWall+ and the integrated privacy options in Lineage OS.