Upgrading from *official* 14.1 to 15.1 (feedback/issues)

any news on the one. According to tot the fairphone bug tracker it seems to be solved but there isn’t any update on the LineageOS bug tracker.

It was solved in the bootloader code for the Fairphone 2, so I think there’s nothing to solve in LineageOS itself.

In the bugtracker @borjan notes:
"Solved with 18.09.2.
Please note that you will have to use the manual archive to flash the bootloader partition - the update file does not provide the fix."

I just did the following for my LineageOS 15.1 to check whether it actually works (the bug didn’t bother me much, so I didn’t check until now), which it does, so …

  • Boot the phone into Fastboot mode
  • Extract the manual archive fp2-gms-18.09.2-manual.zip from here to somewhere on your computer where you can find it
  • Open a cmd or shell
  • Go to the directory where you extracted the archive
  • Make sure fastboot works for you in this directory with fastboot devices
  • Windows cmd:
    fastboot flash aboot "images\emmc_appsboot.mbn"
    Unixoids shell:
    fastboot flash aboot "images/emmc_appsboot.mbn"
  • When done, fastboot reboot

I will check tonight and report back

when I click on here I end up at Fairphone OS downloads for Fairphone 2. So you want me download FP2 - Binary images of Fairphone OS 18.09.2 what has the file name fp2-gms-18.09.2-manual.zip.
I sit behind a very slow internet connection currently. Would you mind to upload the emmc_appsboot.mbn, if this not the only file in the archive, either here in the bug report?

that worked out well :slight_smile:, I updated the bug report, including a extended guide
by the way you can now get fastboot etc. as standalone tools: https://developer.android.com/studio/releases/platform-tools.


TWRP 3.2.3-0 can’t decrypt an encrypted LOS15.1.
i created an issue on github:

is anyone working on this?

a workaround exists, thanks to AnotherElk by upgrading from 14.1 first (Updating LineageOS 15.1 for microG via TWRP + feature test)
but this is not a good solution for the regular user (&not based on the current 8.1 encryption)

1 Like

who is the maintainer of TWRP FP2? As looks like that only an update from 3.2.3-0 to 3.2.3-1 is necessary.

According to Fairphone 2 it’s still @z3ntu … but it seems he had to do something good for the remaining Fairphone 1s first :wink:

Last time I checked, devices which already got TWRP 3.2.3-1 were the minority anyway, so patience seems to be asked of us …


So what I know:

The 3.2.3-1 version that is available for some devices is a rebuild of version 3.2.3 but with an updated device/kernel tree.

I asked what was changed in the devices that got the -1 build but I only got vague answers from the TWRP maintainers. I’ve looked into the issue on the FP2 multiple hours trying different things that didn’t help at all unfortunately.
Basically I don’t know what part is broken so i can’t fix it…


it’s a pain

thx for the effort let’s hope that it will be found, somehow…

After a couple of months, here some experiences on various shortcomings with LOS 15.1
Roughly in order of annoyance

  1. The notorious ‘no shutdown bug’ - variously covered in other threads
    The workaround with the torch doesn’t work always (seems random)

  2. If phone is off, charging via USB & computer drains(!) the battery

  3. Image updates do not install properly. A manual reboot into TWRP is necessary.

  4. Occasionally the dual-sim settings & proximity sensor calibration are lost after reboot

  5. Rebooting while charging via USB seem to make problems (e.g. hangs on boot, …)

  6. Occasionally pugging in/off of headset activates the music player

  7. No possibility for groups in contacts

1 Like

Can you observe whether the workaround does not work when the phone is connected to charger/USB and/or Bluetooth is enabled?
Those circumstances had an impact on the workaround for other users.

These two problems are not normal.

If you happen to have fairphoneangels in your vicinity, they might be able to check whether your bottom module may be faulty by swapping it and seeing whether the battery drain persists.

Else … a general troubleshooting step with modules is to disassemble them (here’s a video), clean the contacts on the respective module and the core module with alcohol, and then re-assemble the module and try again.

Same workaround as for shutting down, else automatically rebooting into the recovery (without keeping Volume + pressed at reboot) will not work.

I can’t say anything about Dual-SIM, but I never lost proximity sensor calibration after a simple reboot.

General question: Did you upgrade an existing LineageOS 14.1 installation, or did you install LineageOS 15.1 from scratch (incl. wiping the phone)?

Thanks for taking the effort going through all the issues.

No, never during any charger/USB connect. Don’t use Bluetooth presently.
For my feeling it occurs purely random. Some times the workaround works works for ~10x in a row. Then I get even 2 reboots before successful shutdown.

Thanks for the detailed advice.

My understanding was that direct upgrade 14.1 → 15.1 is not possible. (Was discussed in some forum or in some installation guide, I guess). So, wipe & from scratch.


For me an upgrade from 14.1 to 15.1 worked very well.

And I solved the non-working upgrades from the LineageOS updater with enabling the torch just before pressing the install button. Both this and the shutdown problem must be related.

Today I had a spontaneous reboot. Added it to the bugtracker.
For reference, this was (among others, see bugtracker) in last_kmsg:

synaptics_rmi4_sensor_report: spontaneous reset detected

and lots more with synaptics and I2C,
then, later:

Unable to handle kernel paging request at virtual address 010210b4
pgd = dae00000
[010210b4] *pgd=00000000

Internal error: Oops: 5 [#1] PREEMPT SMP ARM
Modules linked in:

CPU: 0    Tainted: G        W     (3.4.0-perf-ge616a4e #1)
PC is at scheduler_tick+0xfc/0x144
LR is at scheduler_tick+0x44/0x144
pc : [<c01e3ed4>]    lr : [<c01e3e1c>]    psr: a0000193
 sp : e7a73c88  ip : 00000000  fp : e7a73c9c
r10: b0a1ff3c  r9 : 0000200f  r8 : b0a20557
r7 : 00000000  r6 : d816c600  r5 : 00000000  r4 : c3185800
r3 : 01021070  r2 : 00000000  r1 : d816c600  r0 : c3185800
Flags: NzCv  IRQs off  FIQs on  Mode SVC_32  ISA ARM  Segment user
Control: 10c5787d  Table: 1ae0006a  DAC: 00000015

Edit: I’m on 15.1-20190320


Just wanted to leave here (seems to be the proper place) that I am very happy with 20190320 LOS, works like a charm :slight_smile:

I also had a reboot with 20190320, if I every find my island of stability I’ll stay there
I don’t have logs of this reboot, bc there was no time for it

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.