LOS update problem via TWRP

TWRP 3.2.3 is released:

  • Fix automatic installing of OTA zips on encrypted devices
  • Remove SuperSU from TWRP
  • Support both md5 and md5sum file extensions when doing MD5 checking for zip files

I’m not sure if it belongs in this topic, but I have the problem that I can’t enter anymore the recovery mode.

Last week I did the upgrade to LOS 15.1 and wanted to update to this weeks update of LOS today, but couldn’t install anything because it seems like I can’t enter TWRP anymore? Afterwards the failed update, my FP2 simply rebooted instead of enter the recovery mode, so I tried to reboot into recovery without the LOS updater app, but even this didn’t work.

So I’m not sure what is wrong? Do I need to reflash TWRP or did I brick something?
In LOS everything seems to work, at least I didn’t imagine anything wrong.

before the update to 15.1 I installed the latest version of TWRP.

@Roboe, @z3ntu, @AnotherElk: any ideas?

Please confirm … if you press Vol + all the way through rebooting (from the moment the screen goes blank to the moment TWRP appears) … this doesn’t work?

If in doubt, you can do this anytime.

Well, there’s always booting TWRP without flashing it …



Hi @AnotherElk

the guide to boot into recovery without flashing doesn’t work for me, because similar to @bastoGrande my phone after flashing last weeks’ LOS 15.1 can now only reboot into OS.

Any adb reboot recovery or adb reboot bootloader (or power + Vol+ or power + Vol-) always results into booting OS instead. Even when using the previously installed TWRP app I experience the same problem.

fastboot doesn’t recognize the phone when OS has booted and with adb I cannot flash anything…

The guide doesn’t do anything with ADB.
Please follow the guide :wink: (resulting in … fastboot boot signed_recovery_image_of_choice).

Juhuu, that worked already… afterwards I entered TWRP I installed the LOS-update right away, but what is the problem? Is it a known issue? Do I need to change something?

It is a known issue, that with the new camera module installed, you can’t boot to recovery from within Android. Workaround is to press Vol + until it (hopefully soon) get’s fixed.


I don’t have the new camera module and I have the same issue.

For me, the hint of @Ingo has worked out to boot without camera. I could go to recovery in whatever way I liked. But in contrary to @brab using the old camera module it works as well.

Are you sure? If you got a brand new Fairphone 2 in October 2017 …

… you should have the new camera …

Did you install an old one afterwards?

The new module most notably has a white “separator” between the lens and the flash, the old module didn’t have that … here’s a picture of the two modules.


You’re right, I do have a new module and I did not even know it (I thought it was upgrade only). Sorry for the confusion.


Hi, FP-Community.

Sry if i do a re-post or asking a question already solved, but i have a problem with twrp an LineageOS 15.1 (Build 20181022).

I have installed twrp and LOS 15.1 today and encrypted my FP2 in LOS. I can reboot or shutdown/start my FP2 and enter my encryption key. Normal boot, normal function and login in LOS. So far so good.

But when i want to boot into twrp-recovery (manual or enhanced restart-menu in LOS) i can not enter the encryption key. This error appears:

Updating partition details…
Unable to mount storage
Full SELinux support is present.
Failed to decrypt data.

Im sure, ive typed the correct code, the key works by starting into LOS.
Does anyone have a solution for this situation or more information…?


That’s an issue with TWRP, see https://github.com/omnirom/android_bootable_recovery/issues/224


If you want a fix now, install one of Fairphone’s OSes (Android 6 currently), set a lock screen pin/password/pattern, then encrypt the phone, then install TWRP 3.2.3-0 and wipe everything (only wipe, no format!), then install LineageOS 15.1 . That way TWRP can still access the encrypted data partition, and LineageOS 15.1 is fine with it, too.

I installed LineageOS 15.1 for microG on prior encryption myself, works like intended.

1 Like

Thanks AnotherElk, seems to be a little tricky for me…

I have tested de update to the lastest LOS-Build (20181029) with encrypted phone and all worked perfectly. So its only the access to the encrypted partition in twrp, that doesn`t work. And i will need this access only, if i have a problem with my phone/LOS, to wipe, format or something…

By the way, the same twrp works perfectly on my samsung s7 (also encripted). Seems to be only a problem of a few twrp-recoverys / phones, including the fairphone 2…

I will wait for a (hopefully fast) solution/update of twrp.

Will this help us to decrypt our FP2 in TWRP?

I tought the neccassary changes are discribet in the yesterdays post from github user kumajaya

But to be honest: I have no idea how to figure this out.
If i made an unusefull post: Sorry.

1 Like

I’m no developer either … so, perhaps you really have found something here.

I only saw at first glance that the fix seemed to be for bacon (= OnePlus One), and since fixes for several devices exist already and didn’t translate over to the Fairphone 2 as per the statement of @z3ntu (the maintainer of Fairphone 2 TWRP) in the other topic, I thought I’d link to his statement here, too.

1 Like

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.