Uninstall apps which can't be deinstalled by default (like Google Apps/Play)

Continuing the discussion from Alternative Apps(tores): Living without Google:

@dubiosos I found a way, which may work on this website (in German): http://www.android-user.de/Apps/Tipp-So-loeschen-Sie-Apps-die-sich-nicht-deinstallieren-lassen

They suggest to go to Settings > Security > Device Administrators and then deactivate the apps which are listed there. They should then be deinstallable.

PS.: I opened a new Topic so others can contribute to the problem and also find solutions.
PPS.: Billa (Rewe) even uses the “Hausverstand” as a testimonial for their products: :wink: https://www.youtube.com/watch?v=l4t3A4Gc3Rk

1 Like

Thanks for opening a new topic!

However, this doesn’t work for me. There is nothing listed at “Device Administrators”. Also, there simply is no deinstall button for the Google apps, just deactivate.

I found this article suggesting to use Titanium Backup which you can download from Google Play: http://www.guidingtech.com/13523/freeze-uninstall-android-system-apps-titanium-backup/

Just be very careful and remember to backup important data before trying the guide above.

If something doesn’t work out there is still the option to make a hard reset and restore the FP to the state when it was shipped (without Google Apps already installed), so if the solution doesn’t work, you would at least get rid of GApps by hard resetting the phone.

Please share your experiences with the uninstall guide afterwards! :thumbsup:

I actually tried to uninstall some parts of GApps and can highly recommend to buy the Pro key for Titanium Backup (to be able to set multiple restore points, hidden in the preferences) before trying. I ran into some serious trouble after crippeling Google Search, Google Voice Search, and the Play Store, via Titanium Backup, so I reverted it. (At least I think my fiddeling with those was the cause of the culprit.) Unfortunately, my automatic backup had set in earlier, so Google Search still keeps crashing, constantly.

By the way, if you don’t want GApps at all, a wipe + recovery of some of your apps from a backup seems a far better. But take care: some apps depend on some parts of the GApps framework, like, e.g., Threema, which needs parts of GApps to communicate with the instant messaging server (and crashes, violently, when de-installing parts of GApps).

I, for one, tried the XPosed framework + XPrivacy, which is quite elaborate. It can feed false data to any app, or restrict the rights of apps after installing. Still need to get a pro-key there; seems worth it. (But I’m not setting up a PayPal account only for that, thank you very much…)

1 Like

Maybe this helps: https://gist.github.com/olivier-m/6200184

You would need the Software Developer Kit (SDK) with Android Debug Bridge (ADB).

On the first link go to VIEW ALL DOWNLOADS AND SIZES and scroll down to SDK Tools Only. I don’t think you need the bundle (with the development environment) for only using ADB.

You might need the Java Development Kit (JDK) also, but currently I am not sure of that.

There are a lot of tutorials on the topic, so you may have to do some research. But honestly, the easiest way would be to backup your personal data and reset your phone to get rid of the GApps… :wink:

1 Like

it happened the same to me as to dubiosos. I’ve already installes Google Apps without. Afterwards I regreted my decision and wanted to get rid of them just by applying the factory reset. But still the Google Apps remain on my phone. Any idea why there is just the option to remove the installer but the installation process for Google Apps cannot be undone by resetting??

Thanks in advance

Sorry, the second sentence was not complete: I’ve already installed Google Apps without considering.

As far as I know, Google Apps are only removed during an update. What you could try is to install the software version 1.6 manually.

Thank you. It worked.

1 Like

I belong to those trying to avoid Google : in addition to Fair trade, getting root by default and installing serious firewalls was very significant in my decision to buy a FP1.

I quickly discovered there are some apps that I had to buy exclusively through Google.
Mind you, as I don’t need the latest fashion things, they are really few -and many of them are seeing open equivalent appearing on F-droid.
But still. There are basic when-is-coming-my-bus utilities that sillily demand a Google market installation.

Because of these, I had Gapps installed until the last system update, which very happily left me back without GApps by default, and all my previoulys installed apps.
Save one or two that appear like deinstalled in the process.

So, my question is very naive: if I install GApps, and then the couple of apps that demand it, shall I be able to deinstall Gapps properly and fully afterwards?

What I suspect is, along with these ‘demanding’ apps there will be specific calls to Google APIs or whatsnot, used to check I actually paid the app, or something of the kind…

If this is true I am ready to abandon the related apps, but as I’d like to try ‘one last time’, what indeed I wish is being able to really get rid of GApps completely afterwards, not just firewalling them like I did before…

@Herve5 I’ve moved your post here. Have you already tried the above suggested solutions?

All System-Apps like Google-Apps reside inside a separate partition named /system, which is mounted read-only. Only Systemadmins like Google or root can change anything in this partition. So if you want to get rid of anything named Google or e.g. flashlight, then become root.
These apps in /system/apps can not be “uninstalled” but deleted by root. Better way: rename those apps in “appname-old” which makes it possible to use them after re-renaming.

My tool for this action is Totalcommander (http://www.ghisler.com/android.htm), which in case of commands to /system asks for permission to remount read-write. It does that and afterwards remount read-only. It’s better to leave this partition RO.

Be very careful what you do as root !!! Root is useful but dangerous!


Tip: if you want to have access to Windows-shares (smb): there’s a plugin for Totalcommander …


Thanks Spielmops!
Renaming seems perfect.
Indeed the only thing missing now for me is the actual list of apps installed by the GApps installer.

I posted the link up there. It contains a list of all Google Services (at that time).

1 Like

I guess you can deactivate your apps with Titanium. It really works well and all that are locked down can not be seen on your screen anymore. Also, you can try some file explorers, which can help uninstall those system apps on Android. But, you need to know that either way works with rooted phone only.