Fairphone trying to update, without any update being available

This has occasionally happened to a few users ever since the first FPs were delivered. Did you also wipe cache and data from the Fairphone Updater app before rebooting? IIRC this has helped previously.

When you say that it is constantly trying to update, is it prompting you to install an update? The Fairphone Updater app will check every now and then when connected on wi-fi to see if there is a new update. This displays as a download called Fairphone update, but shouldn’t prompt you to do anything if your phone is on the latest update already.

Is that what you’re experiencing?

@kgha I did wipe the cache before

@Chris_R It is not trying to install something, it is only showing up as an icon, looking like it would try to download something. I am aware that it will check for updates when I connect to wifi (at a given time interval I suppose), but the cross checking should be nothing but sending and receiving a version number, which should not be visible for me because first it should be very fast, we are talking split seconds instead of it staying there for hours, given my wifi is working fine otherwise and this probably should be a background process running (once a day or something like that whenever I am connected to wifi) but it should certainly not show up and stay there on multiple occasions without me connecting/disconnecting from a wifi network.

Yesterday it didn’t show up so I kind of consider this issue solved for the time being, anyway it is not a serious issue but something which is not quite absolutely right.

Thanks for the quick reply to both of you!

I’m experiencing this issue since a few months now - it even “survived” the last regular FP formware update. Any other hints what I could do to hide the downloading icon? Stopping updater and erasing data and cache didn’t work.

Maybe the FairPhone devs should add an option to disable automatically checking for updates and add a button to manually perform an update check.


For the record, I did notice the DL symbol persistently showing up (but not downloading) when the Cherry was rolled out. I tried to look at the traffic, and if I recall correctly, there was a server-side problem. I assumed that to many people were trying to DL the update at the same time, so my DL could not be properly initiated.

I do realise that this should not be the problem right now, since you are running Cherry. But maybe it’s still a server-side problem?

Hi keebock, are you still getting this little error? I was getting it around the same time as you, back in September, then it went away for a few months, but now it’s back!

This time it might be because the update was postponed to fix the issues with rolling it out.
See more on this here.

1 Like

I have updated to version 1.8 and several times a day the phone now “download” automatically some fairphone update. I don’t know what and it disappears after a couple of seconds.

Did you read the previous posts? I will not respond to your question. Please inform yourself, as this has been answered already.

Edit: This was posted by @keesj in another thread:

1 Like

What does that mean, exactly?

As far as I can see, opening the file manager, I don’t have any /mnt/sdcard/updater folder… or maybe I’m misunderstanding. Either way, that makes no sense to me.

Quoting myself:

I use Open Explorer Beta (File manager) - https://f-droid.org/app/org.brandroid.openmanager

I guess that it’s perfectly normal with a short (1 sec. or so) download activity when connecting to a WLAN. This will just be the FP Update app checking for updates. So far I have only experienced a continuing (never-ending) download attempt twice. In both cases it was solved by clearing cache and data from the Updater app. The /mnt/sdcard/updater folder has been empty on both occasions.

Hello guys,

I have the same problem: endless updates which are blocking my data transfer completely.
I tried removing caches and the content of /mnt/sdcard/updater, only to find it updating endlessly again an hour later.

Is there a fix in the foreseeable future, because if not, I have to get another device.
Thanks in advance.

There is a fix that’s being worked on in the current beta release version, and when the FP team are happy with how the update process is working it will be released.

Please bear with the FP team.

Thanks for the swift response.

I assume, we’re not talking about weeks here, are we?
Is there a way to disable the Updater for the time being?

Maybe you can try it with Titanium Backup.


That should help for now, thanks!

Backup + un-install worked fine. I’ll post further details if I encounter any issues.
In order to freeze the app with Titanium Backup, one has to get the “donate version” though.

1 Like

For me, it was money well spent. =) Saved my arse thrice already, if you excuse my Klatchian.

This problem is a known bug:


This topic is now closed. New replies are no longer allowed.