Fairphone does not automatically connect to cellphone network (and other issues)

I recently received my first fairphone, but so far it has not lived up to my expectations.

When I boot the phone it will boot just fine and ask for the pin that unlucks the screen. Then it connects to wifi and I can use some apps etc. However, it does not connect to the cellphone network. I always have to set airplane mode on and off before I am prompted for the sim-pin, and then it will prompt me once more for the screen pin.
One other thing is that there are three ways to toggle airplane mode, and if I use one to activate it I have to use another one to deactivate it. The settings menu in general seems dysfunctional. When I go to Settings > Sim management and toggle the on/off switch it will just hang the settings menu with a message that it is (de)activating. When I go to Settings > Security > Set up SIM card lock I can unclick the “Lock SIM card” option, but it will always be on the next time I boot the phone. I discovered that last one in an attempt to have the phone auto-connect at boot, but that also did not help. When I go to Settings > more… > Mobile networks then nothing happens if the sim is locked (it hangs) and if it is unlocked then I go to > Network operators and I see two options, ‘Select manually’ and ‘Choose automatically’. There is no checkbox or a clear chose between the two, but if I click on the option automatic then it will hang for a while and then say “registered to network”. But this does not mean that it will register automatically next time I boot the phone…

I just want to mention that I installed very few apps, none that interact with the sim or cell network, and that I turned on the device encryption.

Multiple people around me are considering buying one and they have asked what I think about the phone. Unfortunately I can not recommend the phone for people that need one that “just works”. This is especially painful since I have waited anxiously for 6 months for my phone and really do support the idea of a fair trade and (mostly) open source phone.

One last thing that I need to mention. It is really sad (almost painful) that when you install the google play store, it basically just takes over your phone. It even embeds itself in the ROM, as when I did a ‘factory data reset’ as per fairphone instructions the google crap (store, and unwanted apps like gmail) was still there. I know that it is difficult to dodge the google play store, but one effort would be to at least inform users and give them the option to use the f-droid market instead. The current way that fairphone handles this really is not ‘fair’ by any measurement.

If fairphone could help me with at least some of these issues that would be really great.

Hi @remi

First of all I’d like to point out to you that here on this forum it’s other users helping you, the official fairphone support is not on here.

Now I’m trying to understand your description of the problem, please bear with me.
Which three ways of airplane mode do you mean? Toggling the on/off switch under Settings/SIM Management is unrelated to airplane mode. A deactivated SIM slot stays deactivated if you switch out of airplane mode.
The setting under Settings/Security/Set up SIM card lock is also unrelated to the previous mentioned settings. Here you can set whether a PIN is required before activating a SIM card, but this does not activate/deactivate your SIM itself and therefore has no direct influence on mobile connectivity etc.
From your description it sounds like you got all these settings a bit mingled up.

Now onto your actual problem.
To find out what’s actually causing this please try the following:

  1. deactivate WI-FI, deactivate Airplane mode, activate your SIM card (sim management toggle -> on), check the Lock SIM card option in security settings(so that you will be prompted to enter your PIN).
  2. Test your network connectivity.
  3. If it works reboot your phone.
  4. Give your phone a bit of time after startup.
  5. If you’re not prompted to enter the PIN to unlock your SIM card check the above mentioned settings.
  6. Look which setting differs from before you rebooted your phone.

Please let me know if/how this works!

As for Google Play, Fairphone has to walk the line between users wanting easy access to Google Play and those that want the option to decide for themselves. In my opinion it is a huge improvement to have a phone that actually gives you this choice. In case you don’t want Google Play anymore you could try a hard reset or read a bit about doing it manually in this topic here. The factory data reset only resets settings and deletes personal data, as far as I know it doesn’t delete Google Play Services.

1 Like

Thank you for your reply.

The three ways of toggling airplane mode are:
1 scroll down from the top menu (with time, battery etc.) and press the button in the up right corner > airplane mode.
2 Settings > More > Airplane mode
3 The hardware power button > Airplane mode.

As I said, using any one of these options means that it will not work the first following time. So e.g. if I use option 1 to turn it on I can only use options 2,3 to turn it off.

I realize that. What I am saying is that that the sim toggle does not work and hangs the settings menu.
Many of the settings I discuss are indeed unrelated, but they are all dysfunctional. Either they hang the settings menu, or in the case of sim card lock the setting is undone after next boot.

I followed the steps you gave but they did not help. After waiting a while I turned airplane mode on and off again and I was prompted for a sim unluck.

As for your reaction about google play:

Let it be clear that Fairphone did absolutely nothing to inform users of their choice. There is no informed consent that was given to users, only the google play install widget that said something like “There is nothing to worry, you can just install this and give it root access.”. One of fairphone’s selling points is open source, and yet the user is not informed of what is going on here, no mention that there exists an alternative and no mention that google will steal all your personal information if you install.

As for the link you gave, I did follow the hard reset steps, but to my surprise the google apps survived this. The other link you gave is not something that removes google from the phone.

So I am not helped so far.

Hello @remi,

I can’t help you with the SIM Card Problems, I don’t have problems like that and have no idea to fix them.

I just want to complement the point of @Kris_S about the goolge services and Apps. I for my point want just “some” of the services and I’m not sure if this is what you want, too. If it is then I fear the best way to get just some is to install all, and remove the other afterwards. I used this tool (others will do the same job) to remove gmail, gollgoe+ etc. but I’m still using the Play Store and the Push service.


I see your point with the Google Play issue but remember that the phone does run android, which is pretty much Google’s OS. There’s a lot of talk on here about alternatives. So if a user is interested in the information it may not be on the phone itself, but it is available on the website and the forum here.

The whole settings bug is very weird, I understand now what you were trying to say.
The next idea I can think of is checking which Fairphone version you have installed in the Fairphone Updater app and upgrading to 1.6, if that’s not already installed.
Another idea would be flashing the OS to your phone in recovery mode (OS-files are here / please also read here!).

Other than that I’m at a loss.

I’d recommend raising a ticket with Support. You may have to wait a few days but you can get help from the source. Also I think it’d be a good idea to report this bug to them.

I use a Fairphone from the first batch. Initially, I used the installer widget and installed GAPPS, but on the second day I already had enough, so I simply reflashed the Fairphone software from recovery.
So, if you want a phone that’s free from Google Apps, don’t panic (and don’t start messing with methods to remove GAPPS by hand…), simply download the correct software image from here, reboot to recovery and choose “apply update from SD card” (and maybe wipe your data, if you want to be sure).

I hope this helps!

Thanks @haffenloher and @Kris_S.

I used the @haffenloher link to get a clean fairphone OS install.
After boot the phone prompted me to unlock my sim. Good. Then I restarted my system and it again asked to unlock my sim. Better! Then I encrypted my phone, rebooted and the familiar problems were back. The settings misbehave and the phone does not automatically prompt to unlock the sim.

So I think this is a bug.

I was happy to see that after the clean install all the google stuff was gone.
You can use the browser app to go to https://f-droid.org (do type https) to download the f-droid app market.
See https://f-droid.org/repository/browse/ for the apps you can get via free droid market.

Also I think the re-install process was relatively easy.

Hopefully Fairphone will come with an update to better support device encryption?

That’s strange. My phone is also encrypted (using the “native” Android method in Settings > Security > Encrypt phone) and don’t have any of these problems. 10 or 15 seconds after booting up, the phone asks for my SIM’s PIN and afterwards connects to a mobile network. For the phone’s screen lock, I use a password instead of the PIN, but I don’t think this should matter…
I can enable airplane mode from the power button menu and, after waiting a few seconds for the change to apply (!), when I reopen the power button menu I can disable airplane mode again without problems. Any other symptoms?

PS: I do also use f-droid, but for some (free) play store apps, it’s nice to have the NOGAPPS project’s open source play store client. Be warned though, setting up the NOGAPPS stuff can be a little tricky.

@remi, I can confirm that. Worked for me. (The reason why I did not encrypt my phone after the latest update (+ unifying partitions) was that I like to switch off my phone at night. If encrypted, the alarm will wake up the phone, but not sound the alarm - instead, it waits for the password, ticking annoyingly away. The power schedule has the the same problem. Both are really nice features few Android-based phones offer, as far as I know. (But nearly every dumbphone is able to turn itself on sound an alarm… so much for “progress”.)

BTW, you could try to turn turn of the SIM card pin, and set a lock screen password/PIN/pattern. It should be quite enough to protect your phone. Especially if you encrypt it. (You won’t be storing much information on the SIM, anyway.) You can find the options under [Settings][Security][Set up SIM card lock].

As for the device encryption implementation, I doubt FP/KwameCorp can do anything about it, as this is an Android feature. Even if they wanted to, they would not have the resources.

I’m sorry but I think I didn’t get your point - what can you confirm and what worked for you?

Uh, well, sorry if that wasn’t clear enough.

My phone was encrypted as well, and I did not have the problems @remi describes. Like you say: some seconds after booting up (and after entering the decryption code), the SIMs asked for their pin. I deactivated my SIM pin unlock code later, and went for a password.

Rest, see above.

Hey, I cann confirm the connection problem @remi has. My phone doesn’t connect to a network after rebooting, or it takes longer than an hour. I have two sim cards in my phone, and have encrypted it recently. A workaround that works for me is as following:

  1. Turn on Phone
  2. Wait until phone is responding
  3. Go into Airplane mode
  4. wait a few seconds
  5. Turn airplane mode off. (This time this option is only availible in the shutdown menu, not in the settings menu that can be draged in from the status bar)