English

Trying to install /e/OS on FP3, but it hangs on fastboot on Windows 10

Hi!

Yesterday, I received my brand new FP3 and I wanted to install /e/OS on it. However, I have some struggles with enabling fastboot on Windows 10. Hopefully someone can help me.

First, it is important to state that I was able to unlock the bootloader with fastboot on Windows 10, by following the official Fairphone guideluines; I unlocked dev settings and enabled usb debugging properly.

Next, after resetting everything to factory settings, I was able to boot in fastboot mode, whereafter I was trying to run ‘fastboot -w’ (which is the first step in order to flash /e/OS, according to the docs). After this, the terminal session hanged on ‘< waiting for any devices >’. Also, ‘fastboot devices’ did not reveal anything.

The following things I have tried to fix fastboot -w (all without success):

  • Install Universal ADB Drivers https://adb.clockworkmod.com/
  • Trying to change the driver in device settings. Even after removing the driver and rebooting Windows 10, the driver pops up as ‘FP3’ when I plug in the phone by usb (I do not understand why, maybe Windows is installing drivers in the background?)
  • Installed the SDK 9.0 via Android Studio. After this, the phone is known as Samsung device (?)
  • Toggling USB Preferences in Android between File Transfer and PTP
  • Tried all USB ports on my computer:
    2020-05-28%2023_55_52-Window
  • Full phone factory reset

Can someone point me into the right direction?

Ok, since unlocking the bootloader worked we can assume the cable is a working data cable (you could try a different one to make sure it didn’t break just now).

Maybe there’s driver trouble. Here’s a generic driver and ADB/Fastboot repair …

  • Disconnect the phone from the computer.
  • In Control Panel - Programs and Features:
    Uninstall the Android SDK (if installed) and everything with “MTP” or “ADB” in its name.
  • Reboot Windows.
  • In Control Panel - Device Manager:
    Enable View - Show hidden devices, and then uninstall every possible ADB, MTP and smartphone device, hidden or not.
  • Reboot Windows.
  • Connect the phone again. (Windows should install the necessary drivers then automatically. They can be named after a different device, this doesn’t matter.)
  • Download the current Android SDK Platform Tools
  • Unzip the ZIP file to e.g. C:\platform-tools (you can unzip it to wherever you like).
  • Add the path to where you unzipped the tools to the Windows “PATH” environment variable, so adb and fastboot could be run from everywhere without always having to prefix them with the path.

Then try fastboot devices again.

Have a look at Zadig:https://zadig.akeo.ie

Thanks for your thorough reply! I followed all your instructions, but without success.

I also tried adb reboot bootloader, and that works. However, fastboot is still unable to find any device. I have tried Powershell and Git bash, just to make sure it is not editor related. Furthermore, I have tried File Transfer and PTP mode…

With adb devices I can see the device. Is this information that is usable?

By the way: when I select File Transfer and PTP the file browser pops up with FP3 > Internal shared storage.

How can Zadig help me (Windows has installed the drivers already)?

Just to make sure, when you boot your FP3 into fastboot mode, the phone shows a screen like this (with device state “unlocked”, as you already did the unlocking):

Yes :slight_smile: goed

The only time I remember not being able to see the phone with fastboot devices was when I was trying to add FP3 support to the /e/ installer. It turned out the running installer still had some fastboot command active while I tried to execute a second fastboot command in a terminal for debugging purposes. But your case sounds different.

ADB seeing the phone and Fastboot not seeing the phone doesn’t make much sense using the same setup.

However, I’m finding (mostly older) mentions of this in the internet. If you want to try some things, there’s a collection of possible solutions here (for a different device, but once the phone drivers are installed it’s not much device-specific as far as I see briefly browsing through it) … https://forum.xda-developers.com/oneplus-3/help/fastboot-devices-adb-devices-t3485186.

If you can handle Linux, a live Linux DVD or USB stick could be promising, too. To perhaps move forward with installing the phone … or (if fastboot on Linux would fail, too) to see that it’s not the OS’s fault.

Just very recently, I have tried KDE 's Neon distro to set up fastboot to detect the Fairphone. Although I was able to install Android SDK Platform Tools and I was also able to use the adb and the fastboot terminal commands, there was still no phone discovered via fastboot. Again, adb and the ‘normal’ file browser - Dolphin in this case - worked.

Just to make sure it is not the usb cable as well, I have switched it with another cable, but still no result. I have tried to revoke all usb authorizations in Android’s usb debugging settings, but this was fruitless too.

It seems there is something wrong with the phone itself, 'cause fastboot is not able to detect it on multiple machines, multiple operating systems, and with multiple usb cables.

For clarity: first I start the computer. Next, I boot the FP3 in fast boot modus. And lastly, I put in the usb cable and connect it to the desktop machine.

Is there something I can do next? And, Plan B: is it possible to lock the bootloader again via Android itself, or do I have to do that with terminal as well?

Update the OS to the current A.0120 version (it says A.0110 in your screenshot)?
Updating switches to the other boot slot in the phone, so updating would have to set up the bootloader there from scratch … so perhaps this new bootloader might be in the mood to work with fastboot then.

I don’t think this can be triggered from Android.

No, this does not work either (installed A.0120, and rebooted the system completely).

I think I will stop trying to migrate to /e/. It is really hopeless, I guess… It is too bad since I really wanted to install /e/ to get rid of all the Google stuff.

Sorry guys, thank you for the great help!

Just to check: was it needed for you guys to install a custom Android driver on Windows? And if so, did you also only see ‘MTP usb device’ (or something like that) as the only option that you can select? When I then click next, I get the notification that the driver already is installed. Also after I removed all drivers from device management (as was mentioned by AnotherElk above).

This morning, I tried to use fastboot on my Macbook. Although I can use fastboot in terminal, ‘fastboot devices’ is not recognizing any device - even with ‘sudo -s’. Is it possible that the bootloader is not quite in unlocking state?

Furthermore, to be sure, I post the usb cable that I use now (on my Macbook 2019, with adapter, and my Windows desktop). It is just a ‘normal’ USB 2.0 USB-A/USB-C: https://www.belkin.com/nl/p/P-F2CU032/

Fastboot should work nonetheless.
Regardless of the bootloader being locked or not, fastboot would see the phone. If the user would try to do something which a locked state would forbid, fastboot would then just say that it wasn’t allowed to do that.

In my experience fastboot is the most robust thing in dealing with a phone, it’s the last thing that fails to work. If you went through the XDA thread I linked to and tried the possible solutions which worked for people there, I really don’t see what could be wrong or missing here.

I have managed to get it working! Woohoo!

Believe it or not, but it was something stupid… I did not know that it was forbidden to click on ‘select’ after adb bootloader reboot. To me, it was logical to click on it since it was a selection screen. However, suddenly, I stumbled upon an old forum topic from a guy that was having the same problem. So, for future reference: do not select anything after rebooting with adb!

It might be handy to add this to the /e/OS manual, since for flash newbies like me the step to not select anything after rebooting may not be clear enough.

Thanks for everything!

4 Likes

You should probably post that in the /e/ forum (or otherwise contact the /e/ foundation) as I doubt someone able to change their instructions reads along here.

Out of curiosity: what kind of “select” are you talking about? Do you have a screenshot by chance?

Hi Ingo,

It is just the selection screen after booting the phone in fastboot mode (with ‘Start’ in green on top). You can see a picture in the forum topic that I have linked.

I assummed incorrectly that pressing on the power button on the selection screen was starting fastboot mode, but it was nog needed to do so, I discovered later.

I will ask the foundation to add this to the manual.

Kind regards,
Yoeri

2 Likes

Thanks for the clarification, now I get it.

Funnily, I never identified that screen as a selection until I accidentally used one of the volume buttons and saw that the “start” changes to other options :wink:
But that was probably because the fastboot mode of the FP2 had no interactivity at all.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.