Trapped in fastboot mode with locked bootloader and corrupted custom ROM

Maybe a new topic. I notice this one has the eOS tag and implies it is not for the default OS

but with the same consistency
A case for the Fairphone Lab :wink:

1 Like

The OTA problem was that the download always stopped. I live in an area of Germany with very poor internet.
Then I tried to download the offline update to update the Fairphone 4.

I have performed the installation according to instructions. The Fairphone rebooted and was directly in fastboot lock without me having to enter the command.
Maybe the download was faulty or something like that.

No, I have not installed a custom rom/kernel.

Without entering which command? If you did not lock the bootloader you should be fine. Does it say DEVICE STATE - locked?

3 Likes

Let’s not be too strict either, the eOS tag implies it is linked in some way with /e/OS, it doesn’t mean one’s not allowed to talk about a similar problem, even with a different cause.

2 Likes

Very good point!
If the bootloader is still unlocked, please try:

4 Likes

so far I have no answer from support either.
What I find strange, that in the fastboot at the bootloader and baseband is nothing behind. So he would have nothing more what he could start. But where does he get the lock status?!

$ fastboot --set-active=a
Setting current slot to ‘a’
FAILED (remote: ‘Slot Change is not allowed in Lock State’)
fastboot: error: Command failed

$ fastboot flashing unlock
FAILED (remote: ‘Flashing Unlock is not allowed’)
fastboot: error: Command failed

Same issue here. I tried to install iodéOS and /e/OS, but after relocking the bootloader, it would show that the phone is corrupt. I could still unlock and try again to no avail.

I figured I’d reinstall the stock OS to try relocking that way, but it still showed that it’s corrupt and now I can’t even unlock the bootloader. Guess I’ll contact support as well.

1 Like

what exactly?
What have you done in which order?

First iodé?
Later /e/OS

What worked?
And when have you re-locked your bootloader? after whih OS installation?

Please a little mor precise.

I installed iodéOS and it worked fine, but features on some apps were disabled because my bootloader was unlocked, so I decided to lock it. Then it showed me this message: Your device is corrupt. It can't be trusted and will not boot.

I was able to unlock the bootloader again in fastboot and reinstall iodéOS, but locking the bootloader again showed the corrupt message.

I figured I’d try to install /e/OS to see if that worked, but the same thing happened. Worked before locking, corrupt after locking. This happens to many users according to the /e/OS forum: FP4 Device corrupted and won't boot in locked mode after fresh /e/OS install - Fairphone - /e/ community

Someone suggested that you need to have the stock OS installed before installing a custom OS for relocking to work, so I installed the stock ROM and tried to relock it. The result was the same: my device is corrupt and will not boot. This time, however, unlocking the bootloader doesn’t work anymore: FAILED (remote: 'Flashing Unlock is not allowed').

I managed to enter EDL/QDL mode, but looks like nobody has figured out a way to unbrick it through that yet.

1 Like

So you did not locked it directly after you have flashed the OS and did a last wipe?
you have booted in the system without re-locking it first?

I think that’s your problem. iodeOS is signed for verified secure boot…

I thought that might’ve been the problem, so I tried to lock before the first boot. Still corrupted.

Have you seen this:

Would have been a good idea to read that first. :slight_smile:
It seems that thread links back here and the OP there luckily hasn’t bricked their device yet.

I am in the same situation after re-locking the bootloader : FP4 Root Access is possible, maybe a bit risky - #185 by cortomalese.
Look this post too Device not booting after flashing factory image and locking bootloader. I’m waiting for Fairphone support answer.

Out of interest, did you verify that your device booted before locking the bootloader? @cortomalese

Yes, I did. The whole history is: to root my new FP4 I followed this :

So I start to unlock bootloader following this:

The installation of Magisk went well and almost everything was fine for two months. I says “almost” because a bank app refuses to work, even with Magisk hide fonction, because of the unlocked bootloader.
To avoid reformatting my phone I disabled the authorization to unlock the bootloader in developpers settings. The apps bank don’t works anymore, but the phone is ok, until the last Magik’s update.
Other thing. When I tried to boot on TWRP image, I can’t wipe cache, because critical partitions was locked.
That’s when I saw that I couldn’t flash the original FP4 rom, I wanted to go back to the original state and re-lock the bootloader via fastboot flashing lock. And FP4 was blocked.
If I look at the /e/OS installation tutorial,
https://doc.e.foundation/devices/FP4/install
I see that not only the bootloader had to be unlocked fastboot flashing unlock, but also the critical partitions fastboot flashing unlock_critical, which the Fairphone manual does not say. I think that’s where my problems come from.
I think I have a point to make with Fairphone’s support: their tutorial don’t mention the need to flash critical partitions too. If “the Fairphone 4 (FP4) gives you the freedom to unlock your bootloader” it must also give us the resources to do so.

You linked to the wrong tutorial there, this is the right one:

The instructions to unlock the critical partitions are in Part 2: Unlock your bootloader under step 7:

In a Command Prompt or a terminal, type: fastboot flashing unlock_critical and press the “Enter :leftwards_arrow_with_hook:” key

To be fair, those instructions haven’t been there from the beginning and they also only added…

If after returning to Fairphone OS, your phone can not boot to it, don’t lock the bootloader. If you have any issues with booting normally please contact customer support.

…after people kept bricking their phones.

So I agree, the documentation could (and should) be improved in many ways. But at the same time this is also the prize you sometimes pay as an early adopter, “hic sunt dragones”.
Doesn’t mean Fairphone shouldn’t do everything in their power to help the community fix it (especially if it’s their documentation that’s lacking) and I don’t mean “fixing” it with a replacement device offered at full cost… :roll_eyes:

7 Likes

I think that’s the key point.
I assume that if you keep the authorization to unlock enabled (and you check at least once that your device can still boot after flashing the new OS) you should be safe locking it.
(and please don’t get me wrong - I don’t want to say you did something wrong and I’m really sorry for the state off your device! it’s meant for others planning to relock their bootloader…!)

5 Likes

I have more or less the same problem.

I wanted to try eOS, installed it according to their instructions and found it too much IPhone-like, so I wanted to go back to FairPhone OS and ran everything according to their instructions, then ended up in the Android setup process (so where you set up wifi, time, etc.) and turned off the phone and wanted to close the bootloader again to have everything as before … but then I also got this “Your device is corrupt. It can’t be trusted and will not boot.” and since then I’m stuck in the bootloader :confused:

So would I have had to go through the setup process first or do something else? But there was nothing about that in the Instruction?

I have followed the instructions for eOS and Fairphone OS, that my phone now no longer works is a bit stupid…

will write to the support also… not even 1 week after my FP4 arrived :confused:

2 Likes