Unable to lock bootloader


I recently bought an fairphone 4 and wanted to install a degoogled OS.
I decided to go with iode and followed the (sparse) instructions on this site:
[iodéOS installation - iodé]
All went (reasonably) well till i got to step 9 relocking the bootloader.

When relocking the bootloader following the instructions provided here:
After running fastboot flashing lock and confirming, i get the message that my image is corrupt and no longer able to boot. I can still get into the bootloader (now in a locked state) and am no longer able to start the OS…

running fastboot flashing unlock unlocks the bootloader and I’m able to reinstall iode, so at least i haven’t bricked anything (yet).

So at the moment i have a fairphone 4 with iode and unlocked bootloader
As i am a total smatphone noob, I’m not sure what to do at this point.
Is there a better tutorial available on how to relock the bootloader, or did i just follow the wrong instructions?

Welcome to the forum!

You’ve stumbled into a known problem, see here for example

I suggest you are very careful around re-locking the bootloader as this often seems to lead to bricked devices at the moment.


which version did you try?


I tried 20220126

OK, i did it initially with 20220121 without problems

Maybe you give this one a try…

and then change the updater apk, to get beta updates. v2 Version

is this still the proposed action: to install an old version and then upgrade later? I tried version iode-2.4-20220407-FP4. And trying to lock the boot loader at the end I twice was in panic mode. Once when I first went into endless boot-loop after “fastboot flashing lock”. And the second time when I tried the forth or fifth time to get instead of the known “verified boot” warning but the error message “boot corrupt”…
By some other forum posts I was able to find “getvar all” showing these results

(bootloader) current-slot:b
(bootloader) has-slot:boot:yes
(bootloader) slot-retry-count:b:7
(bootloader) slot-unbootable:b:yes
(bootloader) slot-successful:b:yes
(bootloader) slot-retry-count:a:7
(bootloader) slot-unbootable:a:yes
(bootloader) slot-successful:a:no
(bootloader) slot-count:2

and having a “fastboot --set-active=a” at least I could reinstall again. To avoid any additional panic moment and in favor to start using my new phone I’d like to get this unlock/lock issue solved - any safe path

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.