Stock fp3(+) (factory reset) boot loop (workarounds in first post)

Do you also have “LocationServices hast stopped” before it reboots?

1 Like

I haven’t seen that (but I can’t swear it). If I read the discussion correctly, it happened after a first factory reset, right ?

1 Like

Generally it may be advisable for FP3 users to disable any Google updates, how would that mass communication be done.

I note under Google play store I have > Advanced > Modify System settings > Not allowed.

I’m still using Version 22.09.20 (100408-434869283) From April 2022


I’m still OK with EE in the UK


Hi there all FP users,

i am seeing the same issue since yesterday eve while charging!

No sec user. SIM out doesn´t help.
10 sec reboot upon unlock.
I can manage to reach Google service app, but grayed out option. Can´t disable it.

So i am awaiting help and chatting via browser with friends and stuff.

Greets from GER

1 Like

Hey, chiming in here. I am also having these issues, since last Thursday (10-11-2022).
I managed to disable the Play Services, my phone is still on now :slight_smile:
I am on Play Services 22.44.14 and build number 0017.3.

1 Like

Are there any hints what to do if disableing Google Play Services ist greyed out?

Hey. Same issue here since this morning. Stock FP3, operator is Telenet (Belgium). I noticed my Google Play Services version is 22.44.16
Very thankful for this forum: was about to factory reset (and lose a bunch of important stuff), but then found this thread and read that it doesn’t fix the issue.
However: disable Google Play Services is also greyed out on my phone. Is there a way to change this?

1 Like

Nope, but you should be able to downgrade it: Settings-> Apps & notifications → See all apps → Google Play Services → Storage → Clear data.
This will remove all updates (I’m currently running 22.02)


THANKS! This made the trick. I’ve cleared all data of the Google Play Services reverted it back to 22.02. FP3 is now working fine.


Ah, I was too late, had already started the factory reset - yet to see what the damage is - it’s still downloading and updating my apps - over the network - so it will probably crap out. I will pause anything google play services relate.

@punkt @KarimR

How are you trying to do this? Do you have the option to FORCE STOP

And with the three dots (top-right) there’s an option to [Uninstall updates]


I’m also having the same issue Fairphone Support needs to get to this ASAP. First experienced ~ 15:02 UTC, Saturday, 12 November 2022.
I pressed try again and the phone was operational for around ~10seconds

How do you manage to realize this in just 10 secs? My FP3+ does not react this fast

Same here, mine shuts down before I can revert google play app

Have you tried in Safe mode with either the power plugged in or not, or a USB connected to a PC ~ maybe ??

After a lot of tries (the time to do it being only around 10 seconds and having to wait that list of apps is available, then having to scroll to google) I succeeded disabling Google play services, Google play store (+emptying the cache), Google (+emptying the cache) but I’m still locked in this damn boot loop. Did I miss something (I precise: I can’t empty the cache of the google play services since I disable it as it is no longer present in the app list…)

Multiple attempts. Pretend it’s a game. :wink:


Hey. Both “Disable” and “Force Stop” are greyed out on my phone. I tried to uninstall updates with the 3 dots in the top right but it doesn’t work (“Uninstall updates unsuccessful”). And so far I’m not fast enough (or my phone is too slow) to reach the “Clear Data” button under “Storage” before it restarts. Safe mode is even worse. Will try plugging in a cable…

1 Like

I have a big problem with my Fairphone 3,
since yesterday, I’m not able to start the phone after some seconds it resets,
and shows me after a restart in the Recovery the option to restart or to set the phone to
factory reset.

Safe mode doesn’t fix that, I have not unlocked the phone,
and there is not enough time to enter the digits in the user menue…
What can I do to rescue the data on the phone???
Please, I need help…
I had the time to get the admin rights and to set the USB debugging,
but there are no files in the adb shell ???
only things with no permission for me …

That is the best working workaround!
I activated developer tools (and USB debugging).
Then I downgraded gms (Google mobile services) with ADB commands that’s much easier to do than the 5-10sec UI handling…

After USB debugging is enabled, U need to trust the connected computer (dialog at phone’s display), then download the fallback version (apk file) (f.e. APK Fallback version 22.02.21) and type the following commands:

adb shell am force-stop
adb shell pm clear
adb install -d\(150408-428111784\)-220221039_minAPI30\(arm64-v8a,armeabi-v7a\)\(480dpi\)