[SOLVED] Display sleep timeout is limited to 30 seconds

Hi Fairphoners,

in the display settings, it’s possible to select a sleep timeout between 15 seconds and 30 minutes. However, setting it to anything above 30 seconds is ignored. Whatever timeout I select, the display will always fade black after 30 seconds. If I select a sleep timeout of 15 seconds, it will fade black after 15 seconds.

I currently have some problems with my FP2 by which I reset the phone to factory settings, hence I don’t know whether this is a result of the mentioned problems or I just forgot about another setting affecting the display sleep timeout.

My FP2 has FPOS 1.5.1 and is not rooted.

So, can anyone confirm this issue?

1 Like

I have the same problem on my phone. No idea of how to solve it though

Cannot confirm that issue. I have a timeout set to 2 min and the screen gets dim and then black after 2 minutes. FPOS 1.5.1 and not rooted.
So it looks as if something else must be the reason.

Did either of you do a factory reset ever since you got the phone?

Because for me, the problem arose after I did just that. Having said that I’m not 100% certain that this has nothing to do with the hardware issues I’m having at the same time.

Yesterday was for me day #1 with FP Open OS 16.07! Before FPOS 1.2.8 - no problem with display lock change timing. Since yesterday with FPOOS this problem is new to me, but it is a problem . When will it be part of Bug Reports ? Will it become part of official bug list or known issues for both FPOS and FPOOS ? And when ?

I guess if more people confirm this issue or when the developers confirm this as a bug, it will become part of the “known issues”.

Btw, what do you mean by “FPOOS”? Is that just a typo and meant to be “FPOS” or do you mean “FP Open OS”?

Thanks, for quick answer. FPOSOS means Fairphone OpenSource Operating System.

1 Like

I have the same issue.

I was on FPOOS until a few days ago, and this functionality was working fine (I had it set to turn the screen off after 5 minutes). Although I’m not actually sure what version of FPOOS I was on I’m afraid.

I reverted to standard FPOS (version 1.5.1) to see if it would fix an unrelated issue. Now setting it to 15s works OK, as does 30s, but anything above 30s just turns off after 30s.

Have tried reverting to 30s, leaving it for a while, and then going up to 1minute, but the issue persists.

Also tried a reboot, but this didn’t make any difference.Happy to help run further tests if it will help diagnose.

Please guys let’s stop using “FPOSOS”. FP OpenSource OS doesn’t exist, it’s called FP Open OS.

1 Like

Thanks to your experience I’m sure it does not come from switching to or from Open OS. Both our OSes have 15.1 in common. And that was the reason why my last update happened in April, seriously. It was hard to miss security updates - I even opened a ticket for feature request. Denied, because I should update all even without missing bug fixes. Now I am missing a basic display function because FP seems not to be able to test monthly releases for really bad side effects like this one.

I have had the same issue (display timeout is max 30sec, any higher value has no effect) with a freshly installed FP Open OS and I was able to fix it (took me some time to dive into that … bug?).

What happes is that the setting “screen_off_timeout” (thats the variable you can modify using android settings dialog) is set correctly to e.g. 1800000 (that is 30min) BUT there is another value in androids config-datbase called “sleep_timeout”. That “sleep_timeout” is afaik “-1” on most androids which means unlimited if I remember right. Unfortunately FP Open OS seems to have a hardcoded default here which is set to 30000 (30sec) and there is NO option in the settings-app to change that.

If you look at that code-example, you see that this value will always win if you set something higher than 30sec in your settings app (so one cant go higher then 30sec in FP Open OS):

    if (sleepTimeout >= 0) {
        timeout = Math.min(timeout, sleepTimeout);

My fix is: As root (!) you modify the sleep_timeout in the config-database to “-1” by entering that in a shell directly on your phone (as root):

settings put secure sleep_timeout -1

NOTE: Modifying the config-db directly is dangerous and can break your phone - but I assume a FP Open OS user is aware of that. :wink:

PS: That app might help to read out ALL settings (only read, no write):


So, can we assume this came with the OS update? In that case, I’d really like to have a 1.4.2 update file, installable via adb, so I can verify this. Anyone happen to have one by any chance?

If there are no other objectives to this plausible cause we should already have it maybe corrected in FP stock release 1.6.2/, have we ? If not, who brings it on top of the bug reports for the next release update ?


For flashing with fastboot. (Install option 4)

[Note (just to make sure): This will obviously wipe your data)

1 Like

Thanks! Is there a reason I should prefer fastboot? Why not simply via adb sideload <file>?

Oh, so this is not an update, but the whole OS and I need root, right?

Thing is, root is the only thing I am not allowed to do on my device since it’s technically owned by the company I work for. I just have full control over it, but this one restriction is due to the restrictions of the Mobile Device Management System it’s managed by.

I’m on FP Open OS since the beginning, and I have -1 in sleep_timeout…

1 Like

Interessant. I came from the original Fairphone OS Version 1.5.1. Via the fastboot-way I installed Fairphone Open OS 16.07.1 (by wiping all data etc.). After that I reinstalled a backup of all apps (not system!) I made with adb. The system itself was completely factory reset.

Maybe Fairphone Open OS 16.07.1 sets sleep_timeout to 30000 if there was no value set before (means: installing that version from scratch instead of upgrading from a previous one)? But thats true speculation. For sure I can say: With Fairphone OS 1.5.1 there was NO problem with any timeout.

Update: I just greped all the firmware-img’s for a string like “sleep_timeout” in combination with “30000” but can’t find anything. I know, it’s a poor-mans approch of finding information. :wink:

Regarding the naming: I thing people say “Fairphone OpenSource OS” because at http://code.fairphone.com/ the terminus “Open Source” is part of every second line. :wink:

It was called FP Open Source OS earlier and many people referred to it as FPOSOS, until someone got the idea, it would be important to rename name it. Now officially it is called FP Open OS.


I did it with your given shell and root command line. Crossing fingers without thinking about risks that you decently mentioned. Your wonderful explaination made me try it and I was rewarded with functional display sleep time. First I thought this bug should be better corrected by another FP release. But after reading this topic to the end my hope vanished and got afraid I could wait for ever.

thanks, @Wico