Phone constantly crashes and stuck in boot screen

Hi there,

since the afternoon of 23 July '16, my FP2 constantly crashes randomly and is very often stuck on the boot screen (where it says “FAIRPHONE” in the middle and “POWERED BY android” at the bottom). The crashes announce themselves by a frozen screen for roughly 6 seconds.

To see whether the problem is hardware related, I took out my two SIM cards, entered recovery mode and reset the whole phone to factory settings. Yet, after setting it up again, the mentioned problems remain.

I have had two or three crashes in the past 5 months (I’ve got the phone since late February '16), but the phone then rebooted without any problem. But now, these constant crashes and boot screen freezes literally came out of nothing without me (un)installing or (de)activating any apps within the past 7 days.

Additional info:

  • The phone has Fairphone OS 1.7.0 (1.5.1 when this issue arose) and is NOT rooted.
  • There has never been an SD card in the phone.
  • This issue also happens without any SIM card inserted.
  • Wiping the cache partition from within recovery mode did not have any effect regarding this issue.
  • Even entering recovery mode (holding Vol-Up + Power) is hard. Most of the time, the phone simply reboots as if I was only holding the power button. Even taking out the battery beforehand to shut it down does not change that. It’s kind of a lottery whether I will manage to get into recovery mode or not.
  • Even in recovery mode, the phone crashes occasionally.

My phone is currently unusable in this state. If it is a hardware problem, what should I do?

Thanks for your help,


in that case I would contact the Fairphone support team.
To me this problems look some hardware related issue.

You could try to dis- and reassemble the phone and try if that helps. Maybe some connections do not have a good signal.

1 Like

I would like to do some hardware analysis, but this requires root access. In the warranty it says:

“This Warranty is not applicable for: […] (g) damage caused by breaking or circumventing access limitation protection or by the improper usage of a root access;”


“For security and legal limitation reasons, we are not providing the Fairphone 2 with tools to enable root-access on the Fairphone operating system with GMS”

The issue described above did not occur as a result of rooting. Instead, I want to root the phone to analyze the hardware for damage. Does that mean, rooting the phone for analysis purposes expires the warranty? What are these “legal limitations” which are mentioned in the warranty? Do they somehow apply in the described case?

Some additional potentially helpful information

… after some days of observation and investigation

After a few (automatic) boot attempts, the phone was “optimizing” apps. It seems that sometimes, it even crashed there (unless this action might actually involve reboots). It did this optimization every now and then after a few crashes (I didn’t count the crashes between these optimizations).

Three days after the problem’s first occurence, the phone did not get past the boot screen for a few days, no matter what I did. It didn’t even get into the charging screen (which it usually does when plugging it in while it’s off).

But some days later, I could charge it over night and the next morning, it was seemingly working again. So I inserted my SIM cards, configured some settings, but installed only some very basic apps (Lightning browser and Telegram messenger).

I recognized though, that since then on each boot up, the phrase “starting apps” pops up for a split seconds. I have either never noticed this before or it just didn’t appear before.

The phone worked seemlessly for two or three days. At some point, out of nothing, the phone asked me for my second SIM card’s PIN. And while I was typing the PIN, it froze and roughly 6 seconds later, it crashed.

Again, I found the phone in the same situation as before … and again, some two days later, it booted and worked again.

I cannot find a pattern yet, but I’m trying to find a connection between the crashed and either the usage time or the date/time, in case it might be a software issue. Latter is supported by the fact that the display sleep timeout is limited to 30 seconds.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.