Software update: FP4.SP21.B.048.20230215

For screenshot please see and and follow-up in the dedicated topic.

The clock thing is most likely an A12 feature and not a FPOS bug.

The missing icons are still there in the statusbar when you just pull down once from the top (what I think you call tray). Not sure if bug or not…


Well, mine shows right now “11 hours of usage since last charge”, which I doubt, because it’s 14:00 and that would mean I charged it at 03:00 in the morning, and at that time I was sleeping…
It does seem to be a little out of kilter.

A post was merged into an existing topic: Bluetooth audio bug on Android 12

Hi! Thank you for your work.

Since the last update, sometimes the keyboard stops popping up until I restart the phone.

Does it happen to anyone else ?


No, it doesn’t happen to me.

Hi and welcome, in all apps? Do you use the stock keyboard or any third party?

It’s the standard android keyboard.

I noticed while using signal. Then the keyboard does not pop up in any other app when I touch text boxes.

Maybe clearing the cache of the Gboard App helps, under settings, apps, gboard, cache and storage…


I have the same problem with my music apps, they freeze on my Fairphone 4. I can’t use my IFI GoBlu with aptX Adaptive. It works if I turn it off but that cancels my interest in using the GoBlu. Thankfully the phone connection in my car still works over Bluetooth. I don’t know if aptX HD is available on my phone as I can turn aptX Adaptive on and off but that is the only version of the codec I can see.

Thank you, I’ll try it if it happens again.

Wide angle lens distortion can be corrected with:

ffmpeg -i in.mp4 -vf lenscorrection=k1=-0.21:k2=0.055 out.mkv

I’ve found these parameters by recording a grid pattern.
They’re not the best but it corrects most of the distortion and makes a video with regular parallel projection perspective. Please note that some data (edges) is lost with this filter.

Edit: another filter

-vf "v360=input=sg:ih_fov=91:iv_fov=51.5:output=flat:d_fov=100:pitch=0:w=1920:h=1080"

Huh yeah my Minirig changed from aptX toggled off to on with this patch but as it’s not aptX HD it then didn’t work - bit of a silly one for it to turn on all hd audio codecs when not all fixed.

Appreciate lower brightness though happily with 12 it’s great to have an extra dim setting option built-in too

No issues with my keyboard nor 5G

Just for the record, today I moved out of my lair (hollow volcano island) and indeed, it does 5G just fine.


I am similarly appalled to report that I’ve finally accepted the Android 12 update with this, and after a few strange teething troubles (a few minutes after upgrade, the screen just went black: only the emergency-poweroff menu worked, so I rebooted that way)… I have experienced no problems at all, and everything I needed to work has just worked. (The new UI of the app switcher and the notification pulldown are really pig ugly, but I guess that’s Android 12 for you.)

This is just not good enough! I expect some really seriously annoying problems so I can rant about them like everyone else who upgraded last month got to do. What is the Internet coming to, grumble grumble


Ok so I’ve been using wide lens for 4 days and it might be as good as a GoPro (except stabilisation).
Fairphone 4 doesn’t overheat, records 4K H.265 for like 12 hours on a single charge - all with a great software support.

# Removes distortion. Adds nice blurred background
ffmpeg -i in.mkv -filter_complex "[0]v360=input=sg:ih_fov=91:iv_fov=51.5:output=flat:d_fov=100:pitch=0:w=1920:h=1080:alpha_mask=1[a],[0]scale=1920:1080,boxblur=50[b];[b][a]overlay" lens.mkv


A post was merged into an existing topic: Display brightness too low at dark environment

My Fairphone4 just installed some new version. 1GB, and apparenty no way to avoid it.
Now the scren keyboard has narrowed, with a band on the left (or right), uncomfortable.
Where has the screen shot option gone? It used to be just under the windows of active apps.
When I swipe the small screen of an active app upwards to disactivate it, but don’t swipe high enough, it hangs (for that app only) somewhere halfway up, and no way to get it down again.
And in the system settings now everything is uniformly black, all the colours have gone: more difficult to find things!
What is happening?
Andriod 12.

You should find it by tapping the app icon above the window vignette, which will open a menu containing Screenshot. Otherwise there’s always Power + Volume down.

Have you rebooted the phone since doing the update? Turn off completely, then on again (not “restart”).

Which version do you now have? When you’re able, check this by going to Settings > About phone > Build number

Would you also specify the name of your carrier (network operator) and country?

1 Like

Hi OldRoutard:

  1. tapping the icon above the app is a solution I already found but it now needs TWO taps to make a screenshot. Progress…
    Power&VolumeDown do NOT work.
  2. Yes I did the reboot. Did it a second time now, no change.
    3 )Versions: build number: FP4 SP21.B.048.20230215
  3. Carrier: Orange, France. (that should have nothing to do with the usability of the user interface though)
    Sigh… It seems the form takes more and more priority over the functionalities.

And how do I get a clock display with seconds? (no, don’t tell me there are apps for that, I just want the seconds at the top of the screen next to the carrier).

I recognized some issue that happened after A12 update that can but must not be related to the a bug at the OS level. It is a bit weird:

I use the app “Automate” from LlamaLab for several automation tasks. One of them includes speech recognition. Automate (as far as I understand it) uses the recognition engine you define as default in Android.
When I try to use speech recognition in Automate, it says now
java.lang.IllegalStateException: Language not supported.
(that is a system message only piped to the Automate logs)

I digged a bit deeper and it seems to have something to do with a new AiAiSpeechRecognition engine introduced in A12.
To not make this post too long, I will spare you the details but send them to the FP support. Maybe they can reproduce and fix it.
If anyone is interested, see my post at the Automate community at reddit: