English

Software update: 3.A.0101.20210420

Hi amoun, How can you revert to the previous version? Do you know Any step-by-step instruction anywhere in the forum or internet?

Here’s a topic with links to versions:

1 Like

As for the manual install there are topics on that, my next post links to the official Faiphone instructions. Once you have the version you want even /e/ or LOS you will need to install the Android Debug Bridge (ADB) to a computer and use that to access the phone etc.

You can search for (adb) and ensure you are happy with that before doing anything else. i.e. download adb and connect to your phone. Once you are confident you can connect to your phone via computer you can download a version and install/flash to the phone.

Here’s a link to the download options:

Here’s a Fairphone page on manual install, which is clearer and as official is more confidence boosting :slight_smile:

Just a bit more on installing the android dev bridge.

Here is a page written by the e foundation for those that want to switch from the default android 10 ~ this is just to show the adb install process.

https://doc.e.foundation/pages/install-adb

I have installed adb on my Raspberry Pi computer, the process as you can see is much the same ~} you have to install the adb for the OS of your computer e.g.

Since updating to this firmware version, my WiFi reciever has become unstable . On all of the AP’s tested , the WiFi is flapping ( Connecting/ Disconnecting)

Flapping between what and what? If it is a network issue try aeroplane mode then use wifi only. If it is a wifi at home try ensuring your router is on 5G only.
Of course if you are out and about the phone may switch amongst 3G, 4G, 2.4Ghz and 5Ghz.

It could just be a network issue or a phone setting you had that wasn’t kept by the update.

By the way, if you want an uncluttered topic to address your issue you would be better of with a new topic explaining the problem and what you have done to try and resolve it, something like WiFi unstable after update to 3A0101 You could then post it under the Help > FP3 category

1 Like

As I said the Wifi Receiver is flapping ( disconnected/connected) Irrelevant of the mobile network . Irrelevant of what AP ( I have tested many )
Why should I use 5Ghz ? 2.4 Ghz has better coverage , if both are saved as AP’s or the AP is common , usually it is up to the device to connect to the stronger signal . I prefer not to use 5Ghz in many cases . It should work this way .

It has nothing to do with location , it is the same wherever I go , its a bug , never done this before . Just writing here as a warning and I have already submitted a support ticket to Fairphone .

I can bet that I will be asked to reset to factory … Yawn , then spend another hour restoring all my apps

2 Likes

I liked your post not because you have an issue with WiFi, but come to the same conclusion. One of the “Golden Rules of Troubleshooting” is to know when was the last time something worked, and you clearly wrote:

Another rule is to find out whether other components have a positive impact or not. Does the issue occur with other networks, too?

So we can rule out an access point issue, too.

It is just that simple: A new software came out, it was applied, now things do not work anymore like they did before.

Do you have a security app installed that possibly monitors your WiFi networks?

So after installing the latest version using their tutorial I am so far running it without major issues. Let’s hope that I will be able to update.

Thanks again to all that helped or reached out to help.

4 Likes

Hi @phineas,

The Fairphone 3 and 3+ is technically capable of using VoLTE and VoWiFi technologies, however at the moment, we are still working on completing partnerships with some network providers. Here is a list of network operators we currently support.

7 Likes

Finally, some straightforward information on this topic. Thanks! Though kind of disappointing to see that there is so little support for VoWiFi (yet).

Edit: The page says

Currently, we support the following Network Operators from the indicated software version (or higher).

But no software versions are mentioned anywhere.

Hi @rae !
Thanks for the link, I didn’t know this list existed.
However, I am using SFR from France, so this should be compatible.

Edit :
“To use VoLTE or VoWi-Fi, the service needs to be enabled on both phones (on your Fairphone and also on the other device that you are calling).”

Really ?!

1 Like

I had overlooked this. This is very strange indeed and does not give me much confidence that the other information on this page is correct.

Edit: I mean the page with the VoLTE/VoWiFi information that @rae linked to.

1 Like

What other information are you referring to, presumably you mean the page by Fairphone

Yes, sorry this was unclear.

To use VoLTE or VoWi-Fi, the service needs to be enabled on both phones (on your Fairphone and also on the other device that you are calling).

I guess they mean it in a different context: to achieve best possible audio quality…

1 Like

The download link for this version is available:

https://fileshare.fairphone.com/link/ur8b6DfHB6jnv1UQ6FIDnH/download/FP3-REL-Q-3.A.0101-20210420.163631-user-fastbootimage.7z

3 Likes

Just to provide an update:
Here I mentioned that my FP3+ drains the battery much more after the update. This was the case for almost five days.

But now - again, one day later - everything seems to be back to the usual level. Battery usage is fine again.

No idea what caused it, but it’s gone :grinning:

2 Likes

No! With VoWiFi you can call any number in any mobile or landline network. It’s the so called “HD quality”, which only works, if both sides are capable. And since HD quality depends on powerful mobile networks, it is only available via VoLTE or VoWiFi. So you need VoLTE or VoWiFi on both sides for HD calls, but you can do standard quality calls with any other phone connection.

2 Likes

Hi.
I have come across an issue where bluetooth enabled in the same freq band 2.4Ghz (2.42 to 2.48) interferes with wifi on 2.4. It happens on my Windows 10 tablet and my main Raspberry Pi4 computer. Sometimes I have to switch one off the bluetooth to connect to the wifi on 2.4Ghz.

The strongest signal doesn’t equate to the most stable if there is interference.

Ha! I’ve just been checking my phone’s connection, it has reverted to 2.4Ghz without me noticing and after a reboot and clearing wifi networks I can not even see 5Ghz, even when next to the router. If I enter SSID manually I get a message saying Network not in range. ??

And there I was thinking there’s no problem :blush: