SD Card no writing permission in FP2

hi i´m marc from munich and i got my fp2 one week ago, it is working good, some topics are unclear but is tried to solve all my problems. here´s one these small topics maybe somebody knows already.
SD Card in FP2 is working but i have no writing permission can somebody help me? i´m using ES explorer because i have a tera station in my network and with ES explorer it was possible to copy things from the NAS directly to the SD card of FP1, with FP2 it is not working. - does anybody know how?


Apps are supposed to ask the user (just like Amaze does if you try to modify a file on SD card). It’s also possible (with root) to circumvent this by using adb to pull /system/etc/permissions/platform.xml from your phone :

adb pull /system/etc/permissions/platform.xml

edit it by turning

    <permission name="android.permission.WRITE_EXTERNAL_STORAGE" >
        <group gid="sdcard_r" />
        <group gid="sdcard_rw" />


    <permission name="android.permission.WRITE_EXTERNAL_STORAGE" >
        <group gid="sdcard_r" />
        <group gid="sdcard_rw" />
        <group gid="media_rw" />

then re-push it to your phone

adb push platform.xml /system/etc/permissions/platform.xml

Then reboot your phone. You might have to adb remount before you push though.



This app does it for you. After applying you need to reboot your phone.

Keep in mind: the readonly SD card was a major security change from Google (I just haven’t figured out what risk this change should be mitigating)


ES Explorer and Amaze usually ask you to select the root of the SD card to grant permission when you try to do something, such as delete file. Have you been through this process?

Thanks to all of you, yesterday night i tried the version Jon1 suggested and it works without root access.
Forum rules!
by the way does anyone know when Fairphone will give a good advice how to get root access? The current versions are a little bit scary for me, i would like to have a suggestion from Fairphone.

That will work with said application but won’t with others (for example Osmand~ won’t be able to use your SD card to store openstreetmap maps).

Hello Arvil,

Osmand can save to external SD card at “/storage/sdcard1/Android/data/” - or do you mean something else and I’m wrong here?

I installed BTSync on my FP2. I try to sync files between FP2 and PC. But BTSync app say has no write permission on SD card? Any idea wouldbe welcome. BTsync running without any problem on my FP1.

Have you followed my guide from the beginning of this thread or used the app that was linked to ?

@Arvil Thanks. That app need Root Access. Your guide to complicated for me. I am a beginner ;

If you don’t have root and the app doesn’t handle it, you won’t be able to work it around (that’s why it’s so great to have root)


How do I get root access on the FP2?

There are some ways to get it and they are all listed here:

when I try to re-push after modifying the platform.xml adb says:

cannot stat ‘permissions.xml’: No such file or directory

So I tested the “adb devices”-command an my phone is displayed as

e503c01f device

Now I tried the “adb remount”-command but the system says:

remount of system failed: Permission denied

So how do I get my edited xml-file back?

Do you have your phone rooted?
This is necessary.

Are you on stock ROM? Then you need to

adb shell

Into your phone and continue as root, by typing


Then you should be able to remount your /system partition by using

mount -o rw,remount /system

Finally, exit the shell (type “exit” twice). Now it should be possible to push the file back. Note that you want to push the file platform.xml and not permissions.xml (there is a small mistake in the guideline above).

For a more detailed description of this approach you can also have a look at the bottom of the wiki here.


Thank you for helping a beginner!

Yes! Since today!

I think so because I didn’t create my own image. I used 2.B) :slightly_smiling:

When I did that it went like this:
E:\ProgrammeAuf_E\Kommunikation\Minimal ADB and Fastboot>adb push platform.xml /
failed to copy ‘platform.xml’ to ‘/system/etc/permissions/platform.xml’: Permiss
ion denied

E:\ProgrammeAuf_E\Kommunikation\Minimal ADB and Fastboot>adb shell
shell@FP2:/ $ su
root@FP2:/data/data # mount -o rw,remount /system
root@FP2:/data/data # exit
shell@FP2:/ $ exit

E:\ProgrammeAuf_E\Kommunikation\Minimal ADB and Fastboot>adb push platform.xml /
failed to copy ‘platform.xml’ to ‘/system/etc/permissions/platform.xml’: Permiss
ion denied

Where is my mistake?

I see.

This most likely because you’ll need su rights also for copying the file to the system partition, so after logging out you are no longer “su” on the phone.

If you have a sdcard in your phone, you can copy the file there first, and then to the /system partition.

so it would be first:

adb push platform.xml /storage/sdcard1/platform.xml


E:\ProgrammeAuf_E\Kommunikation\Minimal ADB and Fastboot>adb shell
shell@FP2: su
root@FP2: mount -o rw,remount /system
root@FP2: cp /storage/sdcard1/platform.xml /system/etc/permissions/platform.xml

An other option would be: If you have busy box installed, you could edit the file directly on the phone. A description how to do that is at the very end of the wiki in the “how to root” thread.


I have my FP2 now 7days and tried 3 mirco SDs - I formated them several times in the FP2 and all of them are working perfectly on my FP1 - but I can not write on any of them in my FP2.
When I try to create a folder on the micro SD with amaze e.g., amaze informs me “unfortunately, amaze has stopped”…and stops. When I try it with other explorers (I tried 3 of them by now) they inform me that I have no writing permisson.
Not enough, the external SD vanishes at least 4 times/day and I have to mount it again, and with “mount” I mean I have to open the phone and physicaly get it out mount it back in, the promt “mount SD” won’t work.

Are there solutions without rooting?
I am using my FP1 again, because it is realy getting my nerves now :frowning:

As I understood it is an Android security measure which does not allow to write to the SDcard by default. For changing this and granting general write permissions apparently su rights are necessary (i.e. the device needs to be rooted).

That the SDcard unmounts/disappears has been reported before, though I don’t know what the cause was or how to solve the problem.

Wouldn’t an adb root before pushing suffice ?