FP2 Open OS 16.05 : lost read access to SDcard from applications


My phone had the proximity sensor failure problem (black screen during calls : can’t set external speaker, nor check or note things in the phone during calls as powerbutton has to be set to end calls…), and two more problems recently appeared : screen shifting by a quarter upward with “snake” effet (the top of the screen was drawn for the bottom), and it became very slow for everything (swipe some order on the screen, it will take effect after the next 2 or 3 seconds). So I made the software update, crossing fingers.

The update didn’t brick the phone, neither it improved my problems. So I opened-up the phone and blown a bit on the proximity sensor (and everywhere else I seens dust on it). It brang back my reactive FP2 (it may give hope to : FP2 Screen can’t be reactivated during/after calls - See first post for Workarounds )

But all my installed applications lost access to external storage. Data are still here as Amaze in root mode is showing, or root user in Termux. But, as a normal user, I can’t go from / to /storage (nor /sdcard).

As it was not working I did edit my /system/etc/permissions/platform.xml, and reboot, but this is to gain write access. Still I did lost the file and build it back this way : SD Card no writing permission in FP2

But still, it’s read access that I miss first, and I missed it before changing this file.

Permissions on the files and folder look good (/system/etc/* ; /storage/sdcard1), but for instance, my regular Termux user seems to miss group memberships as :
$ id
uid=10092(u0_a92) gid=10092(u0_a92) groups=9997(everybody),50092(all_a92)

I expected some sdcard_r, sdcard_rw, media_rw and so on… but I have no background in Android.

Can you explain this a bit? The file you show is missing the write permission changes. Having the “write” rights under Android should give you reading rights as well (confusing, I know).

Could you try adding those changes again?

If you need the file “fresh” again (but what you show looks okay, it’s just the file without changes), you can just download the bin blob and unpack it. You will find the “fresh” file under: ./vendor/qcom/proprietary/target/product/FP2/system/etc/permissions/platform.xml

The file is okay, but it’s missing the extra entry:

<permission name="android.permission.WRITE_EXTERNAL_STORAGE" >
        <group gid="sdcard_r" />
        <group gid="sdcard_rw" />
        <group gid="media_rw" />

Could you tell us if re-adding the changes works for you? Or have you tried that already? Don’t forget to reboot, just to be sure!

So, sorry I was long, but I did take a fresh file as you suggested, and just rebooted with no read-access back.
I have no user read-access to /storage, so no sdcard0 nor sdcard1… (The phone becomes a dumbphone this way.)
But root access is ok, it must be a right-management failure. I’m surprise to be the only-one with this problem after an upgrade to 16.05…

To explain a bit how a “lost” the genuine file : I made a script to patch automatically after an upgrade, using the embeded vi and a regex, and well, it’s working as expected yet… (and it saved a bad file).

Tried both :
# reboot
# halt

I tried to re-activate the privacy impact app.
I discovered that Updater and f-droid did lost internet right.
Else, it exists (in storage settings) an entry : application with sdcard read right ; it was an empty list.
Also, my phone, which where ciphered before installing Fairphone 16.04 is now listed as unciphered with 16.05…
I did re-init everything from settings menu (snif).
Everything is back in place (except my applications), and even the platform.xml file is the last one I put in place, with external storage write permission given…
(will let you a few hours, I have 40 apps to install and configure back…)


my problem is nearly the same.
After I have installed the latest version of FP Open OS, i cannot add the media_rw line to platform.xml.
Amaze in root mode tel me that saving is done but the added line has disappeared. I tried a lot of reboots and also another file manager. I changed the root-permissions from “always” to “ask” and back again, but nothing happens.
It seems like the update changed the root-rights …

Can anybody help me with that issue?

Before you can edit the file, you need to remount the /system partition (which is by default mounted as read only).

So before editing, open the terminal, type


to gain root rights, and then

mount -o rw,remount /system

Then go to Amaze & edit the platform.xml file.

Thank you for that.
Where is the terminal. Is it an extra app or do you mean a program on my notebook?
I used adb to root my fairphone in january and to switch to open source os, but these are my only experiences with that. Its my first smartphone.

Amaze with root-rights will do the remount thing itself. Just go to the file, edit it and save it.

1 Like

That doesn’t work, as you can read in my post above. I tried to change and save the file with different root settings for amaze. “Always” and “ask”. I even tried it with another editor from f-droid.

Another way is changing the file on my pc, right? Before i installed the latest two updates of osos, i was able to change the file with amaze.
I am wondering, that its not possible anymore. Ti backup is telling me, that i have root rights.

You must have a superuser-app working, where Amaze has an entry that allows this app root-rights. Delete this entry and point Amaze to /data/app. What happens?

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.