Samsung 64GB SD-card not detected after every reboot

I just my 64GB micro sd card some month with my other phone. I inserted the card in the FP2, erased the card and copied some backups via wifi on it. After a while I rebooted the phone and there was no sd card. At the storage options I just found two buttons (mount and erase). Mount doesn’t work, so the only option was erasing.

Little update (30.01.16):
I was optimistic the last days, because 4 reboots and everthing went fine.
But today same problem after reboot.

Did you already try the second option (erase)? Does it work afterwards?

Yes, I hit erase and I can use the SD-card, until the next reboot.

That’s strange. Well, as soon as I formatted (erased) my SD card, I gave my camera apps and my file manager a write permission. I can’t imagine that this is necessary, but you could just try it.

After erasing I give my Total Commander (file manager) the permission to write on the sd card. Now I created a new folder. Reboot. Everything is fine. Put some files on it via USB-cable. Reboot. Same Problem.
When I try the card on my other Phone or on my PC, I can see and write the files on it without any problems.

How do you connect via USB? Via MTP or via “mount SD card”? I always use MTP…

I use MTP or via wifi with “MyPhoneExplorer”


I have the very same problem with my (Samsung) 64GB SDcard. The only way to make it at least visible to the Fairphone is by using the Fairphone’s option to “Delete SDcard”. I still can’t write on it and after reboot it is completely gone again. The card doesn’t make any trouble on any other Android device, only on the Fairphone. My 32GB card (also SanDisk) works fine.
I have tried all methods that I could find in the net, the ones needing root and the ones which don’t. Still, I had to give up trying. Seems to be an incompatibility, somehow.
Well, as the Fairphone has 25GB itself and with 32GB more I think I can live.

Maybe a question to the forum: has anyone got a64GB card running on the FP2 and what mark is it?

1 Like

This is a permission problem which is set in Android. However, on a rooted device it is easy to fix this problem. But I’m afraid that this unfortunately won’t help much if your phone can’t detect the SDcard.

Well, that problem I could fix as desribed in the link. Otherwise I couldn’t have written on my 32GB card. The 64GB problem is a deeper one. I can’t access the card at all.

I’m having the same problem 64gb sd card that is not mountable… has anyone been able to get a 64gb sd card working in a fp2?

Yes, my 64 GB SanDisk Ultra works perfectly, after formatting it with the phone.


I’ve got a Samsung EVO 128GB card in my FP2 and so far, it has behaved perfectly. I was able to erase and format from the phone, then mount and copy my music from PC using Windows Explorer.

1 Like

Samsung 64GB card. The last three times I have to restart the phone, I was able to use the card by taking it out of the phone and back into it. Didn’t need to mount, but that is not very ideal.

I have the same problem with my Samsung 64GB SD Card. It is not being detected after a reboot. Should this be on the known bugs list?

5 posts were merged into an existing topic: SanDisk 32GB MicroSD not detected

I´m using a fresh Samsung Micro SD PRO+ 128GB Memory Card which is performing flawless and smooth in my FP2.

One thing I could experience shortly: it worked perfect from the beginning and was formatted with fat32 by the phone.
I guess there is not much choice in fs selection when fresh out the pack.
Partition size isn´t a problem for the fs, but rather file size.

So recently I tested some new apps and experienced later not being able to access my card. No replacing the card, rebooting or taking out the accumulator changed this condition.
My filemanager simply couldn´t see it any longer.

So I took it out once more and checked the filesystem with windows, there were errors found.

After fixing the fs all went well again and I could access it again with my filemanager on FP2.

Also don´t miss to unmount/mount it if you plan to remove it to prevent damaging the fs.

I have a similar experience with my 64 GB Samsung SD card. When I have to reboot my phone, the SD card is no longer visible. When I insert the card into my PC I need to run CHKDSK and then my FP2 recognizes it again until the next reboot. Today my FP2 was no longer able to read the SD card, so I inserted it into my tablet which immediately recognized the card. So I ejected it from the tablet and could read it fine in my FP2 after that.

So I highly suspect that something marks the card dirty and does not close this status when powering off the phone. So on reboot it’s also not able to fix the chkdsk required status and then the card is gone.

Sounds like a recreateable and fixable scenario to me.
Thanks for looking into this.

Just for the records, my samsung 64GB SDcard is working well in the FP2. No problems after reboots.

Next update (23.04.2016):
With the new update it got a little bit worse. Before the update I used the tip, that you just have to reboot the phone a multiple times until it recognized the SDcard. Now I can reboot it 15 times and nothing changes. Now back to start. Open the case after every reboot (includes spontaneous reboots) and put the card out and in again and again until it works…