Samsung 64GB SD-card not detected after every reboot

I also have the same problem with my new Samsung 64GB evo card. Only solution that works consistently is to take off the back and remove and reinsert.

Hopefully fixable with a software update.

I also had this problem with my SanDisk 64GB card with the FP Open OS.
I was able to fix this by formatting the card to EXT4 with my computer and formatting it again with my FP2 in the storage-settings. Since that, everything is working fine. :blush:

Hopefully, this helps you and also works under other circumstances too. :sweat:

1 Like

Meanwhile I have tried several options and believe it is some kind of timing problem when (auto) mounting the card on reboot.
Usually I do the following with my Samsung 128GB pro+ which in most cases brings back my sdcard after boot.

I don´t reboot my phone but only power it off, rebooting usually don´t manage to get my card mounted again but rather spends my fresh accumulator while doing several runs.
So I have to wait some time after power off, it could take 60 secs or more. After powering on and booting the phone I patiently unlock my sim card(s) without any rush waiting a moment for it (them) being unlocked.
After this I unlock my phone and go to settings/storage to see if the card is available again.
When doing this procedure in most cases I only need one attempt to get back my sdcard.
Anything else that I have tried in the past like rebooting, (re)formating, unmounting before rebooting or what others had also sugested didn´t solve this issue for good.
But with this procedure I have very good chances to get my card mounted quicker than with all other approaches I took.

Have you checked if your SD card might be defective?
I had similar issues with multiple SD cards. The phone did not detect them. Sometimes “Erase SD card” on the phone helped, sometimes not, sometimes it lead to reboots.
In most cases I could see error messages from Vold in the log (with “adb logcat” from a USB-connected computer).
The example log messages below shows that the card was not accessble, then formatted and the filesystems check durign mounting was ok. But creating a directory (LOST.DIR) on the card failed, so it was never mounted.
Note that this example also shows that one of the relevant services crashed due ot the check leading to a reboot.

D/Vold ( 234): Volume sdcard1 state changing 1 (Idle-Unmounted) -> 6 (Formatting)
E/Vold ( 234): Failed to apply disk configuration (-1)
E/Vold ( 234): Failed to initialize MBR (I/O error)
D/Vold ( 234): Volume sdcard1 state changing 6 (Formatting) -> 1 (Idle-Unmounted)
W/Vold ( 234): Returning OperationFailed - no handler for errno 0
I/Vold ( 234): /dev/block/vold/179:65 being considered for volume sdcard1
D/Vold ( 234): Volume sdcard1 state changing 1 (Idle-Unmounted) -> 3 (Checking)
I/fsck_msdos( 234): ** /dev/block/vold/179:65
D/fsck_msdos( 6654): sectors Per cluster :16
D/fsck_msdos( 6654): boot->ClusterOffset :30356
I/fsck_msdos( 6654): FAT32 Filesystem
D/fsck_msdos( 6654): Using cluster_chain_descriptor
I/fsck_msdos( 6654): Total clusters 1942742
I/fsck_msdos( 234): ** Phase 1 - Read FAT (compare skipped)
I/fsck_msdos( 234): Attempting to allocate 7589 KB for FAT
I/fsck_msdos( 6654): ** Phase 2 - Check Cluster Chains
I/fsck_msdos( 6654): Begin to handle the cluster chain
D/fsck_msdos( 6654): rootDir->head :2
I/fsck_msdos( 234): ** Phase 3 - Checking Directories
D/fsck_msdos( 6654): Verify Filesystem information
W/fsck_msdos( 6654): 1 files, 2959000 free (1942739 clusters)
I/fsck_msdos( 6654): free_rb_tree
I/fsck_msdos( 6654): free_fragment_tree
I/fsck_msdos( 6654): free_fragment_tree
I/fsck_msdos( 6654): free_fragment_tree: rb_tree is empty
I/fsck_msdos( 234): ** Phase 4 - Checking for Lost Files
I/Vold ( 234): Filesystem check completed OK
E/Vold ( 234): Unable to create LOST.DIR (I/O error)
D/Vold ( 234): blkid identified as /dev/block/vold/179:65: LABEL=“android” UUID=“EE3E-9E59” TYPE="vfat"
E/VoldConnector( 1141): timed-out waiting for response to 14 volume mount /storage/sdcard1
--------- beginning of crash
E/AndroidRuntime( 1141): *** FATAL EXCEPTION IN SYSTEM PROCESS: Thread-299
E/AndroidRuntime( 1141): java.lang.NullPointerException: Attempt to invoke virtual method ‘int com.android.server.NativeDaemonEvent.getCode()’ on a null object reference
E/AndroidRuntime( 1141): at com.android.server.MountService.doMountVolume(MountService.java:1154)
E/AndroidRuntime( 1141): at com.android.server.MountService.mountVolume(MountService.java:1794)
E/AndroidRuntime( 1141): at com.android.internal.os.storage.ExternalStorageFormatter$2.run(ExternalStorageFormatter.java:295)
D/AndroidRuntime( 6725): >>>>>> START com.android.internal.os.ZygoteInit uid 0 <<<<<<
D/AndroidRuntime( 6725): CheckJNI is OFF
W/Vold ( 234): fs_prepare_dir failed: I/O error
E/Vold ( 234): Failed to mount secure area (I/O error)

In the end what I did was to thoroughly test all SD cards on a computer:

  1. Format the whole card with fat32 or ext4
  2. Create some directories
  3. Write big files to it to fill the whole card
  4. Umount / detach
  5. Attach / mount
  6. Try to read files
  7. Repeat the procedure ten times

All three SD cards I had showed errors and failed during this process, while a new card survived the test and is now working fine in my phone.

I have the same problem with a new FP2: A “Samsung Pro MicroSDXC 64GB UHS-I (Class 10) 90 MB/s” card does not get mounted after a reboot (sometimes).

My finding: The “card not mounted” problem occurs very often if the phone is warm/hot and you reboot it. If its cold, the sdcard seems to work fine. If I shut down the warm phone and wait a little moment (1-2min), power up -> all fine too.

So, could it be temperature related?

I reported the same issue with my Samsung card earlier, but a two weeks ago I ditched the Samsung card and put in a Lexar 64 GB card and I haven’t seen the problem so far. Very strange though, there must be a very tiny electrical margin where the Samsung card seems to have a problem.

Hi folks,
my fairphone 2 functions very well with a Lexar 633x 64 GB micro SDXC and with a Samsung 64 GB Eco. At every time I switch the phone on, the sd-cards are well recognized. I had the same problems as other users here with a Sandisk Ultra 64 GB. The problem was, that the sandisk was never recognized after shutting down and switching on the FP. The Lexar was first not recognized after putting it in the FP. In had to format it with the FP and then it functiones now.
These are my experiences with sd-cards in th FP2.

This post was posted wrong page . sorry

Hi
I also have the same problem as all above … The problem is random, but in most cases, I loose the SD card when I reboot my FP2.
My SD card is also a 64 Go SAMSUNG EVO Plus.
Dis anybody find a solution that does not need extra computer ?

A new finding on this: I installed Fairphone Open OS 16.07.1 and since then no problems mounting the SD-card, even if the phone is warm/hot. But lets see how it goes the next couple of days …

I have the same problem - a Samsung 64GB SD card which disappears after every reboot. Removing the card and reinserting it works OK, but it’s annoying and then I have to reinstall all my music files on VLC!

Did anyone find a solution to this? Should I install the Open OS? I’m a bit nervous of doing that as Android is working fine for me.

I still can say - without having any explanation why - after switching to FPOS the problem went away for almost every reboot. I say almost because it does NOT work 100% but its still better then it was before I made the switch. Very seldom even on FOPS the SD-card is “gone”. But: If that happens, I shut-down the phone, put it into the fridge, wait 5min - and thats it. Fun times with fairphone …

Hi, I have a XLYNE Micro SD card of 64 GB in my FP2 and experience the same problem with mounting the card. After the first time I inserted the card (bought new, straight out of parcel) it didn’t recognized the external memory. The mount option in settings didn’t do anything so I formatted the card and after that it was read and writable. This was yesterday, think I rebooted the phone somewhere between then and now and just saw that I was missing some apps which I had moved to the SD card. So checked and currently no card detected by the system. I’m on OS 1.10.1 Android.

I also have the issue of “not mounted after reboot” with a Sony SR-64UY 64 GB SD card.

Maybe we compile a list for “recommended SD cards” (although there is a risk that the same model is slightly different when produced in different fabs)?

I experience the same problem. Every time I restart/reboot or turn my FP2 on, after it have been turn off, I get a message that my SD card isn’t detected/present, and that I should put this unit into my FP2 again.
I’ve both done this, and under options I’ve both try to delete and re-add it, and configure it. But nothing helps.
So I hope that someone can help.

My SD card is a Kingston microSDHC 32 GB

Hi,
I have a SanDisk Ultra 64 GB working perfectly fine without any problem. No need to format it as well.

@paulakreuzer @Stefan
Maybe you could make this posting a wiki and start a list in the first posting, where for every OS users can add SD cards that are working fine and that have problems.
Maybe a pattern shows, as it seems, that Samsung and Sony cards seem to have the most problems.

Hey @BertG.

I think that’s a little too complicated. You’d have to specify working/not working/partially/working for some working for at least 5 different OSes, everything might change after an OS update, everything might change after Samsung/Sony/… update their hardware.

How about instead we just make polls for the different manufacturers where you can vote how well SD cards from them work?

I thought I had fixed this by buying a Lexar card instead. But now (since upgrading to Fairphone OS 17.9) it tells me my SD card is corrupted, or won’t recognise it at all. Do I need to buy a 3rd SD card now?!

Maybe you could add yourexperiences to this list:


The actual OS would be 17.10.1. I would try updating first, befor buying a new card.

Thanks. Yes, I have updated to 17.10.1. But it was when I upgraded to 17.9 that my SD card stopped working.