[ROM][UNOFFICIAL] Unofficial LineageOS 18.1 for Fairphone 3/Fairphone 3+

How to close the settings app? I needed to add a fingerprint because I removed it. And that’s something I need to do in the settings app :slight_smile:

  • I did the following: I removed my unlock pattern and added a fingerprint. Rebooted the phone. Now when I’m closing the screen my phone automagically unlocks.
  • I tried using ’ adb logcat’ and got an insane amount of lines between closing the phone and that the phone unlocks itself. I’ll try capturing it.

This is the relevant output of adb logcat I think; I started logging when the phone went to sleep and let it wake up without my interference. I put it in a text file due to the length.

Edit: used Google Drive link. It is here

I can’t confirm that. As of may 28, with working frequency scaling, battery usage is ok. Not as good as with LOS 17 (which might be caused by the test UN’s debug features), my drain is at .8% the hour (in airplane mode, though). Still something to look into, but I’m not charging twice a day as with the first version :wink:

Does Bluetooth HID work on this ROM? i.e. for using the phone as an input device. itI doesn’t on the stock ROM. There’s an app that can check: https://play.google.com/store/apps/details?id=com.rkaneapplabs.bluetooth_hid.bluetoothproxy

For me it’s:


I guess Android 12 will be out by the time LOS18.1 becomes official for FP3/3+ :grinning:

1 Like

This release, doing what’s right, is great in itself. :slight_smile: I will happily switch to LOS17.1 beforehand as I await 18.1 official release. :slight_smile:

Hello @TeamB58 ,

I’m trying to build lineageos 18.1 for FP3+, but i get this error:

FAILED: out/soong/build.ninja
out/soong/.bootstrap/bin/soong_build -t -l out/.module_paths/Android.bp.list -b out/soong -n out -d out/soong/build.ninja.d -globFile out/soong/.bootstrap/build-globs.ninja -o out/
soong/build.ninja Android.bp
error: device/fairphone/FP3/light/Android.bp:16:1: module "android.hardware.light@2.0-service.msm8953" variant "android_vendor.30_arm64_armv8-a": depends on //system/libhidl:libhid
ltransport which is not visible to this module
error: device/fairphone/FP3/light/Android.bp:16:1: module "android.hardware.light@2.0-service.msm8953" variant "android_vendor.30_arm64_armv8-a": depends on //system/libhwbinder:li
bhwbinder which is not visible to this module
00:25:03 soong bootstrap failed with: exit status 1

Any help would be so appreciated
Thank You

Have you taken all the commits for lineage-18.1 branch?

This gets fixed with https://review.lineageos.org/c/LineageOS/android_device_fairphone_FP3/+/305113

Let me know if you still face issues.
Welcome to the community btw. :grinning:


Thank you for the welcome, I’m glad to be here, also i got my FP3+ last Wednesday. :slightly_smiling_face:

So, I did the fix, and the build started, but failed with a new error:

make[1]: Leaving directory '/LineageOS_18.1_src/out/target/product/FP3/obj/KERNEL_OBJ'
make: Leaving directory '/LineageOS_18.1_src/kernel/fairphone/sdm632'
depmod: WARNING: could not open modules.order at /LineageOS_18.1_src/out/target/product/FP3/obj/PACKAGING/depmod_vendor_intermediates/lib/modules
/0.0: No such file or directory
depmod: WARNING: could not open modules.builtin at /LineageOS_18.1_src/out/target/product/FP3/obj/PACKAGING/depmod_vendor_intermediates/lib/modul
es/0.0: No such file or directory
23:06:14 ninja failed with: exit status 1

Thank You

Could you share a few lines of git log --oneline from device/fairphone/FP3 project?

The lines that you have shared are not giving any information about errors.

ad88ae1 (HEAD, m/lineage-18.1, github/lineage-18.1) FP3: Import blobs from FP3-REL-Q-3.A.0101-20210420.163631
58bac88 FP3: Enable ANT
97ee746 FP3: Rework device Light HAL
fe68c69 FP3: Import blobs from FP3-REL-Q-3.A.0084-20210204.105300
b16f5c1 FP3: document correct source for SDM blobs
1c0f788 FP3: Update SDM blobs from LA.UM.7.5.r1-03700-8x96.0
bd8ac5c FP3: Import blobs from FP3-REL-Q-3.A.0077-20201221.124002
1bbb1ff FP3: remove move_time_data script
8628256 FP3: Use timeservice_app_cert-legacy-um certificate for TimeService app
b8676b0 FP3: sepolicy: Fix sysfs_rtc files path
c1253af FP3: Use proper source:dest in proprietary files list
754265a FP3: Switch to common basic USB HAL
eb0c544 FP3: import LED patch for light HAL
14fa82d FP3: fstab: Update mmc/usb sysfs paths to 4.9.
0ec818f FP3: extract-files: Adapt to new vendor/product blob layout
f9efe0d FP3: extract-files: drop unneeded libmdmcutback.so fixup
54baba3 FP3: extract-files: Add blob_fixup
e4a5a97 FP3: Build libvndfwk_detect_jni.qti
b2f3b1d FP3: Enable QC framework value-adds
19c5822 FP3: Update remaining permissions for Android Q
74f7622 FP3: Adding GSI keys
f579a92 FP3: Update kernel command line
4477fd7 FP3: Add updatable_apex.mk
90873f1 FP3: Generate the apex image.
5c70c4e FP3: build have overriding commands
ba56c9d FP3: Set cpu “runtime variant” to cortex-a53
714321b FP3: Use generic arch variant
7f66d16 FP3: Fix compile time symlink creation
ef0c686 FP3: sepolicy: address hotspot denials
4e95faa FP3: address a few selinux denials
49c996b FP3: sepolicy: remove persist.vendor.camera
b58c53b FP3: Address ‘LOCAL_MODULE_TAGS := eng debug’ deprecation.
695946c FP3: update init scripts from stock FP3 Q
583ab9a FP3: power: Adapt to new qcom-caf layout
3ae938e FP3: power: Ignore interaction boost sequence in a short period
f1a77b7 FP3: power: Simplify interactive code path.
469034b FP3: power: Remove not supported power op codes.
a0cd00c FP3: power: use SCROLL_PREFILING for short interactions
a85a55c FP3: power: use boost when flinging detected
0c88330 FP3: power: Take SCHED governor into account.
1e38085 FP3: Fix overlay path
ed76ece FP3: Disable config_cleanupUnusedFingerprints
ee5290d FP3: Add telephony_product_privapp-permissions-qti.xml to product
d847917 FP3: update qti_whitelist public.libraries and privapp-permissions-qti
1b8b23b FP3: Allow qcrild to access new QMI service
8ef0ba4 FP3: Remove vendor PowerOffAlarm app.
5dc1e40 FP3: Update vendor NFC config
591e58b FP3: Update Secure MSM blobs
1dbabb0 FP3: Update Wi-Fi and Wi-Fi Display blobs and config
fb2e7eb FP3: Remove vendor hals.conf
e2d7320 FP3: Update radio blobs and configuration
7374720 FP3: Update Qualcomm MSM Interface (QMI) blobs
50f6325 FP3: Update Qualcomm Perf and IOP blobs
379bea9 FP3: Update media xml configs from stock Q
50fe430 FP3: Update media blobs and configuration
f9d791a FP3: Update graphics blobs and config
34a6752 FP3: Build bootctrl using Soong
fe5f8b4 FP3: gpt-utils: merge in LA.UM.8.6.2.r1-07600-89xx.0
0b3d3c5 FP3: gpt-utils: Use generated_kernel_headers
d1a4f6f FP3: gpt-utils: Build libgptutils with Android.bp
51ca2f6 FP3: gpt-utils: Add debug messages and fix format warnings
7c5964a FP3: gpt-utils: Address the warnings
8a5376e FP3: gpt-utils: Drop unnecessary include
4e73817 FP3: move gpt-utils out of recovery dir
c52f921 FP3: Update GPS blobs
c66d9e7 FP3: Build new GNSS HAL
23802bb FP3: Update DSP blobs

I am not able to reproduce this in my new local build. Any pointers for this?

With this I don’t know how the build is even starting. You should probably get error when you try brunch it self.

The lineage-18.1 changes are not merged yet. You need to manually checkout with latest HEAD.

We are hopeful that official lineage-18.1 for FP3 will be ready within this week.



These are screenshots after i ran brunch FP3, and the build fails just after Building Kernel Image.

It seems I have to wait till the merge happens, also I do not know how to manually checkout with the latest HEAD, or Which directory should I be while doing the checkout? :slightly_smiling_face:

Thank You for your time

Hello all,
While we wait for the ROM to go official, have a look at this which is a new work by me.

Please share your feedback and suggestions.


1 Like

I have very recently bought a Fairphone 3+. As a first step I’m now planning to install LOS on the phone. But as LOS 17.1 will probably soon be replaced by 18.1 I would prefer to wait till 18.1 will go official - in my experience with my old phone (a 10 year old Samsung Note 3) it’s not so easy to go from 17.1 to 18.1 or from inofficial to official - I had in any case to make a full wipe, so better wait. Is there any hint how long it will take?

1 Like


Meanwhile you can try a non too invasive de-google option :slight_smile:

Thank you, looks good! But my old Note does still works, only small problems like loosing my stored contact data - but which can be restored on the way. So I’m waiting for the LOS and hoping there will be an updated Nanodroid Patcher as well soon.

1 Like

WoW, I just saw now on LineageOS download link, lineage-18.1 for FP2, so i guess we can expect lineage-18.1 for FP3 anytime on the coming days. lineageOS 18.1 is going official for FPs, YESSSSS. :grinning: