Problems with USB OTG on lineageOS 14.1 (offical)

For me that looks like a problem of the kernel …

These diagnostics are dependent on what you actually connect to the phone.

When I connect my wireless mouse and keyboard dongle, nothing happens (although mouse and keyboard work).
When I connect my NTFS stick, however …

The thing is with the unoffical version I was able to detect and use an Atmega32U4 as an HID-device to control my phone and now I`m not…
I´m not even able to flash the normal fairphone os … I wipe everything and want to flash the original rom and twrp says the zipfile is damaged… Don´t know what to do…

My first guess is, you downloaded the file again to make sure it isn’t really damaged.

My second guess is, you are using the wrong file.
To install the current Fairphone OS in TWRP, you need the OTA files from here (note that you currently need to install version 1.13.0 first and then install the update from 1.13.0 to the current version) …

If you got the file from the “Manually install Fairphone OS” page instead, it will not work with TWRP. To install it manually means to follow the steps on that page (basically you boot your phone into fastboot mode and then start a script on your PC which uses fastboot to flash the OS to the phone) …

1 Like


is this true? So it maybe won’t work with the new screens for devices sold since summer? Or can you workaround from adb on your desktop?

I don’t know, I don’t use Fairphone OS.
I just looked at the page and noticed that 1.13.0 is the newest version they offer a complete OTA install file for, everything else are just update files from 1.13.0 to newer versions or from already installed newer versions to newerer versions.

As I see it, it wouldn’t have to … You don’t boot 1.13.0, you stay in TWRP and install the update file from 1.13.0 to the current version over the installed 1.13.0, and then you have support for the new screen.

If in doubt, there’s still the manual installation via fastboot, there’s a complete current version install file for that.

1 Like

USB Host works for me on lineage. I didn’t test many devices, but USB stick e.g. works fine.


Please post logcat and dmesg after inserting your USB devices.

I changed my os to the normal fairphone os and now my hid-pcb seems to work just perfect again…
Could it be that the drivers for Atmega32U4 were not installed or whatever?
Thanks for your response!!

@Cherry97, are you sure you mean USB OTG? Because this suggests you use the USB back connector. This evening I tried many things for about an hour to get the USB back connector (5 pogo-pins) working. My final conclusion was that it would probably be LineageOS. I’m still using 20171016 (didn’t know it had gone official), but this probably didn’t change. Is there anything I could do to diagnose within LineageOS why it doesn’t work? Or perhaps there is a driver missing? Logcat & dmesg don’t seem to do anything when plugging in something into the attached USB port.
I will update to the latest LineageOS when I have more time BTW, and re-test.

1 Like

Yeah you are right I used the back connector :slight_smile: but isn’t that also otg, I mean FP is in host mode to handle my device ? :slight_smile:

FP2 is in host mode usually only with a special USB-OTG-Adapter.

Any news about a fixed lineageOS? Or any idea his we can get these things fixed?

1 Like

… so perhaps just the new modem files are needed? Should be coming soon I guess.

1 Like

but also with the special update the phone is sometimes crashing (with the PCB-attached) …

I think somehow the FP2 can´t handle the serial communication sometimes… or a task is crashing which is related to the serial communication …

Maybe it´s about baud-rate?

What I have noticed:

-> FP is not rebooting until serial communication has started
(PCB has voltage -> draws current)
-> FP is not rebooting if USB-cable is attached (connected PC)
-> on any OS version the FP didn´t reboot until I rebooted it once or the battery was low an it

They came out today … updated my phone with it … everything works normal but the back-pcb is still not recognized …

As it is working with the 18.3.1-Update - is there a way easily to find the differences between that image and lineage-os? To get a point where to look?

1 Like

it´s only working good with the special update…
So 18.2.0 is the image to look at !! :slight_smile:

EDIT: i flashed Lineage again and like Drezil says the PCB is still not recognized …
but i looked into last_kmsg and there…

usb 1-1: New USB device found, idVendor=2341, idProduct=8037
usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
usb 1-1: Product: Arduino Micro
usb 1-1: Manufacturer: Arduino LLC

EDIT: this maybe could be the fix:

EDIT: is not added to handheld_core_hardware.xml

so does adding these lines in those files fix the problem?

what exactly should change? we should then also update the lineage-os-packages on github :slight_smile:

1 Like

No nothing changed … :confused:

We do have the file system/etc/permissions/