Problems with USB OTG on lineageOS 14.1 (offical)

it´s only working good with the special update…
So 18.2.0 is the image to look at !! :slight_smile:

EDIT: i flashed Lineage again and like Drezil says the PCB is still not recognized …
but i looked into last_kmsg and there…

usb 1-1: New USB device found, idVendor=2341, idProduct=8037
usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
usb 1-1: Product: Arduino Micro
usb 1-1: Manufacturer: Arduino LLC

EDIT: this maybe could be the fix:

EDIT: is not added to handheld_core_hardware.xml

so does adding these lines in those files fix the problem?

what exactly should change? we should then also update the lineage-os-packages on github :slight_smile:

1 Like

No nothing changed … :confused:

We do have the file system/etc/permissions/


I didn’t even know that there’s a USB back connector on the FP2 :slight_smile:
Maybe this commit broke it…


Yeah that’s true but in handheld_core_hardware.xml it was missing… :slight_smile: thought this would solve the problem…

Hmm that could be possible … How to fix?

I checked also last_kmsg and there the uC gets noticed as Arduino Micro, which is correct, so I think the cummincation would basicly work but something blocks it…

Herr you can see the last logs with logcat:

For me it does not even recognize anything in logcat…
Latest lineage ota

Can you compile a test-image for us so that we can see if this was indeed the problem? Or if it is something else?

here’s a boot.img that has the commit reverted

Flash with fastboot:
fastboot flash boot FP2_boot_back_usb.img

1 Like

will try that, thanks.

1 Like

that fixed it. The back-usb now recognizes the chip. :slight_smile:


1 Like

How can I use this ? :slight_smile:

hmmm. good and bad. I disabled this, as I think it reduces power consumption quite visibly.

I`m now able to connect to the DIY-shield but after opening a serial connection and unplugging the usb-cable from the FP2, it´s rebooting…

EDIT: I`m trying to log the problem but can´t find out ( or better I can´t see the problem) in the last_kmsg…

Maybe someone could have a look at => IT <= …

I just noticed, that Bluetooth is not recognized anymore…
Is it my phone or could the patch have something to do with it.

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.