Problems with starting and unlocking the phone FP1(U)

I have been experiencing worrying issues with my Fairphone lately. This issues started before I installed Kola Nut 1.8.5. I was hoping that the update would solve the problem but it didn´t.

I have 3 main problems that I think are connected to each other.

1) If I turn off the phone (as I normally do before I go to sleep), the morning after when I try to turn it on the Fairphone OS launcher takes around 5 minutes (this has been the case for my phone pretty much since I bought it in December 2014 but I think it´s not normal) and after the start process is completed I try to unlock my phone and most of the times (since the last 2 months it happens 95% of the times) I get the “Process system not responding” message and then I tap on any of the two options and both result in a black screen which later results in an automatic reboot. The worse thing is that it is an endless loop, or best case scenario I get to use the phone after 3/4 reboots which is frustrating, it consumes an insane ammount of battery (sometimes around 25% or more) and the phone reaches worrying temperatures.

At the moment my solution to this problem is never turning my phone off, but I don´t like that as my phone is consuming battery even on Plane Mode (I know it´s almost neglectable but still…).

2) I also get the “Process system not responding message” or the “Fairphone OS not responding” message when I make a mistake while unlocking the phone. The phone doesn´t give me a second chance to type the correct password (or repeat the pattern in case I have that as a locking method). This often results in an annoying waiting time (around 10 minutes) until I can try to unlock the phone again and sometimes the phone becomes unusable and I have to remove the battery and reboot the phone.

In order to solve this I tried changing the locking method many times (different patterns and passwords) but it didn´t work, in the sense that the problem is still there: it works great as long as I´m not clumsy with my screen when I´m unlocking the phone.

3) Something is going on with Play Store App… I know this because when I installed the Kola Nut update a new version of Play Store showed up (I know that because it had a different design) but it inmediately changed back to the version I had before without me touching anything. The main consequence of that is that my phone struggles when I want to go to Google Play>My apps>Installed. Which makes it impossible for me to see the list of pending updates on my apps which is quite annoying, although it doesn´t stop me from updating the apps as the phone does automatic updates when I have an available WiFi network.

Overall, I suspect that something is going on with Google Play Store and also with the power button on the phone. I guess it could also be that one of the apps I installed at some point ( I have no idea which one it can be as I have more than 30 installed at the moment) has caused trouble to my phone.

Any help would be much appreciated, specially within the next ten days as I´m gonna be on holidays for an extended period of time and I will need to use my phone regularly for various purposes and I´m quite worried about it at the moment. SORRY FOR THE LONG POST :pensive:

1 Like

This sounds like quite serious problems. Maybe there is somethink wrong with storage on the device.
Anyways: I would recommend a full system reset. Did you do the Storage Upgrade? If not, that would be a perfect oportunity.

If the problems persist, contact support. Seems you have very serious problems, that may be related to hardware defects.

See here how to reset you phone:

1 Like

I haven´t done the Storage Upgrade. I´ll try that and I might try the full system reset. Thanks for the tip!

I forgot to mention something important about the first point, which adds even more mistery to my phone´s problems.

If I set the alarm for the morning before I turn off the phone the night before, the next morning I can touch on the screen to turn-off the alarm and the Fairphone starts normally. Besides, after some time I can unlock the screen with ease and the phone works great.

I must say that appart from the starting issues the phone works great in general, that´s why I´m so confused about these problems.

On reason might be that parts of the Fairphone software are already running then (since otherwise, it would be impossible to sound and turn of the alarm.

You mean that the Alarm app partially initializes the Fairphone OS and this way, all the “standard” turn on procedure issues are bypassed?

I have no idea, it is the only difference to a cold boot i can imagine.

Have you performed a full reset yet?

Not yet. I´m gonna think about it because I´m leaving for holidays soon and I´m not willing to start all over again. I might take another phone that I have and reset this one after holidays and install everything again.

By the way, I had one question. What does the Storage Upgrade do? I´ve read comments about it in the forum but I never checked what it actually does and why it is recomendable.

Good idea to bring a backup if you travel with an unsteady phone.

Storage Upgrade is only necessary if you do not have a FP1U. The FP1 came originally with a somewhat unusual partition layout: the storage was in two parts: One for apps, that is very small, and a second one, like an internal sd card, that is larger.
Many users, including me, found the app-partition way to small. The storage upgrade units the internal partition into one that can be used for apps, app data and media. This is the usual way to do it in modern android devices.

Alright. I have the FP1U because I bought it last Christmas, so I won´t need that. :heavy_check_mark:

I have exactly the same issues as @andyphone on my FP1, except I didn’t verify the Play Store issue. The issues 1 and 2 started about 5 month after I received the phone from the very first batch. When I made a hard reset the phone was working without issues again for some month. Then the same signs of getting slow when starting the phone or entering a wrong pin. Finally it didn’t even start for the alarm clock anymore - which got me into some troubles for oversleeping :- ) Even if there are no SIM cards or SD card in the phone the same issues occur.

I figured that restoring a backup that I did in recovery mode (userdata file) after the hard reset (and some basic configuration and app installations) also solved the issue for some weeks. But the period that a backup restore is solving the problem gets shorter when I use a more recent backup (with more apps installed) - from several month in the beginning to some weeks currently.

So it seems that something is “jamming” the phone over time and making the system process very busy. Whatever it is seems to accumulate over time and finally brings the phone to a full stop (=cpu busy and phone therefore pretty hot around top area). Whatever causes the problems, it is something within the information that is stored in the userdata backup from recovery mode.
As the phone is working normally once it started successfully I could imagine that it is related to the initialisation process and the user/password verification, but I am no expert on this issues.

Some more information about my phone and usage: I got a first revision Fairphone, all OS updates applied (but during all the former versions no update ever changed this behaviour, currently on 1.8.5), partitioning is still the original divided one (no storage unification done), I wasn’t able to track the issue to any single app although it cannot exclude this possibility, Google apps installed, system memory and phone memory have enough free space, I am using 2 SIM cards, no external SD card.

It would be great if someone could give us some hint on how to fix this because it’s extremely annoying if you have to reset your phone every couple of weeks and doing all the configuration stuff again…

Thanks for your suggestions!

1 Like

After some investigation I got some hint what might cause the problem of the long delay when entering a wrong pin or the first right pin after a wrong one.
With “adb logcat” I checked the /dev/log/system output during these unlock intents. When everything works fine (correct pin) the log file has about 6000 lines (or 0.5 MB). But when I enter a wrong pin the log output is totally filled with the following line and grows to 40000 lines (6.5 MB):

V/ActivityManager( 528): Broadcast: Intent { flg=0x10$PolicyAdmin } ordered=false userid=0

The first correct login attempt is filled up to the same size with this line:

V/ActivityManager( 528): Broadcast: Intent { flg=0x10$PolicyAdmin } ordered=false userid=0

I am not an Android programmer but as far as I found out the messages ACTION_PASSWORD_FAILED and ACTION_PASSWORD_SUCCEEDED are correct for a failed login attempt and for the first succeded login attempt after failed ones. But why are these “Intents” or messages repeated so often? I can imagine that such a huge load of messages can totally slow down the phone. Maybe something similar happens when starting the phone (as this issue was mentioned above).

For me this looks like a software problem or configuration problem related to the Android Mail App and failed unlock intents (if I can interpret those messages correctly).

Is there anyone in this forum who knows more about Android log files and the Mail App in order to interpret the log messages and give some hint for a possible solution?
Hopefully there is one…


Hi MartinKrenn,
I have a similar problem with the FP1U! A couple of weeks ago the phone started getting slow / applications crashed, etc… But I do not have a unlock password. Just the display slide. After a hard reset with a clean install I force the same issue after about two weeks. So I guess it’s a problem with the internal memory. (I’ve tried fairphone OS and Android stock OS, no difference).

I have opened a support ticket over a week ago… But I haven’t heard anything since then… I believe they’re very busy…
But it seems to me, that your problem is very similar (Fairphone OS crashed, etc.)


@Kangaroo since the investigation of @MartinKrenn suggests this is related to the build-in Email App: Do you have that app configured to access your email?

Because if so, you could “remove” your accounts from that app and switch to K9mail for example to see if this is related.

1 Like

Just wanted to chime in to say that I’ve had the EXACT same issues.

  1. Telephone booting VERY slowly

  2. process System not responding, often resulting in a hard reboot

  3. Play Store not being able to display my installed apps. Though I believe I already had that issue prior to 1.8.5.

  4. Not mentioned by you but my bluetooth also started acting up, not wanting to turn on. As I had just purchased a €50 headset you might understand that this annoyed me.

Issue 4 was what got me to (finally) cave and format the thing as well as reflashing the firmware. Due to the backup functionality not working for me I ended up erasing everything. Google and my corporate exchange account took care of saving all my contacts. As for the rest, let’s just say that after the fourth wipe I was already used to manually restoring everything else.

It seems to work fine now. Boot times have returned to normal, bluetooth is usable once again and the Play Store now shows My Installed Apps as it should. However I dare not install any apps unless I absolutely need them. See my next post for specifics.

EDIT: As promised a bit more information about my phone prior to meltdown:
-FP1U, version 1.8.5 installed
-Google apps installed, synced to my Gmail.
-Corporate exchange account using default mail and calendar app.
-Security code on lock screen.
-A ton of apps installed, though not as much as the average smartphone user. Installed apps included Republique (lost my savegames due to the wipe, dammit), Minecraft, ConnectBot, Youtube, SkyMaps, Office, OneDrive, OwnCloud (corporate), WifiAutomatic (automatically disables WiFi). Nothing special really.
-As it got slower I started removing apps with an account on my phone (Office, OwnCloud).
-One other thing, I rarely turn my phone off. I use the alarm clock feature which screws up Google sync when the phone is switched on by the alarm clock.

-Not being able to view My Installed Apps in Google Play
-Phone taking longer than usual to validate security code when unlocking.
-Phone boot sequence took increasingly longer as time progressed.
-Near the end bluetooth started acting up, not wanting to connect or outright refusing to enable the bluetooth adapter.
-In the last week or so, it was almost impossible to get it to unlock after booting it up. 5 minute delays between pushing the power button and the lock screen actually showing up.

Hi all,
as I was guessing that the issues are related to the Android Mail app I tried to remove my accounts from the app (corporate exchange accounts with security policies). @ben suggedted the same. But this didn’t make any change - same slow unlocking when entering a wrong pin. So it’s not that easy.
I have to mention that I didn’t get rid of the security policy settings (still needed to use pin unlock). This could be due the corporate mail account not being deleted completely (which would explain the ongoing behaviour) or other policies still in place (maybe from VPN as @Teejoow mentioned, or whatelse could it be?).
I still don’t think that it is a hardware issue, because the strange recurring line in the logfiles points to a software related issue. Anyway, what else do we have in common in our usage or configuration of our phones?
For my part:

  • Android Mail with corporate exchange account with security policies
  • VPN configured but seldom used
  • K9 installed for other mail accounts
  • several social media apps
  • pin unlock
  • battery mood screen when locked
  • fairphone os (several versions with same issue)
  • google apps installed but only sometimes a google account configured with the phone
  • every google access to phone denied (whatever was deselectable in the settings)
  • FP1, divided partitioning

Can anybody think of other related configurations/programms? What do we have in common?

@Kangaroo: the type of unlock mechanism (pin, slide, pattern) doesn’t seem to matter, if you have the same problem - but I didn’t experience phone crashes (except from the whole phone not starting up) - my issues are specifically when unlocking with wrong pin or when starting the phone (same as @andyphone described)

@Teejoow: please tell us, if you think the phone keeps working fine (maybe after some weeks)

1 Like

Sure, I’ll keep you guys in the loop :slight_smile:

I formatted my phone July 23, so that’s two weeks without any noticeable slowdown so far. To be clear, I have not restored any backups, just a clean install with Google restoring my contacts.

This is my phone in its CURRENT state:
-FP1U, update 1.8.5 installed.
-Google apps, connected to my Gmail account.
-Phone is synced with corporate exchange account, using standard mail app.
-4 other apps installed; Fritz WLAN (free app with push button WPS support!), Banking app, Firefox and Google authenticator.
-As mentioned, I have a security code in place. This is a requirement when using VPN connections. I occasionally connect to my private VPN.

I’ll also edit my previous post with details about my phone’s setup prior to meltdown.


Wow! thanks for all the feedback, I´ll look into all your suggestions in September, when I´m back from holidays. I´ll let you know whether I manage to fix the issue or not.

@MartinKrenn made me aware of this thread. Thanks. I’ve, too, been experiencing severe issues with the screen unlocking that results in a system crash and ever longer waiting times before the system reboots and finally unlocks the screen.

I’m on OS 1.8.5, I’ve done the storage upgrade. I don’t use the pre-installed FP email app, so I don’t think it has anything to do with the issues in my case, at least. I use the gmail app instead.

What I’ve been noticing is that the problem get increasingly severe the longer the phone is on. I, too, switch my phone off at night. I then switch it on around 8am. In the evenings, the phone then usually almost comes to a complete stop. Everything is slow. Even the clock freezes and tells me the wrong time. I use the clock widget on my home screen. The time it tells me differs from the time I can see in the top right corner of the screen and both times don’t correspond with the actual time. So, something really seems to be clogging up my system.

I, too, experience extreme increases in temperature; especially around the are where the camera is located. I assume that’s where the CPU must be located, too.

Other than the aforementioned, I’ve got installed a handful of apps:

  • Whatsapp, WeChat, Line, Skype
  • Astrill VPN (which I don’t use often on my phone)
  • Google Maps, Google Authenticator, Google Notes
  • Soundcloud

That’s pretty much about it. I really hope the root for our issue can be found because, frankly, my phone is hardly usable these days :frowning:

1 Like

Hi all!
I did some more investigation on our common issue (as my phone failed to start again). After restoring an older backup via the recovery mode everything works fine as usually. I did this recovery several times before when my phone crashed due to the same issue.
But doing the check with “adb logcat” as I did when the phone was having the delay while unlocking (see my post from 4 days ago) it turns out that the same two suspicious lines are repeatedly shown again. But this time just 31 repetitions (not about 40000 as before) and so the phone doesn’t delay or freeze. 31 repetitions isn’t perfect either, but you don’t notice it.

Right now I am pretty sure it has something to do with the security policy (most probably by the corporate exchange account). I still don’t have a clue why those “broadcast intents” keep repeating (and most probably growing at some point), but maybe there is someone out there who knows more about such behaviour of the security policies.

Might it be an issue with a specific configuration of the security policy settings on the corporate exchange server? (just guessing) On the other hand I was using two different exchange servers over the run of the last year (different companies) and I had the issue with both.

Removing the exchange account (and the device administrator) doesn’t make any difference: still 31 lines of repeating log messages.

Any suggestions?

1 Like