Official LineageOS 19 for Fairphone 3/3+

After testing the unofficial 19.0 version for quite some time, we are finally ready to go official.

Thanks and special mention to @dk1978 for the continuous support and help throughout so far. Also special thanks to @Max_S, @k4y0z and @sooorajjj for their initial contributions.

My special mention to @z3ntu for helping me whenever I approached.

Let’s collect and discuss any potential issues, blockers and feature requests(from device side) in this topic. Use Official bugreport channel to report bugs.

Now that we have Official Android 11 FPOS released, we shall:

  • Update kernel with QC security patches as soon as it is released, with AOSP monthly ASB patches as soon as we can backport them to our kernel.
  • Update the proprietary blobs and firmware files as soon as there is a new FPOS release.

Here are the collection of relevant external links:

Thanks to all users for your support. See you all soon with LineageOS 20!



Changelogs for 20220627 release:

  1. Update blobs and firmware from 8901.4.A.0010 release
  2. Merge tag(LA.UM.10.6.2.r1-02200-89xx.0) corresponding to April SPL for kernel.

Kernel changes for June SPL will be available in next release.


A really big thank you to you, @dk1978, @z3ntu as well as @Max_S, @k4y0z and @sooorajjj for making this work!

I’m running with a locked bootloader and my first attempt for a “dirty” upgrade via adb sideload (see Upgrade LineageOS on FP3 | LineageOS Wiki) resulted in a reboot to recovery with a request to perform a factory reset for getting forward. When transitioning from 17.1 to 18.1 this worked smoothly. Before I proceed, I’d like to know whether other have a similar challange or whether something is strange with device!?

1 Like

Just a quick note here: The download link is not correct. It is the one for the default LOS. Instead, this link should be used: FP3

I get no response (vibration) from the fingerprint reader.
In the menu I can’t add a new one nor delete the old one.
The prompt “are you sure” pops up, after confirmation the fingerprint turns gray and turns white next time I open the menu.
+ Add Fingerprint is grayed out

Try to reboot on Iode it helped. after that fingerprint seem to be better working than ever before…

1 Like

Oh, no, my uptime! :wink:
You where right, easy fix and I should have tested that- thanks.


Thanks. I have corrected the hyperlink.

1 Like

Just tried the LOS 19.?. It seems to be a 19.0, as said in the text, the links says 19.1
And it looks like it’s 19.0, as it’s SDK31? Tried to install some gapps (which I depend upon), and there seems to be none for SDK31. Only SDK32, which seems to be 19.1?

Since LOS 19 there is no distinction between 19.0 or 19.1 anymore. See Changelog 26 - Tailored Twelve, Audacious Automotive, Neat Networking, Devoted Developers – LineageOS – LineageOS Android Distribution

Except for SDK. 19.0 is 12 is SDK 31, 19.1 is 12L is SDK 32…
So, there’s some difference left

Hi. I just wanted to give it a try, but it seems that opengapps does not have a version for Android 12 yet. Is it possible to do a dirty upgrade using “mind the gap” instead?

I’ve been trying this also. It looks like this is the equivalent of Android 12, which is SDK 31. I could not really find “mainstream” gapps for this SDK
Opengapps/Mindthegapps are either Android 11 or Android 12L (which is LOS 19.1), with SDK 32

So, I hope going officially official will bei SDK32 on monday :wink:

Maybe the GApps working on FP4 with LOS will work?

Or this

Indeed, at least litegapps offer packages for SDK31, so they should work

Are you sure it is SDK31? Because the sources say it’s 32.

Yes, quite sure, as the install script says its SDK31. I did not boot it, though, as I did not dare to risk a factory reset as I need my device.
But OpenGapps as well as mindthegapps both state the installed LOS is SDK31, not 32

I actually flashed gapps on top on LOS 19.1 with success.
Had to go with 12.1 version of NikGapps.

Worth noting that LOS recovery won’t be able to flash the zip (well in my case I could not), so you’ll have to flash twrp right after LOS install to successfully flash it.

What do you exactly mean by “LOS recovery won’t be able to flash the zip”? Does the adb sideload result in an error, or does the sideload work, but the result won’t boot? I can’t boot my “dirty upgrade” yet…

Sorry I lacked precision.

In my case LOS recovery ADB sideload feature would throw an error, I don’t recall exactly but I think it was about not being able to mount /root. Installation aborted everytime.

I followed various “how to fix blabla exact problem as I have” tutorials involving wiping dalvik cache, formatting data etc. without success. Turns out flashing the zip through TWRP ADB sideload went flawlessly.

What do you call dirty upgrade, did you upgrade from 18.1 ? Did you build 19.1 yourself, is it signed ?

1 Like